summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-02-28 15:36:43 +0000
committerYixun Lan <dlan@gentoo.org>2015-02-28 15:36:43 +0000
commitc8328e1b9c7badf2b5943ccde5ea824a10faa982 (patch)
treea18758fb708f58b36748847f54035f6227124777 /app-i18n/ibus
parentMark libsolv and zypper for removal in 30 days (diff)
downloadgentoo-2-c8328e1b9c7badf2b5943ccde5ea824a10faa982.tar.gz
gentoo-2-c8328e1b9c7badf2b5943ccde5ea824a10faa982.tar.bz2
gentoo-2-c8328e1b9c7badf2b5943ccde5ea824a10faa982.zip
version bump, drop old
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-i18n/ibus')
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/ibus-1.5.10.ebuild (renamed from app-i18n/ibus/ibus-1.5.9.ebuild)32
2 files changed, 31 insertions, 9 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index eb2a611c390c..e1f3f3378226 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.156 2015/01/19 09:36:21 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.157 2015/02/28 15:36:43 dlan Exp $
+
+*ibus-1.5.10 (28 Feb 2015)
+
+ 28 Feb 2015; Yixun Lan <dlan@gentoo.org> -ibus-1.5.9.ebuild,
+ +ibus-1.5.10.ebuild:
+ version bump, drop old
19 Jan 2015; Pacho Ramos <pacho@gentoo.org> ibus-1.5.9-r1.ebuild:
eautoreconf is needed (#536022 by OGINO Masanori), USE vala needs USE
diff --git a/app-i18n/ibus/ibus-1.5.9.ebuild b/app-i18n/ibus/ibus-1.5.10.ebuild
index c8c0a1b5dcd1..762fe39edb33 100644
--- a/app-i18n/ibus/ibus-1.5.9.ebuild
+++ b/app-i18n/ibus/ibus-1.5.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.5.9.ebuild,v 1.1 2014/11/12 14:31:12 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.5.10.ebuild,v 1.1 2015/02/28 15:36:43 dlan Exp $
EAPI=5
@@ -9,23 +9,31 @@ VALA_MIN_API_VERSION="0.20"
VALA_USE_DEPEND="vapigen"
# Vapigen is needed for the vala binding
# Valac is needed when building from git for the engine
+UPSTREAM_VER=
-inherit bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo vala virtualx
+inherit autotools bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo vala virtualx
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="https://github.com/ibus/ibus/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="deprecated gconf gtk +gtk3 +introspection nls +python test vala wayland +X"
-REQUIRED_USE="|| ( gtk gtk3 X )
+REQUIRED_USE="
+ || ( gtk gtk3 X )
deprecated? ( python )
+ vala? ( introspection )
python? (
${PYTHON_REQUIRED_USE}
|| ( deprecated ( gtk3 introspection ) ) )" #342903
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTRAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ibus/ibus/releases/download/${PV}/${P}.tar.gz
+ ${UPSTRAM_PATCHSET_URI}"
+
COMMON_DEPEND="
>=dev-libs/glib-2.26:2
gnome-base/librsvg:2
@@ -33,7 +41,6 @@ COMMON_DEPEND="
app-text/iso-codes
>=gnome-base/dconf-0.13.4
x11-libs/libnotify
-
gconf? ( >=gnome-base/gconf-2.12:2 )
gtk? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
@@ -64,8 +71,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/intltool
virtual/pkgconfig
nls? ( >=sys-devel/gettext-0.16.1 )
- vala? ( $(vala_depend) )
- gnome-base/gconf"
+ vala? ( $(vala_depend) )"
# stress test in bus/ fails
# IBUS-CRITICAL **: bus_test_client_init: assertion `ibus_bus_is_connected (_bus)' failed
@@ -96,10 +102,20 @@ pkg_setup() {
}
src_prepare() {
+ # Upstream's patchset
+ if [[ -n ${UPSTREAM_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_OPTS="-p1" \
+ epatch "${WORKDIR}"/patches-upstream
+ fi
+
# We run "dconf update" in pkg_postinst/postrm to avoid sandbox violations
sed -e 's/dconf update/:/' \
-i data/dconf/Makefile.{am,in} || die
use vala && vala_src_prepare
+
+ eautoreconf
}
src_configure() {