summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-09 19:33:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-09 19:33:27 +0000
commit499011f31b8cf2b9cbdb78339ab05f13e845c0cb (patch)
treef4e3034e7affe3eddbc30725c14ae424f523b20a /app-i18n/ibus
parentVersion bump (thanks Andreas Sturmlechner, bug 407485) (diff)
downloadgentoo-2-499011f31b8cf2b9cbdb78339ab05f13e845c0cb.tar.gz
gentoo-2-499011f31b8cf2b9cbdb78339ab05f13e845c0cb.tar.bz2
gentoo-2-499011f31b8cf2b9cbdb78339ab05f13e845c0cb.zip
Patch gconf-2.m4 to m4/ directory for eautoreconf wrt #395239 by Mori Rámar
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus')
-rw-r--r--app-i18n/ibus/ChangeLog7
-rw-r--r--app-i18n/ibus/files/ibus-gconf-2.m4.patch49
-rw-r--r--app-i18n/ibus/ibus-1.4.1.ebuild33
3 files changed, 72 insertions, 17 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 91dfb5a1dcea..bb8d9e798ed2 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.104 2012/03/09 19:05:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.105 2012/03/09 19:33:27 ssuominen Exp $
+
+ 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> ibus-1.4.1.ebuild,
+ +files/ibus-gconf-2.m4.patch:
+ Enable introspection by default. Patch gconf-2.m4 to m4/ directory for
+ eautoreconf wrt #395239 by Mori Rámar
09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
-ibus-1.2.0.20100111.ebuild, -ibus-1.3.9.ebuild, -ibus-1.3.9-r2.ebuild,
diff --git a/app-i18n/ibus/files/ibus-gconf-2.m4.patch b/app-i18n/ibus/files/ibus-gconf-2.m4.patch
new file mode 100644
index 000000000000..266a2bf61339
--- /dev/null
+++ b/app-i18n/ibus/files/ibus-gconf-2.m4.patch
@@ -0,0 +1,49 @@
+http://bugs.gentoo.org/395239
+
+--- m4/gconf-2.m4
++++ m4/gconf-2.m4
+@@ -0,0 +1,44 @@
++dnl AM_GCONF_SOURCE_2
++dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
++dnl (i.e. pass to gconftool-2
++dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
++dnl you should install foo.schemas files
++dnl
++
++AC_DEFUN([AM_GCONF_SOURCE_2],
++[
++ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
++ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
++ else
++ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
++ fi
++
++ AC_ARG_WITH([gconf-source],
++ AC_HELP_STRING([--with-gconf-source=sourceaddress],
++ [Config database for installing schema files.]),
++ [GCONF_SCHEMA_CONFIG_SOURCE="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
++ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
++
++ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
++ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
++ fi
++
++ AC_ARG_WITH([gconf-schema-file-dir],
++ AC_HELP_STRING([--with-gconf-schema-file-dir=dir],
++ [Directory for installing schema files.]),
++ [GCONF_SCHEMA_FILE_DIR="$withval"],)
++
++ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
++ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
++
++ AC_ARG_ENABLE(schemas-install,
++ AC_HELP_STRING([--disable-schemas-install],
++ [Disable the schemas installation]),
++ [case ${enableval} in
++ yes|no) ;;
++ *) AC_MSG_ERROR([bad value ${enableval} for --enable-schemas-install]) ;;
++ esac])
++ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
++])
diff --git a/app-i18n/ibus/ibus-1.4.1.ebuild b/app-i18n/ibus/ibus-1.4.1.ebuild
index cd4f51f8a4b6..9fe617e2f790 100644
--- a/app-i18n/ibus/ibus-1.4.1.ebuild
+++ b/app-i18n/ibus/ibus-1.4.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.4.1.ebuild,v 1.5 2012/03/09 14:43:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.4.1.ebuild,v 1.6 2012/03/09 19:33:27 ssuominen Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="python? 2:2.5"
+
inherit confutils eutils gnome2-utils multilib python autotools
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
@@ -13,12 +14,12 @@ SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="dconf doc +gconf gtk gtk3 introspection nls +python vala X"
+IUSE="dconf doc +gconf gtk gtk3 +introspection nls +python vala X"
-RDEPEND=">=dev-libs/glib-2.26:2
+RDEPEND=">=dev-libs/glib-2.26
dconf? ( >=gnome-base/dconf-0.7.5 )
gconf? ( >=gnome-base/gconf-2.12:2 )
- gnome-base/librsvg:2
+ gnome-base/librsvg
sys-apps/dbus[X?]
app-text/iso-codes
gtk? ( x11-libs/gtk+:2 )
@@ -38,7 +39,6 @@ RDEPEND=">=dev-libs/glib-2.26:2
# vala? ( dev-lang/vala )
DEPEND="${RDEPEND}
>=dev-lang/perl-5.8.1
- dev-perl/XML-Parser
dev-util/intltool
dev-util/pkgconfig
doc? ( >=dev-util/gtk-doc-1.9 )
@@ -51,6 +51,8 @@ RDEPEND="${RDEPEND}
RESTRICT="test"
+DOCS="AUTHORS ChangeLog NEWS README"
+
update_gtk_immodules() {
local GTK2_CONFDIR="/etc/gtk-2.0"
# bug #366889
@@ -81,11 +83,13 @@ pkg_setup() {
src_prepare() {
>py-compile #397497
- echo "ibus/_config.py" >> po/POTFILES.skip || die
+ echo ibus/_config.py >> po/POTFILES.skip
epatch \
+ "${FILESDIR}"/${PN}-gconf-2.m4.patch \
"${FILESDIR}"/${PN}-1.4.0-machine-id-fallback.patch
- use gconf || epatch "${FILESDIR}/${P}-no-gconf.patch"
+
+ use gconf || epatch "${FILESDIR}"/${P}-no-gconf.patch
eautoreconf
}
@@ -104,21 +108,18 @@ src_configure() {
$(use_enable python) \
$(use_enable vala) \
$(use_enable X xim) \
- PYTHON="$(PYTHON)" || die
+ PYTHON="$(PYTHON)"
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
- find "${ED}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -exec rm -f {} +
insinto /etc/X11/xinit/xinput.d
- newins xinput-ibus ibus.conf || die
-
- # bug 289547
- keepdir /usr/share/ibus/{engine,icons} || die
+ newins xinput-ibus ibus.conf
- dodoc AUTHORS ChangeLog NEWS README || die
+ keepdir /usr/share/ibus/{engine,icons} #289547
}
pkg_preinst() {