summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-05 15:41:49 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-05 15:41:49 +0000
commit298487829319e0a1269f9d99e3dcd070f7e2e115 (patch)
treee798298486c49e6797f815ea37dc3e85bc384036 /app-i18n/ibus
parentVersion bump (diff)
downloadgentoo-2-298487829319e0a1269f9d99e3dcd070f7e2e115.tar.gz
gentoo-2-298487829319e0a1269f9d99e3dcd070f7e2e115.tar.bz2
gentoo-2-298487829319e0a1269f9d99e3dcd070f7e2e115.zip
Version bumped.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-i18n/ibus')
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/ibus-0.1.1.20081005.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index e94191993eb8..9a11c3b0fd9c 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.8 2008/10/04 14:46:28 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.9 2008/10/05 15:41:49 matsuu Exp $
+
+*ibus-0.1.1.20081005 (05 Oct 2008)
+
+ 05 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-0.1.1.20081005.ebuild:
+ Version bumped.
*ibus-0.1.1.20081004 (04 Oct 2008)
diff --git a/app-i18n/ibus/ibus-0.1.1.20081005.ebuild b/app-i18n/ibus/ibus-0.1.1.20081005.ebuild
new file mode 100644
index 000000000000..94080bbb50be
--- /dev/null
+++ b/app-i18n/ibus/ibus-0.1.1.20081005.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-0.1.1.20081005.ebuild,v 1.1 2008/10/05 15:41:49 matsuu Exp $
+
+EAPI="1"
+inherit multilib
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls qt4"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ dev-libs/dbus-glib
+ qt4? ( || (
+ (
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ )
+ >=x11-libs/qt-4.4:4
+ ) )
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg
+ dev-python/gconf-python"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable qt4 qt4-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bug to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog "2. Set the following in your"
+ elog " user startup scripts such as .xinitrc or .bashrc"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"ibus\""
+ elog " ibus &"
+ elog
+ if ! use qt4; then
+ ewarn "Missing qt4 use flag, ibus will not work in qt4 applications."
+ ebeep 3
+ fi
+ elog
+
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+pkg_postrm() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}