summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-06-01 15:11:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-06-01 15:11:47 +0000
commitaaccf38b278206ad80e6370af0984cb1171eab41 (patch)
tree66c87c8ff21117252453109a513a988e9a004fdd /app-i18n/ibus-table
parentRemove versions that depend on masked/broken libuser (diff)
downloadgentoo-2-aaccf38b278206ad80e6370af0984cb1171eab41.tar.gz
gentoo-2-aaccf38b278206ad80e6370af0984cb1171eab41.tar.bz2
gentoo-2-aaccf38b278206ad80e6370af0984cb1171eab41.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090601.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index c7e8b47368c2..4a44c1f485ec 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.11 2009/05/31 13:24:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.12 2009/06/01 15:11:47 matsuu Exp $
+
+*ibus-table-1.1.0.20090601 (01 Jun 2009)
+
+ 01 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090601.ebuild:
+ Version bumped.
31 May 2009; MATSUU Takuto <matsuu@gentoo.org>
+ibus-table-1.1.0.20090527.ebuild:
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090601.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090601.ebuild
new file mode 100644
index 000000000000..e73387cd4b6e
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090601.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090601.ebuild,v 1.1 2009/06/01 15:11:47 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}