summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-04-03 04:29:20 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-04-03 04:29:20 +0000
commit2a841bf9eeecf76e371e46132fff49e215bbb3e1 (patch)
tree11bdfaf3428fe75219c0fb5f2b6c17764276a59c /app-i18n/ibus-qt
parentVersion bumped. Fixed python dependency, bug #311211. (diff)
downloadgentoo-2-2a841bf9eeecf76e371e46132fff49e215bbb3e1.tar.gz
gentoo-2-2a841bf9eeecf76e371e46132fff49e215bbb3e1.tar.bz2
gentoo-2-2a841bf9eeecf76e371e46132fff49e215bbb3e1.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-qt')
-rw-r--r--app-i18n/ibus-qt/ChangeLog7
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-i18n/ibus-qt/ChangeLog b/app-i18n/ibus-qt/ChangeLog
index e081a8a6501c..685ddc2468d5 100644
--- a/app-i18n/ibus-qt/ChangeLog
+++ b/app-i18n/ibus-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-qt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.6 2010/03/01 10:15:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.7 2010/04/03 04:29:19 matsuu Exp $
+
+*ibus-qt-1.3.0 (03 Apr 2010)
+
+ 03 Apr 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-qt-1.3.0.ebuild:
+ Version bumped.
01 Mar 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
ibus-qt-1.2.0.20091217.ebuild:
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.0.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.0.ebuild
new file mode 100644
index 000000000000..e7e07aaaa83e
--- /dev/null
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ibus-qt-1.3.0.ebuild,v 1.1 2010/04/03 04:29:20 matsuu Exp $
+
+EAPI="2"
+inherit cmake-utils eutils multilib
+
+MY_P="${P}-Source"
+DESCRIPTION="Qt IBus library and Qt input method plugin"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ >=sys-apps/dbus-1.2
+ x11-libs/libX11
+ >=x11-libs/qt-core-4.5:4
+ >=x11-libs/qt-dbus-4.5:4"
+DEPEND="${RDEPEND}
+ >=dev-libs/icu-4
+ dev-util/cmake
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS README TODO"
+
+mycmakeargs="-DLIBDIR=$(get_libdir) -DDOCDIR=/usr/share/doc/${PF} all"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.0.20091217-doc.patch"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake docs || die
+ fi
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS="${CMAKE_BUILD_DIR}/docs/html/*"
+ fi
+
+ cmake-utils_src_install
+}