summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-23 22:57:48 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-23 22:57:48 +0000
commite223c586267c6d728ca8139378a03af100ce90db (patch)
tree75aebc9d3bcd7fb91ec8fe5e09364c42f27f1726 /app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-e223c586267c6d728ca8139378a03af100ce90db.tar.gz
gentoo-2-e223c586267c6d728ca8139378a03af100ce90db.tar.bz2
gentoo-2-e223c586267c6d728ca8139378a03af100ce90db.zip
Version bumped. Fixed QA issue.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild')
-rw-r--r--app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild b/app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild
new file mode 100644
index 000000000000..bae589881849
--- /dev/null
+++ b/app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-chewing/ibus-chewing-0.1.1.20081023.ebuild,v 1.1 2008/10/23 22:57:48 matsuu Exp $
+
+inherit python
+
+DESCRIPTION="The Chewing IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-libs/libchewing-0.3.0.901
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}