summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-08-09 10:44:36 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-08-09 10:44:36 +0000
commit2474c212c830566de59b94a6edaf228ef8e6040a (patch)
treee4112791fda117f3fdc04331de7c334ef41b3fad /app-i18n/fcitx
parentversion bump (diff)
downloadgentoo-2-2474c212c830566de59b94a6edaf228ef8e6040a.tar.gz
gentoo-2-2474c212c830566de59b94a6edaf228ef8e6040a.tar.bz2
gentoo-2-2474c212c830566de59b94a6edaf228ef8e6040a.zip
Version bumped and Fixed SRC_URI.
(Portage version: 2.1-r1)
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/ChangeLog10
-rw-r--r--app-i18n/fcitx/fcitx-3.1.1.ebuild7
-rw-r--r--app-i18n/fcitx/fcitx-3.2.1.ebuild48
-rw-r--r--app-i18n/fcitx/files/digest-fcitx-3.1.12
-rw-r--r--app-i18n/fcitx/files/digest-fcitx-3.2.13
5 files changed, 64 insertions, 6 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 670449f98f06..687ad7d5ed33 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/fcitx
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.15 2006/02/21 20:27:41 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.16 2006/08/09 10:44:36 matsuu Exp $
+
+*fcitx-3.2.1 (09 Aug 2006)
+
+ 09 Aug 2006; MATSUU Takuto <matsuu@gentoo.org> fcitx-3.1.1.ebuild,
+ +fcitx-3.2.1.ebuild:
+ Version bumped, bug 143294.
+ Fixed SRC_URI, bug 126940.
+ Added ~amd64.
21 Feb 2006; Alastair Tse <liquidx@gentoo.org> fcitx-3.1.1.ebuild:
fix bad libXft dep (#123630)
diff --git a/app-i18n/fcitx/fcitx-3.1.1.ebuild b/app-i18n/fcitx/fcitx-3.1.1.ebuild
index be7f51372b0e..0a20c993ed21 100644
--- a/app-i18n/fcitx/fcitx-3.1.1.ebuild
+++ b/app-i18n/fcitx/fcitx-3.1.1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.1.1.ebuild,v 1.5 2006/02/21 20:27:41 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.1.1.ebuild,v 1.6 2006/08/09 10:44:36 matsuu Exp $
DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
HOMEPAGE="http://www.fcitx.org/"
-# The HOMEPAGE and SRC_URI cannot be accessed from outside China :-(
-#SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
-SRC_URI="http://bsdchat.com/dist/dryice/${P}.tar.bz2"
-RESTRICT="nomirror"
+SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-i18n/fcitx/fcitx-3.2.1.ebuild b/app-i18n/fcitx/fcitx-3.2.1.ebuild
new file mode 100644
index 000000000000..70304432abdb
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.2.1.ebuild,v 1.1 2006/08/09 10:44:36 matsuu Exp $
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="truetype"
+
+RDEPEND="|| ( ( x11-libs/libX11 x11-libs/libXrender x11-libs/libXt )
+ virtual/x11 )
+ truetype? ( || ( x11-libs/libXft virtual/xft ) )"
+
+DEPEND="${RDEPEND}"
+src_compile() {
+ econf $(use_enable truetype xft) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ rm -rf "${D}"/usr/share/fcitx/doc/
+ dodoc doc/pinyin.txt doc/cjkvinput.txt doc/fcitx3.pdf
+ dohtml doc/wb_fh.htm
+}
+
+pkg_postinst()
+{
+ einfo "You should export the following variables to use fcitx"
+ einfo " export XMODIFIERS=\"@im=fcitx\""
+ einfo " export XIM=fcitx"
+ einfo " export XIM_PROGRAM=fcitx"
+ einfo ""
+ einfo "If you want to use WuBi or ErBi"
+ einfo " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ einfo ""
+ einfo "Note that fcitx only works in the zh_CN locale."
+}
diff --git a/app-i18n/fcitx/files/digest-fcitx-3.1.1 b/app-i18n/fcitx/files/digest-fcitx-3.1.1
index ae47d820066a..15ecfcd80682 100644
--- a/app-i18n/fcitx/files/digest-fcitx-3.1.1
+++ b/app-i18n/fcitx/files/digest-fcitx-3.1.1
@@ -1 +1,3 @@
MD5 cd871c585dc260ebf48e2bdb5cbe596c fcitx-3.1.1.tar.bz2 2920856
+RMD160 229155ec71deb189ffc52851ee9a242ba9192a5b fcitx-3.1.1.tar.bz2 2920856
+SHA256 011863a2964e64b89f2eabf1f98bed2caf8201e4a998847ffff55098dc7dadaa fcitx-3.1.1.tar.bz2 2920856
diff --git a/app-i18n/fcitx/files/digest-fcitx-3.2.1 b/app-i18n/fcitx/files/digest-fcitx-3.2.1
new file mode 100644
index 000000000000..2a3a32580139
--- /dev/null
+++ b/app-i18n/fcitx/files/digest-fcitx-3.2.1
@@ -0,0 +1,3 @@
+MD5 07be1eaabfb52ad5ce2386e89d4160ae fcitx-3.2.1.tar.bz2 3089016
+RMD160 bacf04d7bdab5e73d13ad0e73e187e5fa678acc9 fcitx-3.2.1.tar.bz2 3089016
+SHA256 f77eacf1326c7764fd2773b18cf64f577a8de41fbbc336da9b5da39e90327325 fcitx-3.2.1.tar.bz2 3089016