summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-04-18 11:02:47 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-04-18 11:02:47 +0000
commitfec6d18927f39d1eefc5fb2520cdc0ee8219e2cd (patch)
tree994a52a9ee3f7edf842e08db693e335e58c525e1 /app-i18n/fcitx/fcitx-3.1.1.ebuild
parentversion bump with mirror (#89474) (diff)
downloadgentoo-2-fec6d18927f39d1eefc5fb2520cdc0ee8219e2cd.tar.gz
gentoo-2-fec6d18927f39d1eefc5fb2520cdc0ee8219e2cd.tar.bz2
gentoo-2-fec6d18927f39d1eefc5fb2520cdc0ee8219e2cd.zip
version bump with mirror (#89474)
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-i18n/fcitx/fcitx-3.1.1.ebuild')
-rw-r--r--app-i18n/fcitx/fcitx-3.1.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/fcitx/fcitx-3.1.1.ebuild b/app-i18n/fcitx/fcitx-3.1.1.ebuild
new file mode 100644
index 000000000000..1ca5323f1738
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.1.1.ebuild,v 1.1 2005/04/18 11:01:48 liquidx Exp $
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+# The HOMEPAGE and SRC_URI cannot be accessed from outside China :-(
+#SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
+SRC_URI="http://bsdchat.com/dist/dryice/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="truetype"
+
+DEPEND="virtual/x11
+ truetype? ( virtual/xft )"
+
+src_compile() {
+ myconf=
+ if use truetype ; then
+ myconf=" --with-xft "
+ else
+ myconf=" --disable-xft "
+ fi
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install()
+{
+ dobin src/fcitx
+ insinto /usr/share/fcitx/data
+ doins data/*.mb
+ doins data/*.dat
+ doins data/*.conf
+ insinto /usr/share/fcitx/xpm
+ doins xpm/*.xpm
+ insinto /usr/share/fcitx/doc
+ doins doc/*.txt
+ doins doc/*.htm
+}
+
+pkg_postinst()
+{
+ einfo "You should export the following variables to use fcitx"
+ einfo " export XMODIFIERS=\"@im=fcitx\""
+ einfo " export XIM=fcitx"
+ einfo " export XIM_PROGRAM=fcitx"
+ einfo ""
+ einfo "If you want to use WuBi or ErBi"
+ einfo " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ einfo ""
+ einfo "Note that fcitx only works in the zh_CN locale."
+}