summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-11 15:33:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-11 15:33:52 +0000
commitddc4600b035a21ca9777555d83f1f3362aba32a9 (patch)
tree67d1abc5fb297b6b2b83af05df9ffa9b2ee06337 /app-i18n/enca
parentStable on alpha, bug #287913 (diff)
downloadgentoo-2-ddc4600b035a21ca9777555d83f1f3362aba32a9.tar.gz
gentoo-2-ddc4600b035a21ca9777555d83f1f3362aba32a9.tar.bz2
gentoo-2-ddc4600b035a21ca9777555d83f1f3362aba32a9.zip
Version bump.
(Portage version: 14568-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/enca')
-rw-r--r--app-i18n/enca/ChangeLog8
-rw-r--r--app-i18n/enca/enca-1.0.ebuild23
-rw-r--r--app-i18n/enca/enca-1.11.ebuild39
-rw-r--r--app-i18n/enca/enca-1.9.ebuild18
4 files changed, 46 insertions, 42 deletions
diff --git a/app-i18n/enca/ChangeLog b/app-i18n/enca/ChangeLog
index 07816bb2f5fc..029a6f2f1ee6 100644
--- a/app-i18n/enca/ChangeLog
+++ b/app-i18n/enca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/enca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.40 2009/09/12 17:02:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.41 2009/10/11 15:33:52 arfrever Exp $
+
+*enca-1.11 (11 Oct 2009)
+
+ 11 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -enca-1.0.ebuild, -enca-1.9.ebuild, +enca-1.11.ebuild:
+ Version bump.
12 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
enca-1.10.ebuild:
diff --git a/app-i18n/enca/enca-1.0.ebuild b/app-i18n/enca/enca-1.0.ebuild
deleted file mode 100644
index 2da05e8d44cc..000000000000
--- a/app-i18n/enca/enca-1.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.0.ebuild,v 1.9 2009/09/11 17:25:26 patrick Exp $
-
-DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
-HOMEPAGE="http://gitorious.org/enca"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc64 x86"
-IUSE=""
-
-DEPEND=""
-
-src_compile() {
- econf || die "Configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}
diff --git a/app-i18n/enca/enca-1.11.ebuild b/app-i18n/enca/enca-1.11.ebuild
new file mode 100644
index 000000000000..6dc8c323c2c5
--- /dev/null
+++ b/app-i18n/enca/enca-1.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.11.ebuild,v 1.1 2009/10/11 15:33:52 arfrever Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND=">=app-text/recode-3.6_p15"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-librecode=/usr \
+ --enable-external \
+ $(use_enable doc gtk-doc)
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ pushd tools > /dev/null
+ $(tc-getBUILD_CC) -o make_hash make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-i18n/enca/enca-1.9.ebuild b/app-i18n/enca/enca-1.9.ebuild
deleted file mode 100644
index 1a579c4280f0..000000000000
--- a/app-i18n/enca/enca-1.9.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.9.ebuild,v 1.17 2009/09/11 17:25:26 patrick Exp $
-
-DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
-HOMEPAGE="http://gitorious.org/enca"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-
-src_install() {
- make DESTDIR=${D} install || die
-}