summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-12 22:59:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-12 22:59:56 +0000
commit3b1eb23c80b337d1cedc144d654da89f880a97ba (patch)
treebac3278fdb07d671f1e37e30160a62697f57713a /app-i18n/enca
parentVersion bump. (diff)
downloadgentoo-2-3b1eb23c80b337d1cedc144d654da89f880a97ba.tar.gz
gentoo-2-3b1eb23c80b337d1cedc144d654da89f880a97ba.tar.bz2
gentoo-2-3b1eb23c80b337d1cedc144d654da89f880a97ba.zip
Version bump.
(Portage version: 14816-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/enca')
-rw-r--r--app-i18n/enca/ChangeLog8
-rw-r--r--app-i18n/enca/enca-1.12.ebuild39
-rw-r--r--app-i18n/enca/enca-1.9-r1.ebuild32
3 files changed, 46 insertions, 33 deletions
diff --git a/app-i18n/enca/ChangeLog b/app-i18n/enca/ChangeLog
index 97718b71df10..e3ff306687d6 100644
--- a/app-i18n/enca/ChangeLog
+++ b/app-i18n/enca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/enca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.47 2009/11/03 18:37:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/ChangeLog,v 1.48 2009/11/12 22:59:56 arfrever Exp $
+
+*enca-1.12 (13 Nov 2009)
+
+ 13 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -enca-1.9-r1.ebuild, +enca-1.12.ebuild:
+ Version bump.
03 Nov 2009; Raúl Porcel <armin76@gentoo.org> enca-1.10.ebuild:
arm/ia64/sparc stable wrt #288568
diff --git a/app-i18n/enca/enca-1.12.ebuild b/app-i18n/enca/enca-1.12.ebuild
new file mode 100644
index 000000000000..d9f841fbfe56
--- /dev/null
+++ b/app-i18n/enca/enca-1.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.12.ebuild,v 1.1 2009/11/12 22:59:56 arfrever Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND=">=app-text/recode-3.6_p15"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-librecode=/usr \
+ --enable-external \
+ $(use_enable doc gtk-doc)
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ pushd tools > /dev/null
+ $(tc-getBUILD_CC) -o make_hash make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-i18n/enca/enca-1.9-r1.ebuild b/app-i18n/enca/enca-1.9-r1.ebuild
deleted file mode 100644
index 6e2bddd50eaf..000000000000
--- a/app-i18n/enca/enca-1.9-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/enca/enca-1.9-r1.ebuild,v 1.13 2009/09/11 17:25:26 patrick Exp $
-
-inherit toolchain-funcs
-DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
-HOMEPAGE="http://gitorious.org/enca"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~arm alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND=">=app-text/recode-3.6_p15"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- econf \
- --with-librecode=/usr \
- --enable-external \
- $(use_enable doc gtk-doc) \
- || die "configure failed"
- if tc-is-cross-compiler; then
- ( cd "${S}"/tools && $(tc-getBUILD_CC) -o make_hash make_hash.c ) || die "native make_hash failed"
- fi
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-}