summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-03-01 16:31:28 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-03-01 16:31:28 +0000
commitf41d0175c963dddfd8467363e678609c64d79cbd (patch)
tree19155e6d0878b5b8e02c2e5ec11156d15f1248a2 /app-i18n/anthy
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-f41d0175c963dddfd8467363e678609c64d79cbd.tar.gz
gentoo-2-f41d0175c963dddfd8467363e678609c64d79cbd.tar.bz2
gentoo-2-f41d0175c963dddfd8467363e678609c64d79cbd.zip
version bumped.
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog10
-rw-r--r--app-i18n/anthy/Manifest8
-rw-r--r--app-i18n/anthy/anthy-5100.ebuild68
-rw-r--r--app-i18n/anthy/files/digest-anthy-51001
-rw-r--r--app-i18n/anthy/metadata.xml25
5 files changed, 94 insertions, 18 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index d10fb897340c..7993c0307f5f 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/anthy
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.10 2003/11/24 15:02:38 usata Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.11 2004/03/01 16:31:28 hattya Exp $
+
+*anthy-5100 (01 Mar 2004)
+
+ 01 Mar 2004; Akinori Hattori <hattya@gentoo.org> anthy-5100.ebuild,
+ metadata.xml:
+ version bumped.
*anthy-4700 (31 Oct 2003)
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index 4b58a7f38b9a..cbfaf28b5598 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,7 +1,9 @@
-MD5 841eebbf41a57ab7900b5de04019e524 anthy-4300b.ebuild 976
-MD5 65ba669c399cf14ce56239f65d6e86ca metadata.xml 631
MD5 816a686e229c4f25d455629396b081d4 ChangeLog 2401
+MD5 841eebbf41a57ab7900b5de04019e524 anthy-4300b.ebuild 976
MD5 5643fff6b938d4f0074c89f7da56ac73 anthy-4700.ebuild 975
-MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
+MD5 87cf8b487bcd5c25b2a7be461306339c anthy-5100.ebuild 1366
+MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
+MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
MD5 18278f8fc1cafd5d0c0047982c68142f files/digest-anthy-4700 63
+MD5 686b7ab577ef2ec94a328dade8055bb6 files/digest-anthy-5100 63
diff --git a/app-i18n/anthy/anthy-5100.ebuild b/app-i18n/anthy/anthy-5100.ebuild
new file mode 100644
index 000000000000..cc7458427a5d
--- /dev/null
+++ b/app-i18n/anthy/anthy-5100.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-5100.ebuild,v 1.1 2004/03/01 16:31:28 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/8433/${P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy-ss"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy/files/digest-anthy-5100 b/app-i18n/anthy/files/digest-anthy-5100
new file mode 100644
index 000000000000..7f2803278771
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-5100
@@ -0,0 +1 @@
+MD5 cbc460322a9ed8fedf8cc47edbcc9942 anthy-5100.tar.gz 1523744
diff --git a/app-i18n/anthy/metadata.xml b/app-i18n/anthy/metadata.xml
index 8b0641aa313a..02928c10b4ab 100644
--- a/app-i18n/anthy/metadata.xml
+++ b/app-i18n/anthy/metadata.xml
@@ -1,17 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>cjk</herd>
-<herd>emacs</herd>
-<maintainer>
- <email>usata@gentoo.org</email>
- <name>Mamoru KOMACHI</name>
-</maintainer>
-<longdescription>
-Anthy is a free and secure Japanese kana-kanji server. This ebuild
-includes cannadic as a server-side dictionary, so you don't need any
-extra package to run it. You can use anthy with app-i18n/jmode (XIM),
-app-i18n/uim(XIM, GTK+ immodule) and emacs (to enable Anthy support
-for emacs, build this package with emacs USE flag).
-</longdescription>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+
+ <longdescription>
+ Anthy is a free and secure Japanese kana-kanji server. This ebuild
+ includes cannadic as a server-side dictionary, so you don't need any
+ extra package to run it. You can use anthy with app-i18n/jmode (XIM),
+ app-i18n/uim(XIM, GTK+ immodule) and emacs (to enable Anthy support
+ for emacs, build this package with emacs USE flag).
+ </longdescription>
</pkgmetadata>