summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2008-02-04 16:52:38 +0000
committerAkinori Hattori <hattya@gentoo.org>2008-02-04 16:52:38 +0000
commit219924c24ca0bb82abf6623f351c758bfb0fa1a7 (patch)
tree20acdf0a182c22cad5e9acffa4ebfce6985c8dd6 /app-i18n/anthy
parentAdd -r1, builds against wx-2.8 bug #208714, uses webserver template, bug #199... (diff)
downloadgentoo-2-219924c24ca0bb82abf6623f351c758bfb0fa1a7.tar.gz
gentoo-2-219924c24ca0bb82abf6623f351c758bfb0fa1a7.tar.bz2
gentoo-2-219924c24ca0bb82abf6623f351c758bfb0fa1a7.zip
new upstream release.
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog7
-rw-r--r--app-i18n/anthy/anthy-9100e.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 58b5832bbff5..b5432c8b34bb 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.115 2008/02/04 16:47:39 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.116 2008/02/04 16:52:38 hattya Exp $
+
+*anthy-9100e (04 Feb 2008)
+
+ 04 Feb 2008; Akinori Hattori <hattya@gentoo.org> +anthy-9100e.ebuild:
+ new upstream release.
04 Feb 2008; Akinori Hattori <hattya@gentoo.org> -anthy-8700b.ebuild,
-anthy-9100.ebuild, -anthy-9100b.ebuild, -anthy-9100c.ebuild:
diff --git a/app-i18n/anthy/anthy-9100e.ebuild b/app-i18n/anthy/anthy-9100e.ebuild
new file mode 100644
index 000000000000..d9ba0a787720
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100e.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-9100e.ebuild,v 1.1 2008/02/04 16:52:38 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/29142/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+ mkworddic/dict.args.in
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ docinto doc
+ rm doc/Makefile*
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}