summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-22 20:26:47 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-22 20:26:47 +0000
commitebd338d548a6b319626d637be667664737252ae0 (patch)
treea66215a783bd2fed34d731d36cf6fdb9b46ce9a0 /app-forensics
parentThat was indeed the core ebuild and not the plugins ebuild. My apologies, and... (diff)
downloadgentoo-2-ebd338d548a6b319626d637be667664737252ae0.tar.gz
gentoo-2-ebd338d548a6b319626d637be667664737252ae0.tar.bz2
gentoo-2-ebd338d548a6b319626d637be667664737252ae0.zip
Add cron dependency (bug #383385 by Toralf Förster) and bump to EAPI 4.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/chkrootkit/ChangeLog5
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.49.ebuild19
2 files changed, 14 insertions, 10 deletions
diff --git a/app-forensics/chkrootkit/ChangeLog b/app-forensics/chkrootkit/ChangeLog
index 9bc528bbcf09..bbd0c2023458 100644
--- a/app-forensics/chkrootkit/ChangeLog
+++ b/app-forensics/chkrootkit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-forensics/chkrootkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.62 2011/09/18 16:54:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.63 2011/09/22 20:26:47 radhermit Exp $
+
+ 22 Sep 2011; Tim Harder <radhermit@gentoo.org> chkrootkit-0.49.ebuild:
+ Add cron dependency (bug #383385 by Toralf Förster) and bump to EAPI 4.
18 Sep 2011; Markus Meier <maekke@gentoo.org> chkrootkit-0.49.ebuild:
arm stable, bug #382455
diff --git a/app-forensics/chkrootkit/chkrootkit-0.49.ebuild b/app-forensics/chkrootkit/chkrootkit-0.49.ebuild
index 381c5858582c..7a46c6cb6dc4 100644
--- a/app-forensics/chkrootkit/chkrootkit-0.49.ebuild
+++ b/app-forensics/chkrootkit/chkrootkit-0.49.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.49.ebuild,v 1.4 2011/09/18 16:54:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.49.ebuild,v 1.5 2011/09/22 20:26:47 radhermit Exp $
-EAPI="3"
+EAPI="4"
inherit eutils toolchain-funcs
@@ -17,30 +17,31 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
IUSE=""
+RDEPEND="virtual/cron"
+
src_prepare() {
epatch "${WORKDIR}/${P}-gentoo.diff"
sed -i 's:/var/adm/:/var/log/:g' chklastlog.c || die "sed chklastlog.c failed"
}
src_compile() {
- emake CC=$(tc-getCC) STRIP=true sense || die "emake sense failed"
+ emake CC=$(tc-getCC) STRIP=true sense
}
src_install() {
- dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc \
- strings-static || die
- dodoc ACKNOWLEDGMENTS README* || die
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
exeinto /etc/cron.weekly
- newexe "${FILESDIR}"/${PN}.cron ${PN} || die
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
}
pkg_postinst() {
- echo
+ elog
elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
elog
elog "Some applications, such as portsentry, will cause chkrootkit"
elog "to produce false positives. Read the chkrootkit FAQ at"
elog "http://www.chkrootkit.org/ for more information."
- echo
+ elog
}