summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-30 18:43:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-30 18:43:25 +0000
commitba95814568c0b98ca110f74bdad1d7a79ada4e75 (patch)
tree324330a332905c93b291ba5c4a77e9a45f5f2e05 /app-forensics
parentStable for HPPA (bug #454606). (diff)
downloadgentoo-2-ba95814568c0b98ca110f74bdad1d7a79ada4e75.tar.gz
gentoo-2-ba95814568c0b98ca110f74bdad1d7a79ada4e75.tar.bz2
gentoo-2-ba95814568c0b98ca110f74bdad1d7a79ada4e75.zip
Revbump with patch to fix bug #450328. Thanks to Anton Bolshakov <anton.bugs@gmail.com>
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/openscap/ChangeLog9
-rw-r--r--app-forensics/openscap/files/openscap-0.9.3-policy.patch23
-rw-r--r--app-forensics/openscap/metadata.xml2
-rw-r--r--app-forensics/openscap/openscap-0.9.3-r1.ebuild111
4 files changed, 143 insertions, 2 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index 2a3037a55fdf..09af8b8c5cbd 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.20 2013/01/04 22:48:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.21 2013/01/30 18:43:25 hwoarang Exp $
+
+*openscap-0.9.3-r1 (30 Jan 2013)
+
+ 30 Jan 2013; Markos Chandras <hwoarang@gentoo.org>
+ +files/openscap-0.9.3-policy.patch, +openscap-0.9.3-r1.ebuild, metadata.xml:
+ Revbump with patch to fix bug #450328. Thanks to Anton Bolshakov
+ <anton.bugs@gmail.com>
*openscap-0.9.3 (04 Jan 2013)
diff --git a/app-forensics/openscap/files/openscap-0.9.3-policy.patch b/app-forensics/openscap/files/openscap-0.9.3-policy.patch
new file mode 100644
index 000000000000..e1b01271e111
--- /dev/null
+++ b/app-forensics/openscap/files/openscap-0.9.3-policy.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/show_bug.cgi?id=450328
+--- src/XCCDF_POLICY/xccdf_policy.c.orig 2012-12-14 18:13:18.000000000 +0800
++++ src/XCCDF_POLICY/xccdf_policy.c 2013-01-07 22:31:10.417704932 +0800
+@@ -389,8 +389,8 @@
+ __attribute__nonnull__(policy);
+ __attribute__nonnull__(item);
+
+- static bool TRUE = true;
+- static bool FALSE = false;
++ static bool TRUE2 = true;
++ static bool FALSE2 = false;
+ bool result;
+
+ oscap_htable_detach(policy->selected_final, xccdf_item_get_id(item));
+@@ -408,7 +408,7 @@
+ xccdf_item_iterator_free(child_it);
+ }
+
+- assume_ex(oscap_htable_add(policy->selected_final, xccdf_item_get_id(item), result ? &TRUE : &FALSE), NULL);
++ assume_ex(oscap_htable_add(policy->selected_final, xccdf_item_get_id(item), result ? &TRUE2 : &FALSE2), NULL);
+ }
+
+ /**
diff --git a/app-forensics/openscap/metadata.xml b/app-forensics/openscap/metadata.xml
index 889e265b225d..51d5fd284635 100644
--- a/app-forensics/openscap/metadata.xml
+++ b/app-forensics/openscap/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>proxy-maintainers</herd>
<maintainer>
-<email>corentin.labbe@geomatys.fr</email>
+<email>clabbe.montjoie@gmail.com</email>
<name>LABBE Corentin (Montjoie)</name>
<description>Maintainer</description>
</maintainer>
diff --git a/app-forensics/openscap/openscap-0.9.3-r1.ebuild b/app-forensics/openscap/openscap-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..a6f62ef70cff
--- /dev/null
+++ b/app-forensics/openscap/openscap-0.9.3-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.9.3-r1.ebuild,v 1.1 2013/01/30 18:43:25 hwoarang Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python bash-completion-r1
+
+DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
+HOMEPAGE="http://www.open-scap.org/"
+SRC_URI="https://fedorahosted.org/releases/o/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion doc nss perl python rpm selinux sql test"
+#RESTRICT="test"
+
+RDEPEND="!nss? ( dev-libs/libgcrypt )
+ nss? ( dev-libs/nss )
+ rpm? ( >=app-arch/rpm-4.9 )
+ sql? ( dev-db/opendbx )
+ dev-libs/libpcre
+ dev-libs/libxml2
+ dev-libs/libxslt
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ test? (
+ app-arch/unzip
+ dev-perl/XML-XPath
+ net-misc/ipcalc
+ sys-apps/grep )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
+
+ #probe runlevel for non-centos/redhat/fedora is not implemented
+ sed -i 's,.*runlevel_test.*,echo "runlevel test bypassed",' tests/mitre/test_mitre.sh || die
+ sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die
+
+ #According to comment of theses tests, we must modify it. For the moment disable it
+ sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
+ sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die
+
+ # theses tests are hardcoded for checking hald process...,
+ # but no good solution for the moment, disabling them with a fake echo
+ # because encased in a if then
+# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
+# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
+ sed -i 's,.*process_test.*,echo "process test bypassed",' tests/mitre/test_mitre.sh || die
+ sed -i 's,.*process58_test.*,echo "process58 test bypassed",' tests/mitre/test_mitre.sh || die
+
+ #This test fail
+ sed -i 's,.*generate report: xccdf,#&,' tests/API/XCCDF/unittests/all.sh || die
+
+ if ! use rpm ; then
+ sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
+ sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
+ sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
+ sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
+ sed -i 's,^probe_rpm.*_deps_missing=,&disabled by USE flag,' configure || die
+ sed -i 's,.*rpm.*,#&,' tests/mitre/test_mitre.sh || die
+ fi
+ if ! use selinux ; then
+ sed -i 's,.*selinux.*, echo "SELinux test bypassed",' tests/mitre/test_mitre.sh || die
+ #process58 need selinux
+ sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
+ fi
+ #450328
+ epatch "${FILESDIR}"/${P}-policy.patch
+}
+
+src_configure() {
+ local myconf
+ if use python ; then
+ myconf+=" --enable-python"
+ else
+ myconf+=" --enable-python=no"
+ fi
+ if use perl ; then
+ myconf+=" --enable-perl"
+ fi
+ if use nss ; then
+ myconf+=" --with-crypto=nss3"
+ else
+ myconf+=" --with-crypto=gcrypt"
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.la' -delete || die
+ if use doc ; then
+ dohtml -r docs/html/* || die
+ dodoc docs/examples/* || die
+ fi
+ if use bash-completion ; then
+ dobashcomp "${D}"/etc/bash_completion.d/oscap
+ fi
+ rm -rf "${D}"/etc/bash_completion.d || die
+}