summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-07-27 00:50:55 +0000
committerRick Farina <zerochaos@gentoo.org>2013-07-27 00:50:55 +0000
commita03faaf125c7622bcc9b66780352a046fd2cd003 (patch)
treecab6291d35c2b95fe12b7dbd71cf2bb025e76d17 /app-forensics
parentremove old, outdated, etc (diff)
downloadgentoo-2-a03faaf125c7622bcc9b66780352a046fd2cd003.tar.gz
gentoo-2-a03faaf125c7622bcc9b66780352a046fd2cd003.tar.bz2
gentoo-2-a03faaf125c7622bcc9b66780352a046fd2cd003.zip
initial commit of libbfio, imported from pentoo for use with libewf
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libbfio/ChangeLog12
-rw-r--r--app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild31
-rw-r--r--app-forensics/libbfio/libbfio-0.0.20130609_alpha.ebuild27
-rw-r--r--app-forensics/libbfio/libbfio-0.0.20130721.ebuild27
-rw-r--r--app-forensics/libbfio/metadata.xml11
5 files changed, 108 insertions, 0 deletions
diff --git a/app-forensics/libbfio/ChangeLog b/app-forensics/libbfio/ChangeLog
new file mode 100644
index 000000000000..35501e8d8bb4
--- /dev/null
+++ b/app-forensics/libbfio/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-forensics/libbfio
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libbfio/ChangeLog,v 1.1 2013/07/27 00:50:55 zerochaos Exp $
+
+*libbfio-0.0.20130721 (27 Jul 2013)
+*libbfio-0.0.20120425_alpha (27 Jul 2013)
+*libbfio-0.0.20130609_alpha (27 Jul 2013)
+
+ 27 Jul 2013; Rick Farina <zerochaos@gentoo.org>
+ +libbfio-0.0.20120425_alpha.ebuild, +libbfio-0.0.20130609_alpha.ebuild,
+ +libbfio-0.0.20130721.ebuild, +metadata.xml:
+ initial commit of libbfio, imported from pentoo for use with libewf
diff --git a/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild b/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild
new file mode 100644
index 000000000000..c2ae87a16ac5
--- /dev/null
+++ b/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild,v 1.1 2013/07/27 00:50:54 zerochaos Exp $
+
+EAPI=5
+
+inherit versionator
+
+MY_DATE="$(get_version_component_range 3)"
+
+DESCRIPTION="Library for providing a basic file input/output abstraction layer."
+HOMEPAGE="http://code.google.com/p/libbfio/"
+SRC_URI="http://dev.pentoo.ch/~zero/distfiles/${PN}-alpha-${MY_DATE}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="unicode"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_DATE}"
+
+src_configure() {
+ econf $(use_enable unicode wide-character-type)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install"
+}
diff --git a/app-forensics/libbfio/libbfio-0.0.20130609_alpha.ebuild b/app-forensics/libbfio/libbfio-0.0.20130609_alpha.ebuild
new file mode 100644
index 000000000000..c7f029d2f9cc
--- /dev/null
+++ b/app-forensics/libbfio/libbfio-0.0.20130609_alpha.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libbfio/libbfio-0.0.20130609_alpha.ebuild,v 1.1 2013/07/27 00:50:54 zerochaos Exp $
+
+EAPI=5
+
+inherit versionator
+
+MY_DATE="$(get_version_component_range 3)"
+
+DESCRIPTION="Library for providing a basic file input/output abstraction layer."
+HOMEPAGE="http://code.google.com/p/libbfio/"
+SRC_URI="http://dev.pentoo.ch/~zero/distfiles/${PN}-alpha-${MY_DATE}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_DATE}"
+
+src_configure() {
+ econf $(use_enable unicode wide-character-type)
+}
diff --git a/app-forensics/libbfio/libbfio-0.0.20130721.ebuild b/app-forensics/libbfio/libbfio-0.0.20130721.ebuild
new file mode 100644
index 000000000000..eccce2e9dad6
--- /dev/null
+++ b/app-forensics/libbfio/libbfio-0.0.20130721.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libbfio/libbfio-0.0.20130721.ebuild,v 1.1 2013/07/27 00:50:54 zerochaos Exp $
+
+EAPI=5
+
+inherit versionator
+
+MY_DATE="$(get_version_component_range 3)"
+
+DESCRIPTION="Library for providing a basic file input/output abstraction layer."
+HOMEPAGE="http://code.google.com/p/libbfio/"
+SRC_URI="http://dev.pentoo.ch/~zero/distfiles/${PN}-alpha-${MY_DATE}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_DATE}"
+
+src_configure() {
+ econf $(use_enable unicode wide-character-type)
+}
diff --git a/app-forensics/libbfio/metadata.xml b/app-forensics/libbfio/metadata.xml
new file mode 100644
index 000000000000..5fcbf8e1851a
--- /dev/null
+++ b/app-forensics/libbfio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+