summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-21 19:33:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-21 19:33:55 +0000
commit966f89f49a5f9f6ccc5745ecc0a53a8930d27034 (patch)
tree2c7305db2c338e375dbafa7156b659817fdb37b7 /app-forensics
parentInstall /etc/psad/icmp6_types by Graham Murray (bug #444208). (diff)
downloadgentoo-2-966f89f49a5f9f6ccc5745ecc0a53a8930d27034.tar.gz
gentoo-2-966f89f49a5f9f6ccc5745ecc0a53a8930d27034.tar.bz2
gentoo-2-966f89f49a5f9f6ccc5745ecc0a53a8930d27034.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/unhide/ChangeLog5
-rw-r--r--app-forensics/unhide/unhide-20120905.ebuild39
2 files changed, 43 insertions, 1 deletions
diff --git a/app-forensics/unhide/ChangeLog b/app-forensics/unhide/ChangeLog
index c1988d59d283..d1b80c67a30b 100644
--- a/app-forensics/unhide/ChangeLog
+++ b/app-forensics/unhide/ChangeLog
@@ -1,8 +1,11 @@
+*unhide-20120905 (21 Nov 2012)
+
+ 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +unhide-20120905.ebuild:
+ Version bump
*unhide-20110113 (01 Dec 2011)
01 Dec 2011; Anthony G. Basile <blueness@gentoo.org> +unhide-20110113.ebuild,
+metadata.xml:
Initial commit
-
diff --git a/app-forensics/unhide/unhide-20120905.ebuild b/app-forensics/unhide/unhide-20120905.ebuild
new file mode 100644
index 000000000000..78a4be4b5146
--- /dev/null
+++ b/app-forensics/unhide/unhide-20120905.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/unhide/unhide-20120905.ebuild,v 1.1 2012/11/21 19:33:55 blueness Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A forensic tool to find hidden processes and TCP/UDP ports by rootkits/LKMs or other technique."
+HOMEPAGE="http://www.unhide-forensics.info"
+SRC_URI="mirror://sourceforge/${PN}/files/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static -pthread \
+ unhide-linux*.c unhide-output.c -o unhide
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static \
+ unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
+}
+
+src_install() {
+ dobin ${PN}
+ dobin ${PN}-tcp
+ dodoc changelog README.txt TODO
+ dodoc changelog README.txt LEEME.txt LISEZ-MOI.TXT NEWS TODO
+ doman man/unhide.8 man/unhide-tcp.8
+ has "fr" ${LINGUAS} && newman man/fr/unhide.8 unhide.fr.8
+ has "es" ${LINGUAS} && newman man/es/unhide.8 unhide.es.8
+}