summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2011-12-26 14:30:28 +0000
committerSven Vermeulen <swift@gentoo.org>2011-12-26 14:30:28 +0000
commit900fdaac6a5f70272c5f11857a3e00759f8fbf99 (patch)
tree7fbbc7b15b04f7e88ead9c2458c77a3c8a603f8c /app-forensics
parentx86 stable, bug #394231 (diff)
downloadgentoo-2-900fdaac6a5f70272c5f11857a3e00759f8fbf99.tar.gz
gentoo-2-900fdaac6a5f70272c5f11857a3e00759f8fbf99.tar.bz2
gentoo-2-900fdaac6a5f70272c5f11857a3e00759f8fbf99.zip
Bumping to 0.8.0, thanks to Corentin "Montjoie" Labbe for testing/maintaining
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/openscap/ChangeLog7
-rw-r--r--app-forensics/openscap/openscap-0.8.0.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index 1344dd2773fb..1330b808e1a4 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.12 2011/08/24 14:55:17 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.13 2011/12/26 14:30:28 swift Exp $
+
+*openscap-0.8.0 (26 Dec 2011)
+
+ 26 Dec 2011; <swift@gentoo.org> +openscap-0.8.0.ebuild:
+ Bumping to 0.8.0
24 Aug 2011; Torsten Veller <tove@gentoo.org> metadata.xml:
Fix typo
diff --git a/app-forensics/openscap/openscap-0.8.0.ebuild b/app-forensics/openscap/openscap-0.8.0.ebuild
new file mode 100644
index 000000000000..8e422ec5f761
--- /dev/null
+++ b/app-forensics/openscap/openscap-0.8.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.8.0.ebuild,v 1.1 2011/12/26 14:30:28 swift Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python bash-completion-r1
+
+DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
+HOMEPAGE="http://www.open-scap.org/"
+SRC_URI="http://www.open-scap.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion doc nss perl python sql"
+RESTRICT="test"
+
+RDEPEND="!nss? ( dev-libs/libgcrypt )
+ nss? ( dev-libs/nss )
+ sql? ( dev-db/opendbx )
+ dev-libs/libpcre
+ dev-libs/libxml2
+ dev-libs/libxslt
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local myconf
+ if use python || use perl ; then
+ myconf+=" --enable-bindings"
+ else
+ myconf+=" --disable-bindings"
+ fi
+ if use nss ; then
+ myconf+=" --with-crypto=nss3"
+ else
+ myconf+=" --with-crypto=gcrypt"
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.la' -delete || die
+ sed -i 's/^Description/&:/' "${D}"/usr/$(get_libdir)/pkgconfig/libopenscap.pc || die
+ #--enable-bindings enable all bindings, clean unwanted bindings
+ if use python && ! use perl ; then
+ rm -rf "${D}"/usr/$(get_libdir)/perl5 || die
+ fi
+ if ! use python && use perl ; then
+ rm -rf "${D}"/$(python_get_sitedir) || die
+ fi
+ if use doc ; then
+ dohtml -r docs/html/* || die
+ dodoc docs/examples/* || die
+ fi
+ if use bash-completion ; then
+ dobashcomp "${D}"/etc/bash_completion.d/oscap
+ fi
+ rm -rf "${D}"/etc/bash_completion.d || die
+}