summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:25:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:25:22 +0000
commit6b2eff103d3f9ef80df5a2da8aa3e8d1807bf85f (patch)
tree2bec6f2e2b91ab1ba75fe7b1c7ed5beb2af61896 /app-forensics
parentRemove unused virtuals tdb and talloc (diff)
downloadgentoo-2-6b2eff103d3f9ef80df5a2da8aa3e8d1807bf85f.tar.gz
gentoo-2-6b2eff103d3f9ef80df5a2da8aa3e8d1807bf85f.tar.bz2
gentoo-2-6b2eff103d3f9ef80df5a2da8aa3e8d1807bf85f.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog9
-rw-r--r--app-forensics/afflib/afflib-3.5.8.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 2cec045e52d7..e58b5327799e 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.7 2009/11/08 12:01:39 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.8 2010/02/26 20:25:22 patrick Exp $
+
+*afflib-3.5.8 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +afflib-3.5.8.ebuild:
+ Bump
*afflib-3.5.2 (08 Nov 2009)
diff --git a/app-forensics/afflib/afflib-3.5.8.ebuild b/app-forensics/afflib/afflib-3.5.8.ebuild
new file mode 100644
index 000000000000..da7dbe6bc9ab
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.5.8.ebuild,v 1.1 2010/02/26 20:25:22 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}