summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-07-26 17:12:53 +0000
committerRick Farina <zerochaos@gentoo.org>2013-07-26 17:12:53 +0000
commit0d219eeadab7b5efbc83869c2be83f25c62f99d3 (patch)
tree867926d177ebe3bcb120b447b700aed78327d3d6 /app-forensics
parentStable for amd64, wrt bug #478184 (diff)
downloadgentoo-2-0d219eeadab7b5efbc83869c2be83f25c62f99d3.tar.gz
gentoo-2-0d219eeadab7b5efbc83869c2be83f25c62f99d3.tar.bz2
gentoo-2-0d219eeadab7b5efbc83869c2be83f25c62f99d3.zip
add USE=doc, disable html doc generation due to failure, fix sandbox issue
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rdd/ChangeLog8
-rw-r--r--app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch25
-rw-r--r--app-forensics/rdd/rdd-2.0.7.ebuild4
-rw-r--r--app-forensics/rdd/rdd-3.0.4-r1.ebuild47
4 files changed, 81 insertions, 3 deletions
diff --git a/app-forensics/rdd/ChangeLog b/app-forensics/rdd/ChangeLog
index 783d2774d4e8..f7c0d9e025f2 100644
--- a/app-forensics/rdd/ChangeLog
+++ b/app-forensics/rdd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/rdd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/ChangeLog,v 1.5 2013/05/10 05:41:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/ChangeLog,v 1.6 2013/07/26 17:12:53 zerochaos Exp $
+
+*rdd-3.0.4-r1 (26 Jul 2013)
+
+ 26 Jul 2013; Rick Farina <zerochaos@gentoo.org>
+ +files/rdd-3.0.4-sandbox-fix.patch, +rdd-3.0.4-r1.ebuild, rdd-2.0.7.ebuild:
+ add USE=doc, disable html doc generation due to failure, fix sandbox issue
10 May 2013; Patrick Lauer <patrick@gentoo.org> rdd-3.0.4.ebuild:
Whitespace
diff --git a/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch b/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch
new file mode 100644
index 000000000000..b7188030fba5
--- /dev/null
+++ b/app-forensics/rdd/files/rdd-3.0.4-sandbox-fix.patch
@@ -0,0 +1,25 @@
+diff -Naur rdd-3.0.4-orig/src/Makefile.am rdd-3.0.4/src/Makefile.am
+--- rdd-3.0.4-orig/src/Makefile.am 2013-07-26 11:27:50.288696066 -0400
++++ rdd-3.0.4/src/Makefile.am 2013-07-26 12:14:51.601771619 -0400
+@@ -83,14 +83,15 @@
+ rdd-verify.1
+
+ install-exec-local:
+- $(INSTALL) $(srcdir)/rddi.py $(bindir)/rddi
+- $(INSTALL) $(srcdir)/plot-entropy.py $(bindir)/plot-entropy
+- $(INSTALL) $(srcdir)/plot-md5.py $(bindir)/plot-md5
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) $(srcdir)/rddi.py $(DESTDIR)$(bindir)/rddi
++ $(INSTALL) $(srcdir)/plot-entropy.py $(DESTDIR)$(bindir)/plot-entropy
++ $(INSTALL) $(srcdir)/plot-md5.py $(DESTDIR)$(bindir)/plot-md5
+
+ uninstall-local:
+- rm -f $(bindir)/rddi
+- rm -f $(bindir)/plot-entropy
+- rm -f $(bindir)/plot-md5
++ rm -f $(DESTDIR)$(bindir)/rddi
++ rm -f $(DESTDIR)$(bindir)/plot-entropy
++ rm -f $(DESTDIR)$(bindir)/plot-md5
+
+ DISTCLEANFILES= Makefile.in
+
diff --git a/app-forensics/rdd/rdd-2.0.7.ebuild b/app-forensics/rdd/rdd-2.0.7.ebuild
index 7973f167078e..a2eb5fd60a66 100644
--- a/app-forensics/rdd/rdd-2.0.7.ebuild
+++ b/app-forensics/rdd/rdd-2.0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/rdd-2.0.7.ebuild,v 1.3 2011/03/27 10:35:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/rdd-2.0.7.ebuild,v 1.4 2013/07/26 17:12:53 zerochaos Exp $
EAPI="1"
diff --git a/app-forensics/rdd/rdd-3.0.4-r1.ebuild b/app-forensics/rdd/rdd-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..512b8362c98b
--- /dev/null
+++ b/app-forensics/rdd/rdd-3.0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/rdd-3.0.4-r1.ebuild,v 1.1 2013/07/26 17:12:53 zerochaos Exp $
+
+EAPI="5"
+
+inherit autotools eutils
+
+# no worky
+RESTRICT="test"
+
+DESCRIPTION="Rdd is a forensic copy program"
+HOMEPAGE="http://www.sf.net/projects/rdd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-forensics/libewf
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/rdd-3.0.4-sandbox-fix.patch"
+ sed -i 's/AM_PATH_GTK_2_0//' configure.ac || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ #doxygen-html fails but the docs are prebuilt so we don't need to enable them
+ econf --disable-doxygen-html \
+ $(use_enable debug tracing) \
+ $(use_enable doc doxygen-doc)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dobin src/rddi.py
+ dosym rdd-copy /usr/bin/rdd
+ #this causes a warning about not being recursive, no clue why
+ dohtml -r doxygen-doc/html/*
+}