summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-23 23:52:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-23 23:52:56 +0000
commit038f20e6ec2be737ec0c1755d8a0ea1cc85a788d (patch)
tree416c4461c993a427c40363e415ab491fa1662f76 /app-forensics
parentVersion bump. (diff)
downloadgentoo-2-038f20e6ec2be737ec0c1755d8a0ea1cc85a788d.tar.gz
gentoo-2-038f20e6ec2be737ec0c1755d8a0ea1cc85a788d.tar.bz2
gentoo-2-038f20e6ec2be737ec0c1755d8a0ea1cc85a788d.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/autopsy/ChangeLog7
-rw-r--r--app-forensics/autopsy/autopsy-2.24.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/app-forensics/autopsy/ChangeLog b/app-forensics/autopsy/ChangeLog
index e6046afda322..db29ba33f866 100644
--- a/app-forensics/autopsy/ChangeLog
+++ b/app-forensics/autopsy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/autopsy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.18 2011/07/24 18:21:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.19 2011/08/23 23:52:56 radhermit Exp $
+
+*autopsy-2.24 (23 Aug 2011)
+
+ 23 Aug 2011; Tim Harder <radhermit@gentoo.org> +autopsy-2.24.ebuild:
+ Version bump.
24 Jul 2011; Raúl Porcel <armin76@gentoo.org> autopsy-2.03.ebuild,
autopsy-2.21.ebuild, autopsy-2.23.ebuild:
diff --git a/app-forensics/autopsy/autopsy-2.24.ebuild b/app-forensics/autopsy/autopsy-2.24.ebuild
new file mode 100644
index 000000000000..e54ac15fb251
--- /dev/null
+++ b/app-forensics/autopsy/autopsy-2.24.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/autopsy-2.24.ebuild,v 1.1 2011/08/23 23:52:56 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
+HOMEPAGE="http://www.sleuthkit.org/autopsy/"
+SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+# Runtime depend on grep and file deliberate
+RDEPEND=">=dev-lang/perl-5.8.0
+ >=app-forensics/sleuthkit-3.0.0
+ sys-apps/grep
+ sys-apps/file"
+DEPEND=""
+
+src_configure() {
+ ./configure 2>&1 >/dev/null <<-EOF
+ n
+ /tmp
+ EOF
+
+ cat <<-EOF > autopsy
+ #!/usr/bin/perl -wT
+ use lib '/usr/lib/autopsy/';
+ use lib '/usr/lib/autopsy/lib/';
+ base/autopsy.base
+ EOF
+
+ sed -i 's:conf.pl:/etc/autopsy.pl:' $(grep -lr conf\.pl ./)
+ sed -i "s:INSTALLDIR = .*:INSTALLDIR = \'/usr/lib/autopsy\';:" conf.pl
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/lib/autopsy
+ doins autopsy
+ doins global.css
+ insinto /usr/lib/autopsy/help
+ doins help/*
+ insinto /usr/lib/autopsy/lib
+ doins lib/*
+ insinto /usr/lib/autopsy/pict
+ doins pict/*
+ insinto /etc
+ newins conf.pl autopsy.pl
+
+ dodir /usr/bin
+ dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
+ fperms +x /usr/lib/autopsy/autopsy
+
+ doman $(find man/ -type f)
+ dodoc CHANGES.txt README* TODO.txt docs/sleuthkit-informer*.txt
+}