summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-03-02 19:28:17 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-03-02 19:28:17 +0000
commit836137a508f45a42d7802fd61c21a9843d16860b (patch)
treef7167ddb8eace9b61f0196441231c961df2a5fb9 /app-forensics/zzuf
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-836137a508f45a42d7802fd61c21a9843d16860b.tar.gz
gentoo-2-836137a508f45a42d7802fd61c21a9843d16860b.tar.bz2
gentoo-2-836137a508f45a42d7802fd61c21a9843d16860b.zip
bump to fix bug #307049
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/zzuf')
-rw-r--r--app-forensics/zzuf/ChangeLog8
-rw-r--r--app-forensics/zzuf/zzuf-0.13-r1.ebuild (renamed from app-forensics/zzuf/zzuf-0.13.ebuild)22
2 files changed, 21 insertions, 9 deletions
diff --git a/app-forensics/zzuf/ChangeLog b/app-forensics/zzuf/ChangeLog
index 89397d927dce..11570352ed58 100644
--- a/app-forensics/zzuf/ChangeLog
+++ b/app-forensics/zzuf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/zzuf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.7 2010/03/02 18:35:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.8 2010/03/02 19:28:17 cardoe Exp $
+
+*zzuf-0.13-r1 (02 Mar 2010)
+
+ 02 Mar 2010; Doug Goldstein <cardoe@gentoo.org> -zzuf-0.13.ebuild,
+ +zzuf-0.13-r1.ebuild:
+ bump to fix bug #307049
02 Mar 2010; Patrick Lauer <patrick@gentoo.org> zzuf-0.13.ebuild:
Prevent file collision with zziplib on /bin/zzcat, #307049
diff --git a/app-forensics/zzuf/zzuf-0.13.ebuild b/app-forensics/zzuf/zzuf-0.13-r1.ebuild
index 7b2a5bbc4b70..a66f997cc137 100644
--- a/app-forensics/zzuf/zzuf-0.13.ebuild
+++ b/app-forensics/zzuf/zzuf-0.13-r1.ebuild
@@ -1,33 +1,36 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.13.ebuild,v 1.2 2010/03/02 18:35:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.13-r1.ebuild,v 1.1 2010/03/02 19:28:17 cardoe Exp $
+
+EAPI="2"
inherit autotools
DESCRIPTION="Transparent application input fuzzer"
HOMEPAGE="http://libcaca.zoy.org/wiki/zzuf/"
-SRC_URI="http://caca.zoy.org/files/${PN}/${P}.tar.gz"
+SRC_URI="http://caca.zoy.org/files/${PN}/${P}.tar.gz
+ http://dev.gentoo.org/~cardoe/distfiles/${P}-zzcat-zzat-rename.patch.bz2"
LICENSE="WTFPL-2"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE=""
-RDEPEND="!dev-libs/zziplib"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DEPEND=""
+RDEPEND=""
+src_prepare() {
sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
|| die "unable to fix the configure.ac"
sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
|| die "unable to fix unconditional test building"
+ epatch "${DISTDIR}"/${P}-zzcat-zzat-rename.patch.bz2
+
eautoreconf
}
-src_compile() {
+src_configure() {
# Don't build the static library, as the library is only used for
# preloading, so there is no reason to build it statically, unless
# you want to use zzuf with a static-linked executable, which I'm
@@ -36,6 +39,9 @@ src_compile() {
--disable-dependency-tracking \
--disable-static \
|| die "econf failed"
+}
+
+src_compile() {
emake || die "emake failed"
}