summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-29 14:43:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-29 14:43:31 +0000
commit0ffabb3ee21d7b561ec6337dbb855646f740376b (patch)
tree46251811c323e83a9e90a0e69b74a9c1fc270ae7 /app-forensics/unhide/unhide-20121229.ebuild
parentStable for sparc, wrt bug #445564 (diff)
downloadgentoo-2-0ffabb3ee21d7b561ec6337dbb855646f740376b.tar.gz
gentoo-2-0ffabb3ee21d7b561ec6337dbb855646f740376b.tar.bz2
gentoo-2-0ffabb3ee21d7b561ec6337dbb855646f740376b.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-forensics/unhide/unhide-20121229.ebuild')
-rw-r--r--app-forensics/unhide/unhide-20121229.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-forensics/unhide/unhide-20121229.ebuild b/app-forensics/unhide/unhide-20121229.ebuild
new file mode 100644
index 000000000000..1700f480701b
--- /dev/null
+++ b/app-forensics/unhide/unhide-20121229.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/unhide/unhide-20121229.ebuild,v 1.1 2012/12/29 14:43:31 blueness Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+S="${WORKDIR}"
+
+DESCRIPTION="A forensic tool to find hidden processes and TCP/UDP ports by rootkits/LKMs or other technique."
+HOMEPAGE="http://www.unhide-forensics.info"
+SRC_URI="mirror://sourceforge/${PN}/files/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static -pthread \
+ unhide-linux*.c unhide-output.c -o unhide
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static \
+ unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
+}
+
+src_install() {
+ dobin ${PN}
+ dobin ${PN}-tcp
+ dodoc changelog README.txt TODO
+ dodoc changelog README.txt LEEME.txt LISEZ-MOI.TXT NEWS TODO
+ doman man/unhide.8 man/unhide-tcp.8
+ has "fr" ${LINGUAS} && newman man/fr/unhide.8 unhide.fr.8
+ has "es" ${LINGUAS} && newman man/es/unhide.8 unhide.es.8
+}