summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-07 09:48:38 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-07 09:48:38 +0000
commit4e767967e796457e7766d7f085a176f910ad4aa0 (patch)
tree04c87045dc0634e1bf7ef8e7897f0f23be773881 /app-forensics/tct/files
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-4e767967e796457e7766d7f085a176f910ad4aa0.tar.gz
gentoo-2-4e767967e796457e7766d7f085a176f910ad4aa0.tar.bz2
gentoo-2-4e767967e796457e7766d7f085a176f910ad4aa0.zip
Revision bump; fixes bug #70307, use tc-getCC, and don't install md5 man page as it gets installed by openssl.
Diffstat (limited to 'app-forensics/tct/files')
-rw-r--r--app-forensics/tct/files/digest-tct-1.15-r11
-rw-r--r--app-forensics/tct/files/tct-1.15-r1-gentoo.diff193
2 files changed, 194 insertions, 0 deletions
diff --git a/app-forensics/tct/files/digest-tct-1.15-r1 b/app-forensics/tct/files/digest-tct-1.15-r1
new file mode 100644
index 000000000000..38d219d8302e
--- /dev/null
+++ b/app-forensics/tct/files/digest-tct-1.15-r1
@@ -0,0 +1 @@
+MD5 d4992f242f7b3a6c8137e8562935f946 tct-1.15.tar.gz 317164
diff --git a/app-forensics/tct/files/tct-1.15-r1-gentoo.diff b/app-forensics/tct/files/tct-1.15-r1-gentoo.diff
new file mode 100644
index 000000000000..363193d81a66
--- /dev/null
+++ b/app-forensics/tct/files/tct-1.15-r1-gentoo.diff
@@ -0,0 +1,193 @@
+diff -urN tct-1.15.orig/Makefile tct-1.15/Makefile
+--- tct-1.15.orig/Makefile 2001-09-15 16:23:28.000000000 -0400
++++ tct-1.15/Makefile 2004-11-07 04:15:01.023763997 -0500
+@@ -16,7 +16,6 @@
+ cd src/misc; make "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make "CC=$(CC)" MAKELEVEL=
+- cd src/file; make "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make "CC=$(CC)" MAKELEVEL=
+@@ -30,7 +29,6 @@
+ cd src/misc; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make $@ "CC=$(CC)" MAKELEVEL=
+- cd src/file; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make $@ "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make $@ "CC=$(CC)" MAKELEVEL=
+@@ -44,7 +42,6 @@
+ cd src/misc; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/fstools; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/pcat; make $@ "CC=$(CC)" MAKELEVEL=
+- cd src/file; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/lastcomm; make $@ "CC=$(CC)" MAKELEVEL=
+ cd src/major_minor; make $@ "CC=$(CC)" MAKELEVEL=
+ cd extras/entropy; make $@ "CC=$(CC)" MAKELEVEL=
+diff -urN tct-1.15.orig/bin/grave-robber tct-1.15/bin/grave-robber
+--- tct-1.15.orig/bin/grave-robber 2004-01-22 14:48:01.000000000 -0500
++++ tct-1.15/bin/grave-robber 2004-11-07 04:15:01.024763832 -0500
+@@ -424,9 +424,7 @@
+ die "Can't find TCT_HOME - did you run reconfig?\n";
+ }
+
+-if (!-f "$BIN/file") {
+- die "Can't find our \"$BIN/file\" command - did you type \"make\" first?\n";
+- }
++die "Can't find \"$FILE\" command \n" unless (-f $FILE);
+
+ require "logger.pl";
+ require "command.pl";
+@@ -495,15 +493,10 @@
+ #
+ # we usually carry around the alternate magic file...
+ #
+-if (-f "$ETC/magic") { $magic_file = "$ETC/magic"; }
+- else {
+- die "Can't find the /etc/magic file\n" unless (-f "/etc/magic");
+- $magic_file = "/etc/magic";
+- warn "Couldn't find $ETC/magic, switching over to $magic_file\n";
+- }
++$magic_file = "/usr/share/misc/file/magic";
++die "Can't find $magic_file" unless (-f $magic_file);
+
+ }
+-
+ #
+ # does a system have a proc file system? Returns 0 if so, !0 if no
+ #
+diff -urN tct-1.15.orig/conf/coroner.cf tct-1.15/conf/coroner.cf
+--- tct-1.15.orig/conf/coroner.cf 2004-01-22 14:48:00.000000000 -0500
++++ tct-1.15/conf/coroner.cf 2004-11-07 04:15:01.024763832 -0500
+@@ -2,7 +2,7 @@
+ # Configuration file for coroner's toolkit
+ #
+
+-$TCT_HOME = "";
++$TCT_HOME = "/usr/lib/tct";
+
+ $ETC = "$TCT_HOME/etc" unless $ETC;
+
+@@ -21,7 +21,7 @@
+ #
+ # All sensitive operations are logged with a time stamp.
+ #
+-$logfile = "coroner.log";
++$logfile = "/var/log/tct/coroner.log";
+
+ #
+ # What colors to use for MACtime HTML stuff
+diff -urN tct-1.15.orig/conf/grave-robber.cf tct-1.15/conf/grave-robber.cf
+--- tct-1.15.orig/conf/grave-robber.cf 2004-01-22 14:48:00.000000000 -0500
++++ tct-1.15/conf/grave-robber.cf 2004-11-07 04:15:01.025763666 -0500
+@@ -2,7 +2,7 @@
+ # Configuration file for coroner's toolkit
+ #
+
+-$TCT_HOME = "";
++$TCT_HOME = "/usr/lib/tct";
+
+ $LIB = "$TCT_HOME/lib" unless $LIB;
+ $BIN = "$TCT_HOME/bin" unless $BIN;
+@@ -28,7 +28,7 @@
+ #
+ # stderr goes...
+ #
+-$error_log = "error.log";
++$error_log = "/var/log/tct/error.log";
+
+ #
+ # Don't copy file larger than this (bytes). Set to 0 if don't want limits
+diff -urN tct-1.15.orig/conf/paths.pl tct-1.15/conf/paths.pl
+--- tct-1.15.orig/conf/paths.pl 2004-01-08 17:29:05.000000000 -0500
++++ tct-1.15/conf/paths.pl 2004-11-07 04:15:01.025763666 -0500
+@@ -13,7 +13,7 @@
+
+ $CRONTAB="/usr/bin/crontab";
+ $DATE="/bin/date";
+-$DMESG="/sbin/dmesg";
++$DMESG="/bin/dmesg";
+ $DOMAINNAME="/bin/domainname";
+ $ECHO="/bin/echo";
+
+@@ -21,20 +21,20 @@
+ $FINGER="/usr/bin/finger";
+ $IFCONFIG="/sbin/ifconfig";
+ $IPCS="/usr/bin/ipcs";
+-$LAST="/usr/bin/last";
++$LAST="/bin/last";
+
+-$LSOF="/usr/local/sbin/lsof";
++$LSOF="/usr/sbin/lsof";
+ $MKDIR="/bin/mkdir";
+-$NETSTAT="/usr/bin/netstat";
++$NETSTAT="/bin/netstat";
+ $PS="/bin/ps";
+ $PWD="/bin/pwd";
+
+-$RPCINFO="/usr/bin/rpcinfo";
++$RPCINFO="/usr/sbin/rpcinfo";
+ $SHOWMOUNT="/usr/bin/showmount";
+ $STRINGS="/usr/bin/strings";
+-$SU="/usr/bin/su";
++$SU="/bin/su";
+ $SYNC="/bin/sync";
+-$TEE="/usr/bin/tee";
++$TEE="/bin/tee";
+
+ $TOP="/usr/bin/top";
+ $UNAME="/usr/bin/uname";
+@@ -61,9 +61,9 @@
+ $PSTAT="/usr/sbin/pstat";
+
+ # linux
+-$RPM="/usr/local/bin/rpm";
++$RPM="/usr/bin/rpm";
+ $KSYMS="/sbin/ksyms";
+-$LSMOD="/sbin/lsmod";
++$LSMOD="/bin/lsmod";
+
+ # kernel modules
+ $MODINFO="/sbin/modinfo";
+@@ -77,7 +77,7 @@
+ #
+ # our stuff
+ #
+-$FILE = "$TCT_HOME/bin/file";
++$FILE = "/usr/bin/file";
+ $MD5 = "$TCT_HOME/bin/md5";
+ $PCAT = "$TCT_HOME/bin/pcat";
+ $ICAT = "$TCT_HOME/bin/icat";
+diff -urN tct-1.15.orig/lazarus/lazarus tct-1.15/lazarus/lazarus
+--- tct-1.15.orig/lazarus/lazarus 2004-01-22 14:48:00.000000000 -0500
++++ tct-1.15/lazarus/lazarus 2004-11-07 04:19:27.807662812 -0500
+@@ -88,12 +88,9 @@
+ #
+ # we usually carry around the alternate magic file...
+ #
+-if (-f "$ETC/magic") { $magic_file = "$ETC/magic"; }
+-else {
+- die "Can't find the /etc/magic file\n" unless (-f "/etc/magic");
+- $magic_file = "/etc/magic";
+- warn "Couldn't find $ETC/magic, switching over to $magic_file\n";
+- }
++$magic_file="/usr/share/misc/file/magic"
++die "Can't find $magic_file\n" unless (-f $magic_file);
++
+
+ #
+ # Currently the default is to save/write everything other than unresolved
+diff -urN tct-1.15.orig/reconfig tct-1.15/reconfig
+--- tct-1.15.orig/reconfig 2001-09-15 16:48:51.000000000 -0400
++++ tct-1.15/reconfig 2004-11-07 04:15:01.026763501 -0500
+@@ -157,7 +157,8 @@
+ "extras/ils2mac", "extras/realpath");
+
+ # where are we now?
+-chop($cwd = `pwd`);
++#chop($cwd = `pwd`);
++$cwd = "/usr/lib/tct";
+
+ # a few small files; suck them in, change in memory, overwrite the old one
+ for $file (@files2reconfig) {