summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-10 20:54:55 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-10 20:54:55 +0000
commitf8e2c1336bef688e956668194c64aa5144e03faf (patch)
treea5219f14c00686a635e9deb1a9e3271797fa6bfa /app-forensics/sleuthkit
parentMake weather support optional to allow evolution-3 to be installed on gnome-2... (diff)
downloadgentoo-2-f8e2c1336bef688e956668194c64aa5144e03faf.tar.gz
gentoo-2-f8e2c1336bef688e956668194c64aa5144e03faf.tar.bz2
gentoo-2-f8e2c1336bef688e956668194c64aa5144e03faf.zip
Version bump. Add subslot and migrate to autotools-utils.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-forensics/sleuthkit')
-rw-r--r--app-forensics/sleuthkit/ChangeLog7
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index f53ba613e289..232f7992b405 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.75 2013/01/27 07:17:45 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.76 2013/02/10 20:54:55 radhermit Exp $
+
+*sleuthkit-4.0.2 (10 Feb 2013)
+
+ 10 Feb 2013; Tim Harder <radhermit@gentoo.org> +sleuthkit-4.0.2.ebuild:
+ Version bump. Add subslot and migrate to autotools-utils.
27 Jan 2013; Tim Harder <radhermit@gentoo.org> -sleuthkit-3.2.3.ebuild,
-files/sleuthkit-3.2.3-system-sqlite.patch, -sleuthkit-4.0.0.ebuild:
diff --git a/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild b/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild
new file mode 100644
index 000000000000..e931ff6a1a87
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild,v 1.1 2013/02/10 20:54:55 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+SLOT="0/9" # subslot = major soname version
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="aff ewf static-libs"
+
+DEPEND="dev-db/sqlite:3
+ ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+DOCS=( NEWS.txt README.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-system-sqlite.patch
+ "${FILESDIR}"/${PN}-3.2.3-tools-shared-libs.patch
+)
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with aff afflib)
+ $(use_with ewf libewf)
+ )
+ autotools-utils_src_configure
+}