summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-29 05:51:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-29 05:51:25 +0000
commit0866c14d57e8cb597af99e8c7fcfcf97f157b30c (patch)
tree469da68f35c8d113d7a63c8a270dc8602d2da899 /app-forensics/libewf
parentDrop old. (diff)
downloadgentoo-2-0866c14d57e8cb597af99e8c7fcfcf97f157b30c.tar.gz
gentoo-2-0866c14d57e8cb597af99e8c7fcfcf97f157b30c.tar.bz2
gentoo-2-0866c14d57e8cb597af99e8c7fcfcf97f157b30c.zip
Bump
(Portage version: 2.2.12/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-forensics/libewf')
-rw-r--r--app-forensics/libewf/ChangeLog7
-rw-r--r--app-forensics/libewf/libewf-20140608.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index d1159c427368..3f16849d63c9 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.58 2014/08/08 14:00:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.59 2014/08/29 05:51:25 patrick Exp $
+
+*libewf-20140608 (29 Aug 2014)
+
+ 29 Aug 2014; Patrick Lauer <patrick@gentoo.org> +libewf-20140608.ebuild:
+ Bump
08 Aug 2014; Anthony G. Basile <blueness@gentoo.org>
libewf-20130416-r1.ebuild, libewf-20131210.ebuild, libewf-20140227.ebuild,
diff --git a/app-forensics/libewf/libewf-20140608.ebuild b/app-forensics/libewf/libewf-20140608.ebuild
new file mode 100644
index 000000000000..1c25e2a86a03
--- /dev/null
+++ b/app-forensics/libewf/libewf-20140608.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20140608.ebuild,v 1.1 2014/08/29 05:51:25 patrick Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://code.google.com/p/libewf/"
+SRC_URI="https://googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python unicode"
+IUSE="bfio debug ewf +fuse +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with bfio libbfio)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}