summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-09-07 12:59:01 +0000
committerMike Auty <ikelos@gentoo.org>2010-09-07 12:59:01 +0000
commit708743d779373eafe034a004a4ee1a7fd47d17af (patch)
tree1212f000903a3e4a14195a367093010894823406 /app-forensics/foremost
parentRemove patch to make pykde4 build agains stable tree, bug 332503 (diff)
downloadgentoo-2-708743d779373eafe034a004a4ee1a7fd47d17af.tar.gz
gentoo-2-708743d779373eafe034a004a4ee1a7fd47d17af.tar.bz2
gentoo-2-708743d779373eafe034a004a4ee1a7fd47d17af.zip
Fix bug 336153 by adding LDFLAGS to RAW_FLAGS for compilation.
(Portage version: 2.2_rc74/cvs/Linux i686)
Diffstat (limited to 'app-forensics/foremost')
-rw-r--r--app-forensics/foremost/foremost-1.5.5-r1.ebuild4
-rw-r--r--app-forensics/foremost/foremost-1.5.6-r1.ebuild4
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r1.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-forensics/foremost/foremost-1.5.5-r1.ebuild b/app-forensics/foremost/foremost-1.5.5-r1.ebuild
index b673e8ae3203..07c730a65fe4 100644
--- a/app-forensics/foremost/foremost-1.5.5-r1.ebuild
+++ b/app-forensics/foremost/foremost-1.5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.5-r1.ebuild,v 1.1 2010/04/12 20:20:14 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.5-r1.ebuild,v 1.2 2010/09/07 12:59:01 ikelos Exp $
inherit eutils toolchain-funcs
@@ -20,7 +20,7 @@ src_unpack() {
}
src_compile() {
- emake RAW_FLAGS="${CFLAGS} -Wall" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
CONF=/etc || die "emake failed"
}
diff --git a/app-forensics/foremost/foremost-1.5.6-r1.ebuild b/app-forensics/foremost/foremost-1.5.6-r1.ebuild
index c22f5d711fd4..809f8bf0a9e1 100644
--- a/app-forensics/foremost/foremost-1.5.6-r1.ebuild
+++ b/app-forensics/foremost/foremost-1.5.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.6-r1.ebuild,v 1.1 2010/04/12 20:20:14 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.6-r1.ebuild,v 1.2 2010/09/07 12:59:01 ikelos Exp $
inherit eutils toolchain-funcs
@@ -22,7 +22,7 @@ src_unpack() {
}
src_compile() {
- emake RAW_FLAGS="${CFLAGS} -Wall" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
CONF=/etc || die "emake failed"
}
diff --git a/app-forensics/foremost/foremost-1.5.7-r1.ebuild b/app-forensics/foremost/foremost-1.5.7-r1.ebuild
index f119e5822b71..07f30e533fee 100644
--- a/app-forensics/foremost/foremost-1.5.7-r1.ebuild
+++ b/app-forensics/foremost/foremost-1.5.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.7-r1.ebuild,v 1.1 2010/04/12 20:20:14 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.7-r1.ebuild,v 1.2 2010/09/07 12:59:01 ikelos Exp $
inherit eutils toolchain-funcs
@@ -22,7 +22,7 @@ src_unpack() {
}
src_compile() {
- emake RAW_FLAGS="${CFLAGS} -Wall" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
CONF=/etc || die "emake failed"
}