summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-31 14:42:40 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-31 14:42:40 +0000
commit6e2d63080c4ad1bfc36fdbe1c2cb856a7ec0b660 (patch)
treea0af0ae945a73a0141bc6106ae48bae30aacdc89 /app-forensics/afflib
parenthttp://my.opera.com/desktopteam/blog/2012/05/31/password-and-font-fixes (diff)
downloadgentoo-2-6e2d63080c4ad1bfc36fdbe1c2cb856a7ec0b660.tar.gz
gentoo-2-6e2d63080c4ad1bfc36fdbe1c2cb856a7ec0b660.tar.bz2
gentoo-2-6e2d63080c4ad1bfc36fdbe1c2cb856a7ec0b660.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog8
-rw-r--r--app-forensics/afflib/afflib-3.7.1.ebuild61
-rw-r--r--app-forensics/afflib/files/afflib-3.7.1-python-module.patch14
3 files changed, 82 insertions, 1 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index c48701f56788..05c58293bb1f 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.36 2012/05/16 22:35:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.37 2012/05/31 14:42:40 radhermit Exp $
+
+*afflib-3.7.1 (31 May 2012)
+
+ 31 May 2012; Tim Harder <radhermit@gentoo.org> +afflib-3.7.1.ebuild,
+ +files/afflib-3.7.1-python-module.patch:
+ Version bump.
16 May 2012; Tim Harder <radhermit@gentoo.org> -afflib-3.6.12.ebuild:
Remove old.
diff --git a/app-forensics/afflib/afflib-3.7.1.ebuild b/app-forensics/afflib/afflib-3.7.1.ebuild
new file mode 100644
index 000000000000..00b15146c8fb
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.7.1.ebuild,v 1.1 2012/05/31 14:42:40 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils python
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/simsong/AFFLIBv3"
+SRC_URI="mirror://github/simsong/AFFLIBv3/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-module.patch
+ "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
+)
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e "/FLAGS/s: -g::" configure.ac || die
+ sed -i -e "/-static/d" tools/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable threads threading)
+ )
+ autotools-utils_src_configure
+}
diff --git a/app-forensics/afflib/files/afflib-3.7.1-python-module.patch b/app-forensics/afflib/files/afflib-3.7.1-python-module.patch
new file mode 100644
index 000000000000..d89509f2f7ea
--- /dev/null
+++ b/app-forensics/afflib/files/afflib-3.7.1-python-module.patch
@@ -0,0 +1,14 @@
+--- afflib-3.7.1/pyaff/Makefile.am
++++ afflib-3.7.1/pyaff/Makefile.am
+@@ -7,8 +7,8 @@
+ pyexec_LTLIBRARIES = pyaff.la
+
+ pyaff_la_SOURCES = pyaff.c
+-pyaff_la_LIBADD = ../lib/libafflib.la
++pyaff_la_LIBADD = @top_builddir@/lib/libafflib.la
+ pyaff_la_CPPFLAGS = $(PYTHON_CPPFLAGS)
+-pyaff_la_CFLAGS = -fno-strict-aliasing
+-pyaff_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
++pyaff_la_CFLAGS = $(AM_CFLAGS) -shared -fno-strict-aliasing
++pyaff_la_LDFLAGS = -module -avoid-version -shared $(PYTHON_LDFLAGS)
+ endif