summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-01 05:18:21 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-01 05:18:21 +0000
commit5f4462659029993f9749b8d26f7d49bc1d19c60b (patch)
tree379fa3a158d981b6d19ac05351a0624b25e25077 /app-forensics/afflib
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-5f4462659029993f9749b8d26f7d49bc1d19c60b.tar.gz
gentoo-2-5f4462659029993f9749b8d26f7d49bc1d19c60b.tar.bz2
gentoo-2-5f4462659029993f9749b8d26f7d49bc1d19c60b.zip
Version bump. Update HOMEPAGE.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog7
-rw-r--r--app-forensics/afflib/afflib-3.7.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 2e8ef2dee935..c660707615c1 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.29 2012/03/06 12:22:34 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.30 2012/05/01 05:18:21 radhermit Exp $
+
+*afflib-3.7.0 (01 May 2012)
+
+ 01 May 2012; Tim Harder <radhermit@gentoo.org> +afflib-3.7.0.ebuild:
+ Version bump. Update HOMEPAGE.
*afflib-3.6.16 (06 Mar 2012)
diff --git a/app-forensics/afflib/afflib-3.7.0.ebuild b/app-forensics/afflib/afflib-3.7.0.ebuild
new file mode 100644
index 000000000000..c965a5580c9d
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.7.0.ebuild,v 1.1 2012/05/01 05:18:21 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils python
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/simsong/AFFLIBv3"
+SRC_URI="mirror://github/simsong/AFFLIBv3/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6.12-python-module.patch
+ "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
+)
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e "/FLAGS/s: -g::" configure.ac || die
+ sed -i -e "/-static/d" tools/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable threads threading)
+ )
+ autotools-utils_src_configure
+}