summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-28 05:41:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-28 05:41:56 +0000
commit1ef8f53ae0d7ab8d16246839721a7c62d57eeb93 (patch)
tree9d2101b076fa535125cd9280c742c380bcfb78c0 /app-forensics/afflib
parentclean up deps + remove oldest (diff)
downloadgentoo-2-1ef8f53ae0d7ab8d16246839721a7c62d57eeb93.tar.gz
gentoo-2-1ef8f53ae0d7ab8d16246839721a7c62d57eeb93.tar.bz2
gentoo-2-1ef8f53ae0d7ab8d16246839721a7c62d57eeb93.zip
Fix autotools-utils usage (bug #392137). Fix python module CFLAGS handling.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog7
-rw-r--r--app-forensics/afflib/afflib-3.6.12.ebuild28
-rw-r--r--app-forensics/afflib/files/afflib-3.6.12-pyaff-header.patch13
-rw-r--r--app-forensics/afflib/files/afflib-3.6.12-python-module.patch4
4 files changed, 35 insertions, 17 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index c281faf9de7b..b4916c6913fd 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.20 2011/11/26 10:50:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.21 2011/11/28 05:41:56 radhermit Exp $
+
+ 28 Nov 2011; Tim Harder <radhermit@gentoo.org> afflib-3.6.12.ebuild,
+ +files/afflib-3.6.12-pyaff-header.patch,
+ files/afflib-3.6.12-python-module.patch:
+ Fix autotools-utils usage (bug #392137). Fix python module CFLAGS handling.
26 Nov 2011; Tim Harder <radhermit@gentoo.org> metadata.xml:
Improve s3 use flag description.
diff --git a/app-forensics/afflib/afflib-3.6.12.ebuild b/app-forensics/afflib/afflib-3.6.12.ebuild
index d962d3e912c4..22b39aa564e8 100644
--- a/app-forensics/afflib/afflib-3.6.12.ebuild
+++ b/app-forensics/afflib/afflib-3.6.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.12.ebuild,v 1.6 2011/11/26 10:43:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.12.ebuild,v 1.7 2011/11/28 05:41:56 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -25,7 +25,10 @@ RDEPEND="dev-libs/expat
s3? ( net-misc/curl )"
DEPEND="${RDEPEND}"
-AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${P}-python-module.patch
+ "${FILESDIR}"/${P}-pyaff-header.patch
+)
pkg_setup() {
if use python ; then
@@ -35,11 +38,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-python-module.patch
-
sed -i -e "/FLAGS/s: -g::" configure.ac || die
sed -i -e "/-static/d" tools/Makefile.am || die
+ autotools-utils_src_prepare
eautoreconf
}
@@ -48,16 +50,12 @@ src_configure() {
use ncurses || export ac_cv_lib_ncurses_initscr=no
use readline || export ac_cv_lib_readline_readline=no
- econf \
- $(use_enable fuse) \
- $(use_enable python) \
- $(use_enable qemu) \
- $(use_enable s3) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
$(use_enable threads threading)
-}
-
-src_install() {
- default
- remove_libtool_files all
+ )
+ autotools-utils_src_configure
}
diff --git a/app-forensics/afflib/files/afflib-3.6.12-pyaff-header.patch b/app-forensics/afflib/files/afflib-3.6.12-pyaff-header.patch
new file mode 100644
index 000000000000..496b02d25035
--- /dev/null
+++ b/app-forensics/afflib/files/afflib-3.6.12-pyaff-header.patch
@@ -0,0 +1,13 @@
+Fix include location based on the include directories passed via CFLAGS.
+
+--- afflib-3.6.12/pyaff/pyaff.c.orig
++++ afflib-3.6.12/pyaff/pyaff.c
+@@ -21,7 +21,7 @@
+ ****************************************************/
+
+ #include "Python.h"
+-#include "lib/afflib.h"
++#include "afflib.h"
+
+ #include <string.h>
+ #include <stdlib.h>
diff --git a/app-forensics/afflib/files/afflib-3.6.12-python-module.patch b/app-forensics/afflib/files/afflib-3.6.12-python-module.patch
index c5422010f615..281d8f38c0e1 100644
--- a/app-forensics/afflib/files/afflib-3.6.12-python-module.patch
+++ b/app-forensics/afflib/files/afflib-3.6.12-python-module.patch
@@ -1,3 +1,5 @@
+Only build the shared python library.
+
--- afflib-3.6.12/pyaff/Makefile.am.orig
+++ afflib-3.6.12/pyaff/Makefile.am
@@ -7,7 +7,8 @@
@@ -8,6 +10,6 @@
+pyaff_la_LIBADD = @top_builddir@/lib/libafflib.la
pyaff_la_CPPFLAGS = $(PYTHON_CPPFLAGS)
-pyaff_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
-+pyaff_la_CFLAGS = -shared
++pyaff_la_CFLAGS = $(AM_CFLAGS) -shared
+pyaff_la_LDFLAGS = -module -avoid-version -shared $(PYTHON_LDFLAGS)
endif