summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-07-25 09:24:52 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-07-25 09:24:52 +0000
commitffe3f72e46d7a7c144af3a764568ec2d0772984d (patch)
treeb3b833dff8f4b203eeb0968bf181253919591e4d /app-emulation
parentClean up old revisions. (diff)
downloadgentoo-2-ffe3f72e46d7a7c144af3a764568ec2d0772984d.tar.gz
gentoo-2-ffe3f72e46d7a7c144af3a764568ec2d0772984d.tar.bz2
gentoo-2-ffe3f72e46d7a7c144af3a764568ec2d0772984d.zip
Version bump (bug #376269).
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice-vdagent/ChangeLog8
-rw-r--r--app-emulation/spice-vdagent/files/spice-vdagent.initd5
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.8.1.ebuild50
3 files changed, 61 insertions, 2 deletions
diff --git a/app-emulation/spice-vdagent/ChangeLog b/app-emulation/spice-vdagent/ChangeLog
index 93a23bf47bde..2b03163229a8 100644
--- a/app-emulation/spice-vdagent/ChangeLog
+++ b/app-emulation/spice-vdagent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spice-vdagent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.1 2011/05/11 09:02:31 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.2 2011/07/25 09:24:52 dev-zero Exp $
+
+*spice-vdagent-0.8.1 (25 Jul 2011)
+
+ 25 Jul 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +spice-vdagent-0.8.1.ebuild, files/spice-vdagent.initd:
+ Version bump (bug #376269).
*spice-vdagent-0.8.0 (11 May 2011)
diff --git a/app-emulation/spice-vdagent/files/spice-vdagent.initd b/app-emulation/spice-vdagent/files/spice-vdagent.initd
index 3d8f71ab00d9..08b685c98251 100644
--- a/app-emulation/spice-vdagent/files/spice-vdagent.initd
+++ b/app-emulation/spice-vdagent/files/spice-vdagent.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/files/spice-vdagent.initd,v 1.1 2011/05/11 09:02:31 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/files/spice-vdagent.initd,v 1.2 2011/07/25 09:24:52 dev-zero Exp $
depend() {
after dbus
@@ -26,6 +26,9 @@ start() {
fi
eend 0
+ # recreate the directory since /var/run may reside on a ramdisk
+ mkdir -p /var/run/spice-vdagentd
+
# cleanup stalled socket
rm -f /var/run/spice-vdagentd/spice-vdagent-sock
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.8.1.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.8.1.ebuild
new file mode 100644
index 000000000000..84e4fe8907f1
--- /dev/null
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/spice-vdagent-0.8.1.ebuild,v 1.1 2011/07/25 09:24:52 dev-zero Exp $
+
+EAPI=4
+
+inherit linux-info
+
+DESCRIPTION="SPICE VD Linux Guest Agent."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+consolekit"
+
+RDEPEND="x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ >=app-emulation/spice-protocol-0.8.1
+ consolekit? ( sys-auth/consolekit sys-apps/dbus )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+CONFIG_CHECK="INPUT_UINPUT"
+ERROR_INPUT_UINPUT="User level driver support is required to run the spice-vdagent daemon"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ $(use_enable consolekit console-kit)
+}
+
+src_install() {
+ default
+
+ rm -rf "${D}"/etc/{rc,tmpfiles}.d
+
+ keepdir /var/run/spice-vdagentd
+ keepdir /var/log/spice-vdagentd
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+}
+
+pkg_postinst() {
+ elog "Make sure that the User level driver support kernel module 'uinput' is loaded"
+ elog "if built as a module before starting the vdagent daemon."
+}