summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-12 01:51:26 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-12 01:51:26 +0000
commitfea42b6bf1de1fecc1880da72e835d4f953d22fa (patch)
treebe5f8142e34f6f24adb17a1f55bdf1361d25e0cb /app-emulation
parentdev-vcs/svneverever: Remove cruft (diff)
downloadgentoo-2-fea42b6bf1de1fecc1880da72e835d4f953d22fa.tar.gz
gentoo-2-fea42b6bf1de1fecc1880da72e835d4f953d22fa.tar.bz2
gentoo-2-fea42b6bf1de1fecc1880da72e835d4f953d22fa.zip
Update required kernel options for different configs
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog6
-rw-r--r--app-emulation/libvirt/libvirt-1.0.3-r2.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-1.0.4.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-1.0.5.ebuild7
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild7
5 files changed, 25 insertions, 9 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 05ef1509cf49..30ea5edfc7b8 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.266 2013/05/10 09:42:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.267 2013/05/12 01:51:26 cardoe Exp $
+
+ 12 May 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.0.3-r2.ebuild,
+ libvirt-1.0.4.ebuild, libvirt-1.0.5.ebuild, libvirt-9999.ebuild:
+ Update required kernel options for different configs
10 May 2013; Agostino Sarubbo <ago@gentoo.org> libvirt-1.0.3-r2.ebuild:
Stable for x86, wrt bug #469244
diff --git a/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild b/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
index 5811910fc46d..04c0b90e126b 100644
--- a/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild,v 1.5 2013/05/10 09:42:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.3-r2.ebuild,v 1.6 2013/05/12 01:51:26 cardoe Exp $
EAPI=5
@@ -138,8 +138,11 @@ LXC_CONFIG_CHECK="
VIRTNET_CONFIG_CHECK="
~BRIDGE_NF_EBTABLES
+ ~BRIDGE_EBT_MARK_T
~NETFILTER_ADVANCED
~NETFILTER_XT_TARGET_CHECKSUM
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MARK
"
MACVTAP_CONFIG_CHECK="~MACVTAP"
@@ -162,7 +165,7 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
- kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
diff --git a/app-emulation/libvirt/libvirt-1.0.4.ebuild b/app-emulation/libvirt/libvirt-1.0.4.ebuild
index 69876b2ba0b6..86e74dae7336 100644
--- a/app-emulation/libvirt/libvirt-1.0.4.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.4.ebuild,v 1.2 2013/05/10 05:06:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.4.ebuild,v 1.3 2013/05/12 01:51:26 cardoe Exp $
EAPI=5
@@ -138,8 +138,11 @@ LXC_CONFIG_CHECK="
VIRTNET_CONFIG_CHECK="
~BRIDGE_NF_EBTABLES
+ ~BRIDGE_EBT_MARK_T
~NETFILTER_ADVANCED
~NETFILTER_XT_TARGET_CHECKSUM
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MARK
"
MACVTAP_CONFIG_CHECK="~MACVTAP"
@@ -162,7 +165,7 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
- kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
diff --git a/app-emulation/libvirt/libvirt-1.0.5.ebuild b/app-emulation/libvirt/libvirt-1.0.5.ebuild
index 964ec3ff2a41..f6612b4926e8 100644
--- a/app-emulation/libvirt/libvirt-1.0.5.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.ebuild,v 1.2 2013/05/10 05:06:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.ebuild,v 1.3 2013/05/12 01:51:26 cardoe Exp $
EAPI=5
@@ -138,8 +138,11 @@ LXC_CONFIG_CHECK="
VIRTNET_CONFIG_CHECK="
~BRIDGE_NF_EBTABLES
+ ~BRIDGE_EBT_MARK_T
~NETFILTER_ADVANCED
~NETFILTER_XT_TARGET_CHECKSUM
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MARK
"
MACVTAP_CONFIG_CHECK="~MACVTAP"
@@ -162,7 +165,7 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
- kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index c83f7a9cd908..61f089242766 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.46 2013/05/10 05:06:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.47 2013/05/12 01:51:26 cardoe Exp $
EAPI=5
@@ -138,8 +138,11 @@ LXC_CONFIG_CHECK="
VIRTNET_CONFIG_CHECK="
~BRIDGE_NF_EBTABLES
+ ~BRIDGE_EBT_MARK_T
~NETFILTER_ADVANCED
~NETFILTER_XT_TARGET_CHECKSUM
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MARK
"
MACVTAP_CONFIG_CHECK="~MACVTAP"
@@ -162,7 +165,7 @@ pkg_setup() {
# Handle specific kernel versions for different features
kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
- kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""