summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-05 18:32:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-05 18:32:44 +0000
commitfcd545d6c979b35b759d5c62494b682c91daaff5 (patch)
tree6e174442b3e53e10d51db0cf2b14cd15d906ce21 /app-emulation
parentMark 1.610.0 stable for x86. Drop 1.61 (diff)
downloadgentoo-2-fcd545d6c979b35b759d5c62494b682c91daaff5.tar.gz
gentoo-2-fcd545d6c979b35b759d5c62494b682c91daaff5.tar.bz2
gentoo-2-fcd545d6c979b35b759d5c62494b682c91daaff5.zip
Version bump; also includes fixes for the init script, closing bugs #379679 and #379683 by George Georgiev.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxc/ChangeLog9
-rw-r--r--app-emulation/lxc/files/lxc.initd19
-rw-r--r--app-emulation/lxc/lxc-0.7.5.ebuild (renamed from app-emulation/lxc/lxc-0.7.4.1-r1.ebuild)34
3 files changed, 30 insertions, 32 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index 5f36bf6eb8d3..f5e51d06f862 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.25 2011/07/26 13:39:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.26 2011/09/05 18:32:44 flameeyes Exp $
+
+*lxc-0.7.5 (05 Sep 2011)
+
+ 05 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org> -lxc-0.7.4.1-r1.ebuild,
+ +lxc-0.7.5.ebuild, files/lxc.initd:
+ Version bump; also includes fixes for the init script, closing bugs #379679
+ and #379683 by George Georgiev.
*lxc-0.7.4.2 (26 Jul 2011)
diff --git a/app-emulation/lxc/files/lxc.initd b/app-emulation/lxc/files/lxc.initd
index 6937901e4a81..16b5140e4bc0 100644
--- a/app-emulation/lxc/files/lxc.initd
+++ b/app-emulation/lxc/files/lxc.initd
@@ -1,15 +1,12 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd,v 1.5 2011/05/06 11:03:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd,v 1.6 2011/09/05 18:32:44 flameeyes Exp $
CONTAINER=${SVCNAME#*.}
-CONFIGFILE=${CONFIGFILE:-/etc/lxc/${CONTAINER}.conf}
lxc_get_configfile() {
- if [ -n "${CONFIGFILE}" ]; then
- echo "${CONFIGFILE}"
- elif [ -f "/etc/lxc/${CONTAINER}.conf" ]; then
+ if [ -f "/etc/lxc/${CONTAINER}.conf" ]; then
echo "/etc/lxc/${CONTAINER}.conf"
elif [ -f "/etc/lxc/${CONTAINER}/config" ]; then
echo "/etc/lxc/${CONTAINER}/config"
@@ -21,8 +18,10 @@ lxc_get_configfile() {
fi
}
+CONFIGFILE=${CONFIGFILE:-$(lxc_get_configfile)}
+
lxc_get_var() {
- awk 'BEGIN { FS="[ \t]*=[ \t]*" } $1 == "'$1'" { print $2; exit }' $(lxc_get_configfile)
+ awk 'BEGIN { FS="[ \t]*=[ \t]*" } $1 == "'$1'" { print $2; exit }' ${CONFIGFILE}
}
cgroup_get_mount() {
@@ -37,7 +36,7 @@ checkconfig() {
fi
# no need to output anything, the function takes care of that.
- [ -z "$(lxc_get_configfile)" ] && return 1
+ [ -z "${CONFIGFILE}" ] && return 1
utsname=$(lxc_get_var lxc.utsname)
if [ ${CONTAINER} != ${utsname} ]; then
@@ -52,14 +51,14 @@ depend() {
# non-muxed init script, unfortunately.
checkconfig 2>/dev/null || return 0
- config $(lxc_get_configfile)
+ config ${CONFIGFILE}
need localmount
# find out which network interface the container is linked to,
# and then require that to be enabled, so that the
# dependencies are correct.
netif=$(lxc_get_var lxc.network.link)
- [ -n "${netif}" ] && need net.${netif}
+ [ -n "${netif}" ] && use net.${netif}
}
start() {
@@ -93,7 +92,7 @@ start() {
esac
ebegin "Starting ${CONTAINER}"
- env -i ${setarch} $(type -p lxc-start) -l WARN -n ${CONTAINER} -f $(lxc_get_configfile) -d -o /var/log/lxc/${CONTAINER}.log
+ env -i ${setarch} $(type -p lxc-start) -l WARN -n ${CONTAINER} -f ${CONFIGFILE} -d -o /var/log/lxc/${CONTAINER}.log
sleep 0.5
# lxc-start -d will _always_ report a correct startup, even if it
diff --git a/app-emulation/lxc/lxc-0.7.4.1-r1.ebuild b/app-emulation/lxc/lxc-0.7.5.ebuild
index 4a50eb3f2f08..53fe91a015aa 100644
--- a/app-emulation/lxc/lxc-0.7.4.1-r1.ebuild
+++ b/app-emulation/lxc/lxc-0.7.5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.4.1-r1.ebuild,v 1.2 2011/07/05 02:46:37 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.5.ebuild,v 1.1 2011/09/05 18:32:44 flameeyes Exp $
-EAPI="2"
+EAPI="4"
MY_P="${P/_/-}"
-inherit eutils linux-info versionator base
+inherit eutils linux-info versionator flag-o-matic
DESCRIPTION="LinuX Containers userspace utilities"
HOMEPAGE="http://lxc.sourceforge.net/"
@@ -17,12 +17,12 @@ KEYWORDS="~amd64 ~ppc64 ~x86"
LICENSE="LGPL-3"
SLOT="0"
-IUSE="doc examples vanilla"
+IUSE="examples vanilla"
RDEPEND="sys-libs/libcap"
DEPEND="${RDEPEND}
- doc? ( app-text/docbook-sgml-utils )
+ app-text/docbook-sgml-utils
>=sys-kernel/linux-headers-2.6.29"
# For init script, so protect with vanilla, they are not strictly
@@ -34,7 +34,7 @@ RDEPEND="${RDEPEND}
)"
CONFIG_CHECK="~CGROUPS
- ~CGROUP_NS ~CPUSETS ~CGROUP_CPUACCT
+ ~CPUSETS ~CGROUP_CPUACCT
~RESOURCE_COUNTERS ~CGROUP_MEM_RES_CTLR
~CGROUP_SCHED
@@ -56,7 +56,11 @@ ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
ERROR_VETH="CONFIG_VETH: needed for internal (host-to-container) networking"
ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+DOCS=(AUTHORS CONTRIBUTING MAINTAINERS NEWS TODO README doc/FAQ.txt)
+
src_configure() {
+ append-flags -fno-strict-aliasing
+
econf \
--localstatedir=/var \
--bindir=/usr/sbin \
@@ -64,24 +68,12 @@ src_configure() {
--with-config-path=/etc/lxc \
--with-rootfs-path=/usr/lib/lxc/rootfs \
--with-linuxdir="${KERNEL_DIR}" \
- $(use_enable doc) \
- $(use_enable examples) \
- || die "configure failed"
+ --enable-doc \
+ $(use_enable examples)
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dodoc AUTHORS CONTRIBUTING MAINTAINERS \
- NEWS TODO README doc/FAQ.txt || die "dodoc failed"
-
- # If the documentation is going to be rebuilt, the Makefiles will
- # install the man pages themselves; if we're not going to, we
- # still need to install them, as they are provided with the
- # tarball in recent versions.
- if ! use doc; then
- doman doc/*.{1,5,7} || die
- fi
+ default
rm -r "${D}"/usr/sbin/lxc-{setcap,ls} \
"${D}"/usr/share/man/man1/lxc-ls.1 \