summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-04-29 01:59:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-04-29 01:59:15 +0000
commitf4722a7913d2e4d650aa4c3b60bdfa97d9cd3e81 (patch)
tree8eb767aead6f0021d207f894f0c828eddae5fd36 /app-emulation
parentdrop older versions (diff)
downloadgentoo-2-f4722a7913d2e4d650aa4c3b60bdfa97d9cd3e81.tar.gz
gentoo-2-f4722a7913d2e4d650aa4c3b60bdfa97d9cd3e81.tar.bz2
gentoo-2-f4722a7913d2e4d650aa4c3b60bdfa97d9cd3e81.zip
bump versions to the latest versions. The goal is going to be to stabilize the 2.6.32.x series while maintaining 2.6.3x at the cutting edge to test with. Useful for people who don't want to constantly upgrade their kernel to get the latest KVM updates.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog12
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.32.12.ebuild66
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.33.3.ebuild66
3 files changed, 143 insertions, 1 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index 93a8b620872d..a85dd8d9c5d6 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.9 2010/04/29 01:55:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.10 2010/04/29 01:59:15 cardoe Exp $
+
+*kvm-kmod-2.6.33.3 (29 Apr 2010)
+*kvm-kmod-2.6.32.12 (29 Apr 2010)
+
+ 29 Apr 2010; Doug Goldstein <cardoe@gentoo.org>
+ +kvm-kmod-2.6.32.12.ebuild, +kvm-kmod-2.6.33.3.ebuild:
+ bump versions to the latest versions. The goal is going to be to stabilize
+ the 2.6.32.x series while maintaining 2.6.3x at the cutting edge to test
+ with. Useful for people who don't want to constantly upgrade their kernel
+ to get the latest KVM updates.
29 Apr 2010; Doug Goldstein <cardoe@gentoo.org> -kvm-kmod-2.6.32.2.ebuild,
-kvm-kmod-2.6.32.3.ebuild:
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.12.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.12.ebuild
new file mode 100644
index 000000000000..76e0845633cf
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.12.ebuild,v 1.1 2010/04/29 01:59:15 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.33.3.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.33.3.ebuild
new file mode 100644
index 000000000000..f97b6e41b65f
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.33.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.33.3.ebuild,v 1.1 2010/04/29 01:59:15 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}