summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-05-02 20:05:35 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-05-02 20:05:35 +0000
commitf3be1e5bb43ca55b684b9ba23b227843f0677873 (patch)
treed8261380db14fd85902d2bdcdac38e2da4bb2514 /app-emulation
parentAdd back rcairo 1.8.1 until newer versions go together with media-sound/rubyr... (diff)
downloadgentoo-2-f3be1e5bb43ca55b684b9ba23b227843f0677873.tar.gz
gentoo-2-f3be1e5bb43ca55b684b9ba23b227843f0677873.tar.bz2
gentoo-2-f3be1e5bb43ca55b684b9ba23b227843f0677873.zip
Version bump. WRT bug #351726
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fuse-utils/ChangeLog8
-rw-r--r--app-emulation/fuse-utils/files/fuse-utils-1.0.0-libgcrypt.patch36
-rw-r--r--app-emulation/fuse-utils/fuse-utils-1.0.0.ebuild41
-rw-r--r--app-emulation/fuse-utils/metadata.xml4
4 files changed, 88 insertions, 1 deletions
diff --git a/app-emulation/fuse-utils/ChangeLog b/app-emulation/fuse-utils/ChangeLog
index 0402a111c63d..4faa25a935f3 100644
--- a/app-emulation/fuse-utils/ChangeLog
+++ b/app-emulation/fuse-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/fuse-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse-utils/ChangeLog,v 1.10 2011/01/18 17:11:34 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse-utils/ChangeLog,v 1.11 2011/05/02 20:05:35 neurogeek Exp $
+
+*fuse-utils-1.0.0 (02 May 2011)
+
+ 02 May 2011; Jesus Rivero <neurogeek@gentoo.org> +fuse-utils-1.0.0.ebuild,
+ +files/fuse-utils-1.0.0-libgcrypt.patch, metadata.xml:
+ Version bump. WRT bug #351726
18 Jan 2011; <neurogeek@gentoo.org> metadata.xml:
Changed metadata.xml for coherence with app-emulation/fuse
diff --git a/app-emulation/fuse-utils/files/fuse-utils-1.0.0-libgcrypt.patch b/app-emulation/fuse-utils/files/fuse-utils-1.0.0-libgcrypt.patch
new file mode 100644
index 000000000000..6212cf670b4a
--- /dev/null
+++ b/app-emulation/fuse-utils/files/fuse-utils-1.0.0-libgcrypt.patch
@@ -0,0 +1,36 @@
+--- configure.in 2010-12-16 21:47:12.000000000 +0000
++++ configure.in 2011-02-03 19:13:29.000000000 +0000
+@@ -48,12 +48,16 @@
+ LDFLAGS="$LDFLAGS -L$prefix/lib"
+ fi)
+
+-dnl Check that libgcrypt is available
+-AC_CHECK_LIB(gcrypt,gcry_check_version,
+- AC_DEFINE([HAVE_LIBGCRYPT], 1, [Defined if we've got libgcrypt])
+- GCRYPT_LIBS="$LIBS -lgcrypt"
+- gcrypt=yes
+-)
++dnl Check whether to use libgcrypt
++AC_MSG_CHECKING(whether to use libgcrypt)
++AC_ARG_WITH(libgcrypt,
++[ --without-libgcrypt don't use libgcrypt],
++if test "$withval" = no; then libgcrypt=no; else libgcrypt=yes; fi,
++libgcrypt=yes)
++AC_MSG_RESULT($libgcrypt)
++if test "$libgcrypt" = yes; then
++ AC_CHECK_HEADERS(gcrypt.h,LIBS="$LIBS -lgcrypt")
++fi
+ AC_SUBST(GCRYPT_LIBS)
+ AM_CONDITIONAL(BUILD_RZXCHECK, test "$gcrypt" = yes)
+
+--- audio2tape.h 2010-12-16 21:47:12.000000000 +0000
++++ audio2tape.h 2011-02-03 19:13:02.000000000 +0000
+@@ -26,6 +26,8 @@
+ #ifndef AUDIO2TAPE_H
+ #define AUDIO2TAPE_H
+
++#include <string.h>
++
+ class audio2tape_exception : public std::exception
+ {
+ public:
diff --git a/app-emulation/fuse-utils/fuse-utils-1.0.0.ebuild b/app-emulation/fuse-utils/fuse-utils-1.0.0.ebuild
new file mode 100644
index 000000000000..f944ee90c37a
--- /dev/null
+++ b/app-emulation/fuse-utils/fuse-utils-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fuse-utils/fuse-utils-1.0.0.ebuild,v 1.1 2011/05/02 20:05:35 neurogeek Exp $
+
+EAPI="3"
+
+DESCRIPTION="Utils for the Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audiofile gcrypt"
+
+RDEPEND="~app-emulation/libspectrum-1.0.0[gcrypt?]
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-libgcrypt.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with audiofile ) \
+ $(use_with gcrypt libgcrypt) \
+ || die "Configure failed!"
+}
+
+src_compile() {
+ emake || die "Make failed!"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ doman man/*.1
+}
diff --git a/app-emulation/fuse-utils/metadata.xml b/app-emulation/fuse-utils/metadata.xml
index a0ff0a203f89..e81ba224a8e5 100644
--- a/app-emulation/fuse-utils/metadata.xml
+++ b/app-emulation/fuse-utils/metadata.xml
@@ -12,4 +12,8 @@
<description>Proxied Maintainer. Please assign on bugs.</description>
<name>José Manuel Ferrer Ortiz</name>
</maintainer>
+ <use>
+ <flag name='gcrypt'>Use <pkg>dev-libs/libgcrypt</pkg> for low-level crypto of some
+ features, including logfiles.</flag>
+ </use>
</pkgmetadata>