summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-12 23:04:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-12 23:04:35 +0000
commiteeb0c6573c97b05c54490beb5cd31c1635fd7d00 (patch)
tree3d7d376da4bd9768ded390e861361a90745a73b4 /app-emulation
parentadd desktop entry support (bug #109043) (diff)
downloadgentoo-2-eeb0c6573c97b05c54490beb5cd31c1635fd7d00.tar.gz
gentoo-2-eeb0c6573c97b05c54490beb5cd31c1635fd7d00.tar.bz2
gentoo-2-eeb0c6573c97b05c54490beb5cd31c1635fd7d00.zip
Version bump #109055 by Jose Marino.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog16
-rw-r--r--app-emulation/cedega/cedega-4.4.2.ebuild56
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.4.21
3 files changed, 62 insertions, 11 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 186b4983b21d..b7094328d2cc 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.17 2005/09/03 22:07:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.18 2005/10/12 23:04:35 vapier Exp $
- 03 Sep 2005; Jeremy Huddleston <eradicator@gentoo.org>
- cedega-4.2.1.ebuild, cedega-4.3.ebuild, cedega-4.3.1.ebuild,
- cedega-4.3.2.ebuild, cedega-4.4.ebuild, cedega-4.4.1.ebuild:
- Added required deps to work on amd64.
+*cedega-4.4.2 (12 Oct 2005)
+
+ 12 Oct 2005; Mike Frysinger <vapier@gentoo.org> +cedega-4.4.2.ebuild:
+ Version bump #109055 by Jose Marino.
*cedega-4.4.1 (12 Aug 2005)
@@ -62,12 +62,6 @@
14 Aug 2004; Mike Frysinger <vapier@gentoo.org> +cedega-4.0.1.ebuild:
Version bump #59989 by John5788.
- 26 Jul 2004; Danny van Dyk <kugelfang@gentoo.org> cedega-4.0.ebuild:
- Marked ~amd64.
-
- 24 Jun 2004; Martin Holzer <mholzer@gentoo.org> cedega-4.0.ebuild:
- fixing einfo
-
*cedega-4.0 (23 Jun 2004)
23 Jun 2004; Alex Veber <coronalvr@gentoo.org> +cedega-4.0.ebuild:
diff --git a/app-emulation/cedega/cedega-4.4.2.ebuild b/app-emulation/cedega/cedega-4.4.2.ebuild
new file mode 100644
index 000000000000..e0d174e636c7
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.4.2.ebuild,v 1.1 2005/10/12 23:04:35 vapier Exp $
+
+MY_P="cedega_${PV}-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.4.2 b/app-emulation/cedega/files/digest-cedega-4.4.2
new file mode 100644
index 000000000000..bac680f70f68
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.4.2
@@ -0,0 +1 @@
+MD5 f602043649dfd5d19859a83203c444b2 cedega_4.4.2-1.i386.tgz 7653025