summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-04-28 16:47:33 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-04-28 16:47:33 +0000
commite9b4d4c37468bc391c4c315373e46a120028d098 (patch)
treecb32bd34ddbe394f4b3d7d2774ae8a2a61596d8f /app-emulation
parentstable x86. (Manifest recommit) (diff)
downloadgentoo-2-e9b4d4c37468bc391c4c315373e46a120028d098.tar.gz
gentoo-2-e9b4d4c37468bc391c4c315373e46a120028d098.tar.bz2
gentoo-2-e9b4d4c37468bc391c4c315373e46a120028d098.zip
new version, again
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog8
-rw-r--r--app-emulation/qemu/Manifest5
-rw-r--r--app-emulation/qemu/files/digest-qemu-0.5.41
-rw-r--r--app-emulation/qemu/files/qemu-0.5.4-jocelyn-mayer-ppc.patch160
-rw-r--r--app-emulation/qemu/qemu-0.5.3.ebuild4
-rw-r--r--app-emulation/qemu/qemu-0.5.4.ebuild50
6 files changed, 224 insertions, 4 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index d8b360f206db..e1b9e550acc8 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.7 2004/04/27 21:27:12 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.8 2004/04/28 16:47:33 lu_zero Exp $
+
+*qemu-0.5.4 (28 Apr 2004)
+
+ 28 Apr 2004; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.5.4-jocelyn-mayer-ppc.patch, +qemu-0.5.4.ebuild:
+ New version
27 Apr 2004; Luca Barbato <lu_zero@gentoo.org> qemu-0.5.3.ebuild:
Removed the softmmu target
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 55714491d211..68c0a1916ab5 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,8 +1,11 @@
MD5 f41aa55eaa380d398106f1dfe30a68b2 qemu-0.5.3.ebuild 1139
-MD5 fe857a2ad8bad137fee899f894e796f1 ChangeLog 942
+MD5 8712157f0d2066f9ad24578837b4c64f ChangeLog 1098
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
+MD5 5283be76a0a717acbe8b920d2970e329 qemu-0.5.4.ebuild 1246
MD5 3f69424d19df7ca55325286f36fd6973 qemu-0.5.1.ebuild 1268
MD5 2af14a088decec02f8898b702caf1620 qemu-0.5.2.ebuild 1263
MD5 0c6b253eac2104422e703ff88143185a files/digest-qemu-0.5.3 62
MD5 88e94451ca673f24fe04a290f6675c88 files/digest-qemu-0.5.1 62
+MD5 62d5623a299bcc726e288cf573600681 files/qemu-0.5.4-jocelyn-mayer-ppc.patch 5341
+MD5 db8dd5ec671adf9b083ee0ab605a10b7 files/digest-qemu-0.5.4 62
MD5 786f98412b9ce8febf208cf9be8e38f6 files/digest-qemu-0.5.2 62
diff --git a/app-emulation/qemu/files/digest-qemu-0.5.4 b/app-emulation/qemu/files/digest-qemu-0.5.4
new file mode 100644
index 000000000000..2fd872f8bd91
--- /dev/null
+++ b/app-emulation/qemu/files/digest-qemu-0.5.4
@@ -0,0 +1 @@
+MD5 4880e253de75ebaf0673428388232797 qemu-0.5.4.tar.gz 748094
diff --git a/app-emulation/qemu/files/qemu-0.5.4-jocelyn-mayer-ppc.patch b/app-emulation/qemu/files/qemu-0.5.4-jocelyn-mayer-ppc.patch
new file mode 100644
index 000000000000..9f72fb1b9efb
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.5.4-jocelyn-mayer-ppc.patch
@@ -0,0 +1,160 @@
+Index: hw/vga.c
+===================================================================
+RCS file: /cvsroot/qemu/qemu/hw/vga.c,v
+retrieving revision 1.23
+diff -u -d -w -B -b -d -p -r1.23 vga.c
+--- hw/vga.c 26 Apr 2004 19:44:02 -0000 1.23
++++ hw/vga.c 28 Apr 2004 00:03:16 -0000
+@@ -33,6 +33,16 @@
+ /* S3 VGA is deprecated - another graphic card will be emulated */
+ //#define CONFIG_S3VGA
+
++/* XXX: should go in target definition */
++#if defined (TARGET_I386)
++#define ISA_MEM_BASE (target_phys_addr_t)(0x00000000)
++#elif defined (TARGET_PPC)
++/* Note: this true only for PREP platform */
++#define ISA_MEM_BASE (target_phys_addr_t)(0xc0000000)
++#else
++#error "Please define IO memory base for the emulated target"
++#endif
++
+ #define MSR_COLOR_EMULATION 0x01
+ #define MSR_PAGE_SELECT 0x20
+
+@@ -92,7 +102,7 @@ typedef struct VGAState {
+ uint8_t dac_write_index;
+ uint8_t dac_cache[3]; /* used when writing */
+ uint8_t palette[768];
+- int32_t bank_offset;
++ target_phys_addr_t bank_offset;
+ #ifdef CONFIG_BOCHS_VBE
+ uint16_t vbe_index;
+ uint16_t vbe_regs[VBE_DISPI_INDEX_NB];
+@@ -549,7 +559,8 @@ static void vbe_ioport_write(void *opaqu
+ case VBE_DISPI_INDEX_BANK:
+ val &= s->vbe_bank_mask;
+ s->vbe_regs[s->vbe_index] = val;
+- s->bank_offset = (val << 16) - 0xa0000;
++
++ s->bank_offset = -(val << 16) - (0xa0000 + ISA_MEM_BASE);
+ break;
+ case VBE_DISPI_INDEX_ENABLE:
+ if (val & VBE_DISPI_ENABLED) {
+@@ -603,7 +614,7 @@ static void vbe_ioport_write(void *opaqu
+ s->vbe_regs[s->vbe_index] = val;
+ } else {
+ /* XXX: the bios should do that */
+- s->bank_offset = -0xa0000;
++ s->bank_offset = -(0xa0000 + ISA_MEM_BASE);
+ }
+ break;
+ case VBE_DISPI_INDEX_VIRT_WIDTH:
+@@ -658,22 +669,22 @@ static uint32_t vga_mem_readb(target_phy
+ memory_map_mode = (s->gr[6] >> 2) & 3;
+ switch(memory_map_mode) {
+ case 0:
+- addr -= 0xa0000;
++ addr -= 0xa0000 + ISA_MEM_BASE;
+ break;
+ case 1:
+- if (addr >= 0xb0000)
++ if (addr >= 0xb0000 + ISA_MEM_BASE)
+ return 0xff;
+ addr += s->bank_offset;
+ break;
+ case 2:
+- addr -= 0xb0000;
+- if (addr >= 0x8000)
++ addr -= 0xb0000 + ISA_MEM_BASE;
++ if (addr >= 0x8000 + ISA_MEM_BASE)
+ return 0xff;
+ break;
+ default:
+ case 3:
+- addr -= 0xb8000;
+- if (addr >= 0x8000)
++ addr -= 0xb8000 + ISA_MEM_BASE;
++ if (addr >= 0x8000 + ISA_MEM_BASE)
+ return 0xff;
+ break;
+ }
+@@ -736,22 +747,22 @@ static void vga_mem_writeb(target_phys_a
+ memory_map_mode = (s->gr[6] >> 2) & 3;
+ switch(memory_map_mode) {
+ case 0:
+- addr -= 0xa0000;
++ addr -= 0xa0000 + ISA_MEM_BASE;
+ break;
+ case 1:
+- if (addr >= 0xb0000)
++ if (addr >= 0xb0000 + ISA_MEM_BASE)
+ return;
+ addr += s->bank_offset;
+ break;
+ case 2:
+- addr -= 0xb0000;
+- if (addr >= 0x8000)
++ addr -= 0xb0000 + ISA_MEM_BASE;
++ if (addr >= 0x8000 + ISA_MEM_BASE)
+ return;
+ break;
+ default:
+ case 3:
+- addr -= 0xb8000;
+- if (addr >= 0x8000)
++ addr -= 0xb8000 + ISA_MEM_BASE;
++ if (addr >= 0x8000 + ISA_MEM_BASE)
+ return;
+ break;
+ }
+@@ -1642,7 +1653,11 @@ static void vga_save(QEMUFile *f, void *
+ qemu_put_buffer(f, s->dac_cache, 3);
+ qemu_put_buffer(f, s->palette, 768);
+
++#if TARGET_PHYS_ADDR_BITS == 32
+ qemu_put_be32s(f, &s->bank_offset);
++#elif TARGET_PHYS_ADDR_BITS == 64
++ qemu_put_be64s(f, &s->bank_offset);
++#endif
+ #ifdef CONFIG_BOCHS_VBE
+ qemu_put_byte(f, 1);
+ qemu_put_be16s(f, &s->vbe_index);
+@@ -1686,7 +1701,11 @@ static int vga_load(QEMUFile *f, void *o
+ qemu_get_buffer(f, s->dac_cache, 3);
+ qemu_get_buffer(f, s->palette, 768);
+
++#if TARGET_PHYS_ADDR_BITS == 32
+ qemu_get_be32s(f, &s->bank_offset);
++#elif TARGET_PHYS_ADDR_BITS == 64
++ qemu_get_be64s(f, &s->bank_offset);
++#endif
+ is_vbe = qemu_get_byte(f);
+ #ifdef CONFIG_BOCHS_VBE
+ if (!is_vbe)
+@@ -1758,7 +1777,7 @@ int vga_initialize(DisplayState *ds, uin
+ register_ioport_read(0x3d4, 2, 1, vga_ioport_read, s);
+ register_ioport_read(0x3ba, 1, 1, vga_ioport_read, s);
+ register_ioport_read(0x3da, 1, 1, vga_ioport_read, s);
+- s->bank_offset = -0xa0000;
++ s->bank_offset = -(0xa0000 + ISA_MEM_BASE);
+
+ #ifdef CONFIG_BOCHS_VBE
+ s->vbe_regs[VBE_DISPI_INDEX_ID] = VBE_DISPI_ID0;
+@@ -1771,15 +1790,13 @@ int vga_initialize(DisplayState *ds, uin
+ #endif
+
+ vga_io_memory = cpu_register_io_memory(0, vga_mem_read, vga_mem_write);
++ cpu_register_physical_memory(0x000a0000 + ISA_MEM_BASE, 0x20000, vga_io_memory);
+ #if defined (TARGET_I386)
+- cpu_register_physical_memory(0x000a0000, 0x20000, vga_io_memory);
+ #ifdef CONFIG_BOCHS_VBE
+ /* XXX: use optimized standard vga accesses */
+ cpu_register_physical_memory(VBE_DISPI_LFB_PHYSICAL_ADDRESS,
+ vga_ram_size, vga_ram_offset);
+ #endif
+-#elif defined (TARGET_PPC)
+- cpu_register_physical_memory(0xf00a0000, 0x20000, vga_io_memory);
+ #endif
+ return 0;
+ }
diff --git a/app-emulation/qemu/qemu-0.5.3.ebuild b/app-emulation/qemu/qemu-0.5.3.ebuild
index 8c01e0668811..7fd0ac5a54be 100644
--- a/app-emulation/qemu/qemu-0.5.3.ebuild
+++ b/app-emulation/qemu/qemu-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.5.3.ebuild,v 1.2 2004/04/27 21:27:12 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.5.3.ebuild,v 1.3 2004/04/28 16:47:33 lu_zero Exp $
DESCRIPTION="Multi-platform & multi-targets dynamic translator"
SRC_URI="http://fabrice.bellard.free.fr/qemu/${P}.tar.gz"
@@ -17,7 +17,7 @@ RDEPEND=""
RESTRICT="nostrip"
-TARGET_LIST="arm-user i386-user ppc-user sparc-user" #i386-softmmu
+TARGET_LIST="arm-user i386-user ppc-user sparc-user" #i386-softmmu
#RUNTIME_PATH="/emul/gnemul/"
diff --git a/app-emulation/qemu/qemu-0.5.4.ebuild b/app-emulation/qemu/qemu-0.5.4.ebuild
new file mode 100644
index 000000000000..41a5a3ad503c
--- /dev/null
+++ b/app-emulation/qemu/qemu-0.5.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.5.4.ebuild,v 1.1 2004/04/28 16:47:33 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="Multi-platform & multi-targets dynamic translator"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P}.tar.gz"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+
+KEYWORDS="~x86 ~ppc -alpha -sparc"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="virtual/glibc
+ media-libs/libsdl"
+RDEPEND=""
+
+RESTRICT="nostrip"
+
+TARGET_LIST="arm-user i386-user ppc-user sparc-user" #i386-softmmu
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-jocelyn-mayer-ppc.patch
+}
+
+
+src_compile () {
+ ./configure --prefix=/usr \
+ --target-list="${TARGET_LIST}" || die "could not configure"
+ make || die "make failed"
+
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+}
+
+src_install() {
+ make install prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ sharedir=${D}/usr/share/qemu \
+ mandir=${D}/usr/share/man || die
+}
+
+pkg_postinstall() {
+ echo ">> You will need the Universal TUN/TAP driver compiled into"
+ echo ">> kernel or as a module to use the virtual network device."
+}