summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 22:05:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 22:05:50 +0000
commite8757d48db10e5950c5a0e7494e87f0e93eee461 (patch)
tree23fe7812f7f2e62823f11be1c279e087678df07f /app-emulation
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-e8757d48db10e5950c5a0e7494e87f0e93eee461.tar.gz
gentoo-2-e8757d48db10e5950c5a0e7494e87f0e93eee461.tar.bz2
gentoo-2-e8757d48db10e5950c5a0e7494e87f0e93eee461.zip
don't use deprecated ?: use syntax
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uae/ChangeLog6
-rw-r--r--app-emulation/uae/uae-0.8.22.ebuild18
-rw-r--r--app-emulation/uae/uae-0.8.23_pre20040129.ebuild19
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild17
4 files changed, 44 insertions, 16 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 9c85862b1e69..f83458ab02af 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.16 2004/03/07 15:50:34 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.17 2004/03/24 22:05:50 mr_bones_ Exp $
+
+ 24 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> uae-0.8.22.ebuild,
+ uae-0.8.23_pre20040129.ebuild, uae-0.8.25_pre20040302.ebuild:
+ don't use deprecated ?: use syntax
07 Mar 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild:
Replace -O3 with -O2 (again). Splitting cpuemu_6.c was not enough.
diff --git a/app-emulation/uae/uae-0.8.22.ebuild b/app-emulation/uae/uae-0.8.22.ebuild
index febf2bda3562..59be6f216160 100644
--- a/app-emulation/uae/uae-0.8.22.ebuild
+++ b/app-emulation/uae/uae-0.8.22.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.12 2004/01/29 03:26:16 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.13 2004/03/24 22:05:50 mr_bones_ Exp $
+
+inherit eutils
DESCRIPTION="An amiga emulator"
HOMEPAGE="http://www.freiburg.linux.de/~uae/"
@@ -11,7 +13,15 @@ SLOT="0"
KEYWORDS="x86 ~ppc amd64"
IUSE="X gtk svga sdl"
-DEPEND="X? ( virtual/x11 gtk? ( x11-libs/gtk+ ) ) : ( sys-libs/ncurses svga? ( media-libs/svgalib ) )
+DEPEND="virtual/glibc
+ X? (
+ virtual/x11
+ gtk? ( x11-libs/gtk+ )
+ )
+ !X? (
+ sys-libs/ncurses
+ svga? ( media-libs/svgalib )
+ )
sdl? ( media-libs/libsdl )"
src_unpack() {
@@ -23,11 +33,11 @@ src_unpack() {
src_compile() {
local myconf=""
- if [ `use X` ]; then
+ if use X ; then
myconf="--with-x --enable-dga --enable-vidmode --with-sdl --with-sdl-sound --with-sdl-gfx"
myconf="$myconf `use_enable gtk ui`"
else
- if [ `use svga` ]; then
+ if use svga ; then
myconf="--with-svgalib";
else
myconf="--with-asciiart";
diff --git a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
index 31cb77615881..59a6eeffa46c 100644
--- a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
+++ b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.3 2004/02/11 21:04:54 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.4 2004/03/24 22:05:50 mr_bones_ Exp $
inherit flag-o-matic
@@ -13,11 +13,18 @@ SRC_URI="http://www.rcdrummond.net/uae/uae-${MY_PV}/uae-${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="X gtk sdl"
-
-DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
- ( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
- sdl? media-libs/libsdl"
+IUSE="X gtk sdl ncurses svga"
+
+DEPEND="virtual/glibc
+ X? (
+ virtual/x11
+ gtk? ( x11-libs/gtk+ )
+ )
+ !X? (
+ ncurses? ( sys-libs/ncurses )
+ svga? ( media-libs/svgalib )
+ )
+ sdl? ( media-libs/libsdl )"
src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index 7387b911904a..21e809ac37a7 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.5 2004/03/07 15:51:49 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.6 2004/03/24 22:05:50 mr_bones_ Exp $
inherit flag-o-matic
@@ -13,11 +13,18 @@ SRC_URI="http://www.rcdrummond.net/uae/uae-${MY_PV}/uae-${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="X gtk sdl"
+IUSE="X gtk sdl ncurses svga"
-DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
- ( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
- sdl? media-libs/libsdl
+DEPEND="virtual/glibc
+ X? (
+ virtual/x11
+ gtk? ( x11-libs/gtk+ )
+ )
+ !X? (
+ ncurses? ( sys-libs/ncurses )
+ svga? ( media-libs/svgalib )
+ )
+ sdl? ( media-libs/libsdl )
app-cdr/cdrtools
games-emulation/caps"