summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
commite6086baf08a56b8bc47632d7ac4203bd413d2ab5 (patch)
treebd0d30a582abc1dfaabbc8c3b4da4f714107902d /app-emulation
parentdependency fix (diff)
downloadgentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.tar.gz
gentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.tar.bz2
gentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.zip
New package. Fixes #3266-#3274
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/epsxe/ChangeLog13
-rw-r--r--app-emulation/epsxe/epsxe-1.5.2.ebuild43
-rw-r--r--app-emulation/epsxe/files/digest-epsxe-1.5.21
-rw-r--r--app-emulation/epsxe/files/epsxe30
-rw-r--r--app-emulation/pcsx/ChangeLog13
-rw-r--r--app-emulation/pcsx/files/digest-pcsx-1.21
-rw-r--r--app-emulation/pcsx/files/ix86.h.diff27
-rw-r--r--app-emulation/pcsx/files/pcsx53
-rw-r--r--app-emulation/pcsx/pcsx-1.2.ebuild54
-rw-r--r--app-emulation/psemu-cdr/ChangeLog13
-rw-r--r--app-emulation/psemu-cdr/files/digest-psemu-cdr-1.621
-rw-r--r--app-emulation/psemu-cdr/psemu-cdr-1.62.ebuild26
-rw-r--r--app-emulation/psemu-cdriso/ChangeLog13
-rw-r--r--app-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.21
-rw-r--r--app-emulation/psemu-cdriso/psemu-cdriso-1.2.ebuild29
-rw-r--r--app-emulation/psemu-gpupetemesagl/ChangeLog13
-rw-r--r--app-emulation/psemu-gpupetemesagl/files/digest-psemu-gpupetemesagl-1.6.21
-rw-r--r--app-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.6.2.ebuild21
-rw-r--r--app-emulation/psemu-padjoy/ChangeLog13
-rw-r--r--app-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.611
-rw-r--r--app-emulation/psemu-padjoy/psemu-padjoy-0.61.ebuild26
-rw-r--r--app-emulation/psemu-padxwin/ChangeLog13
-rw-r--r--app-emulation/psemu-padxwin/files/digest-psemu-padxwin-1.41
-rw-r--r--app-emulation/psemu-padxwin/psemu-padxwin-1.4.ebuild26
-rw-r--r--app-emulation/psemu-peopssoftgpu/ChangeLog13
-rw-r--r--app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.61
-rw-r--r--app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild45
-rw-r--r--app-emulation/psemu-peopsspu/ChangeLog13
-rw-r--r--app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.11
-rw-r--r--app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild45
30 files changed, 551 insertions, 0 deletions
diff --git a/app-emulation/epsxe/ChangeLog b/app-emulation/epsxe/ChangeLog
new file mode 100644
index 000000000000..7bbebc8e9b98
--- /dev/null
+++ b/app-emulation/epsxe/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/epsxe
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*epsxe-1.5.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/epsxe/epsxe-1.5.2.ebuild b/app-emulation/epsxe/epsxe-1.5.2.ebuild
new file mode 100644
index 000000000000..ed3007599cc7
--- /dev/null
+++ b/app-emulation/epsxe/epsxe-1.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/epsxe-1.5.2.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+S=${WORKDIR}
+DESCRIPTION="ePSXe Playstation Emulator"
+HOMEPAGE="http://www.epsxe.com"
+LICENSE="Freeware"
+
+use opengl && GLDEPEND="app-emulation/psemu-gpupetemesagl"
+use opengl || GLDEPEND="app-emulation/psemu-peopssoftgpu"
+
+DEPEND="app-arch/unzip"
+RDEPEND="=dev-libs/glib-1.2
+ =x11-libs/gtk+-1.2*
+ =sys-libs/ncurses-5*
+ =sys-libs/zlib-1*
+ net-misc/wget
+ app-emulation/psemu-peopsspu
+ ${GLDEPEND}"
+
+SRC_URI="http://download.epsxe.com/files/epsxe152lin.zip"
+
+# For some strange reason, strip truncates the whole file
+RESTRICT="nostrip"
+
+src_unpack() {
+ unzip ${DISTDIR}/${A}
+}
+
+src_install () {
+ dobin ${FILESDIR}/epsxe
+
+ insinto /opt/epsxe
+ doins epsxe
+ chmod 755 ${D}/opt/epsxe/epsxe
+
+ insinto /usr/lib/psemu/cheats
+ doins cheats/*
+
+ dodoc docs/*
+}
diff --git a/app-emulation/epsxe/files/digest-epsxe-1.5.2 b/app-emulation/epsxe/files/digest-epsxe-1.5.2
new file mode 100644
index 000000000000..cc22445f82b5
--- /dev/null
+++ b/app-emulation/epsxe/files/digest-epsxe-1.5.2
@@ -0,0 +1 @@
+MD5 5834f34cb904b08d95abda057eff3981 epsxe152lin.zip 166559
diff --git a/app-emulation/epsxe/files/epsxe b/app-emulation/epsxe/files/epsxe
new file mode 100644
index 000000000000..d433ba6d37a7
--- /dev/null
+++ b/app-emulation/epsxe/files/epsxe
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+if [ ! -f ~/.epsxe ]; then
+ echo You are running ePSXe for the first time.
+ echo Setting up your ePSXe environment... Please wait...
+
+ mkdir -p $HOME/.epsxe
+ cd $HOME/.epsxe
+ mkdir memcards bios cfg cheats snap sstates patches plugins
+
+ ln -s /usr/lib/psemu/plugins/* plugins/
+ ln -s /opt/epsxe/epsxe epsxe
+
+ cd bios
+ if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
+ ln -s /usr/lib/psemu/bios/scph1001.bin .
+ else
+ wget http://aral3uz.tripod.com/sc.zip
+ unzip -L sc.zip
+ rm -f sc.zip
+ fi
+fi
+
+cd $HOME/.epsxe
+
+ln -s /usr/lib/psemu/plugins/* plugins/
+ln -s /usr/lib/psemu/cfg/* cfg/
+ln -s /usr/lib/psemu/cheats/* cheats/
+
+./epsxe
diff --git a/app-emulation/pcsx/ChangeLog b/app-emulation/pcsx/ChangeLog
new file mode 100644
index 000000000000..0abe4cccc969
--- /dev/null
+++ b/app-emulation/pcsx/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/pcsx
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*pcsx-1.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/pcsx/files/digest-pcsx-1.2 b/app-emulation/pcsx/files/digest-pcsx-1.2
new file mode 100644
index 000000000000..fbe0fec2ce0c
--- /dev/null
+++ b/app-emulation/pcsx/files/digest-pcsx-1.2
@@ -0,0 +1 @@
+MD5 f62a8ec57b4c744e134238b4850b0326 pcsxsrc1.2.zip 232084
diff --git a/app-emulation/pcsx/files/ix86.h.diff b/app-emulation/pcsx/files/ix86.h.diff
new file mode 100644
index 000000000000..2f70ecf9fef4
--- /dev/null
+++ b/app-emulation/pcsx/files/ix86.h.diff
@@ -0,0 +1,27 @@
+--- PcsxSrc/Cpu/ix86/ix86.h.orig Wed Apr 17 15:05:26 2002
++++ PcsxSrc/Cpu/ix86/ix86.h Mon May 27 01:16:45 2002
+@@ -6,6 +6,8 @@
+ #ifndef __IX86_H__
+ #define __IX86_H__
+
++#include "../Common.h"
++
+ // Basic types
+ #if defined(__WIN32__)
+
+@@ -21,6 +23,7 @@
+
+ #elif defined(__LINUX__)
+
++/*
+ typedef char s8;
+ typedef short s16;
+ typedef long s32;
+@@ -30,6 +33,7 @@
+ typedef unsigned short u16;
+ typedef unsigned long u32;
+ typedef unsigned long long u64;
++*/
+
+ #endif
+
diff --git a/app-emulation/pcsx/files/pcsx b/app-emulation/pcsx/files/pcsx
new file mode 100644
index 000000000000..b90d0636c953
--- /dev/null
+++ b/app-emulation/pcsx/files/pcsx
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+if [ ! -f ~/.pcsx/config ]; then
+ echo You are running PCSX for the first time.
+ echo Setting up your PCSX environment... Please wait...
+
+ mkdir -p $HOME/.pcsx
+ cd $HOME/.pcsx
+ mkdir memcards bios cfg plugins
+
+ ln -s /usr/bin/pcsx.bin pcsx
+ ln -s /usr/lib/psemu/plugins/* plugins/
+
+ cat >$HOME/.pcsx/config <<EOF
+Bios = scph1001.bin
+Gpu = $(basename $(echo plugins/libgpu* | cut -f1 -d\ ) )
+Spu = $(basename $(echo plugins/libspu* | cut -f1 -d\ ) )
+Cdr = $(basename $(echo plugins/libcdr* | cut -f1 -d\ ) )
+Pad1 = $(basename $(echo plugins/libpadXwin-* | cut -f1 -d\ ) )
+Pad2 = $(basename $(echo plugins/libpadXwin-* | cut -f1 -d\ ) )
+Mcd1 = $HOME/.pcsx/memcards/Mcd001.mcr
+Mcd2 = $HOME/.pcsx/memcards/Mcd002.mcr
+PluginsDir = $HOME/.pcsx/plugins/
+BiosDir = $HOME/.pcsx/bios/
+Xa = 0
+Sio = 0
+Mdec = 0
+PsxAuto = 1
+PsxType = 0
+Cdda = 0
+Cpu = 0
+PsxOut = 0
+SpuIrq = 0
+CdTiming = 0
+EOF
+
+ cd bios
+ if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
+ ln -s /usr/lib/psemu/bios/scph1001.bin .
+ else
+ wget http://aral3uz.tripod.com/sc.zip
+ unzip -L sc.zip
+ rm -f sc.zip
+ fi
+fi
+
+cd $HOME/.pcsx/
+
+ln -s /usr/lib/psemu/cfg/* cfg/ &>/dev/null
+ln -s /usr/lib/psemu/plugins/* plugins/ &>/dev/null
+
+./pcsx -cfg $HOME/.pcsx/config
+
diff --git a/app-emulation/pcsx/pcsx-1.2.ebuild b/app-emulation/pcsx/pcsx-1.2.ebuild
new file mode 100644
index 000000000000..f9f3c9923188
--- /dev/null
+++ b/app-emulation/pcsx/pcsx-1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/pcsx-1.2.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Playstation emulator"
+HOMEPAGE="http://www.pcsx.net"
+LICENSE="GPL"
+
+use opengl && GLDEPEND="app-emulation/psemu-gpupetemesagl"
+use opengl || GLDEPEND="app-emulation/psemu-peopssoftgpu"
+
+DEPEND="sys-libs/zlib
+ app-arch/unzip
+ x11-libs/gtk+
+ gnome-base/libglade"
+
+RDEPEND="net-misc/wget
+ app-emulation/psemu-cdr
+ app-emulation/psemu-cdriso
+ app-emulation/psemu-padxwin
+ app-emulation/psemu-padjoy
+ app-emulation/psemu-peopsspu
+ ${GLDEPEND}"
+
+SRC_URI="http://www.pcsx.net/downloads/${PN}src${PV}.zip"
+
+src_unpack() {
+ cd ${WORKDIR}
+ set
+ unzip -a ${DISTDIR}/$(echo ${A} | cut -f1 -d\ )
+ patch -p0 < ${FILESDIR}/ix86.h.diff
+}
+
+src_compile() {
+ cd PcsxSrc/Linux
+
+ # Change some defaults...
+ sed -e 's:Plugin/:/usr/lib/psemu/plugins/:' \
+ -e 's:Bios/:/usr/lib/psemu/bios/:' \
+ -e 's:Pcsx.cfg:~/.pcsx/config:' \
+ <LnxMain.c >LnxMain.tmp
+ mv -f LnxMain.tmp LnxMain.c
+
+ emake OPTIMIZE="${CFLAGS} -fPIC -fomit-frame-pointer -finline-functions -ffast-math" || die
+ mv pcsx pcsx.bin
+}
+
+src_install () {
+ dobin PcsxSrc/Linux/pcsx.bin
+ dobin ${FILESDIR}/pcsx
+ dodoc PcsxSrc/Docs/*
+}
diff --git a/app-emulation/psemu-cdr/ChangeLog b/app-emulation/psemu-cdr/ChangeLog
new file mode 100644
index 000000000000..f40de9a01e97
--- /dev/null
+++ b/app-emulation/psemu-cdr/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-cdr
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-cdr/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-cdr (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-cdr/files/digest-psemu-cdr-1.62 b/app-emulation/psemu-cdr/files/digest-psemu-cdr-1.62
new file mode 100644
index 000000000000..5bb965011919
--- /dev/null
+++ b/app-emulation/psemu-cdr/files/digest-psemu-cdr-1.62
@@ -0,0 +1 @@
+MD5 d8a69d63e8fb9b6ef8b1e9d3d158a7f7 cdr-1.62.tgz 12854
diff --git a/app-emulation/psemu-cdr/psemu-cdr-1.62.ebuild b/app-emulation/psemu-cdr/psemu-cdr-1.62.ebuild
new file mode 100644
index 000000000000..5eb2cffc288b
--- /dev/null
+++ b/app-emulation/psemu-cdr/psemu-cdr-1.62.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-cdr/psemu-cdr-1.62.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="PSEmu plugin to read from CD-ROM"
+HOMEPAGE="http://www.pcsx.net"
+LICENSE="GPL-2"
+SRC_URI="http://linux.pcsx.net/downloads/plugins/cdr-${PV}.tgz"
+DEPEND="x11-libs/gtk+"
+S=${WORKDIR}
+
+src_compile() {
+ cd src
+ ( echo CFLAGS = ${CFLAGS}
+ sed 's/CFLAGS =/CFLAGS +=/' < Makefile ) >Makefile.gentoo
+ emake -f Makefile.gentoo
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins/
+ doins src/libcdr-*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ dodoc ReadMe.txt
+}
+
diff --git a/app-emulation/psemu-cdriso/ChangeLog b/app-emulation/psemu-cdriso/ChangeLog
new file mode 100644
index 000000000000..6cca9de84135
--- /dev/null
+++ b/app-emulation/psemu-cdriso/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-cdriso
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-cdriso/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-cdriso-1.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.2 b/app-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.2
new file mode 100644
index 000000000000..e4ecf12bc605
--- /dev/null
+++ b/app-emulation/psemu-cdriso/files/digest-psemu-cdriso-1.2
@@ -0,0 +1 @@
+MD5 ea93d2db91b67843315497b8845da267 cdriso-1.2.tgz 28759
diff --git a/app-emulation/psemu-cdriso/psemu-cdriso-1.2.ebuild b/app-emulation/psemu-cdriso/psemu-cdriso-1.2.ebuild
new file mode 100644
index 000000000000..91c0b284f165
--- /dev/null
+++ b/app-emulation/psemu-cdriso/psemu-cdriso-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-cdriso/psemu-cdriso-1.2.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="PSEmu plugin to read CD-images"
+HOMEPAGE="http://www.pcsx.net"
+LICENSE="GPL-2"
+DEPEND="sys-libs/zlib
+ sys-apps/bzip2
+ x11-libs/gtk+"
+
+SRC_URI="http://linux.pcsx.net/downloads/plugins/cdriso-${PV}.tgz"
+S=${WORKDIR}
+
+src_compile() {
+ cd src
+ ( echo CFLAGS = ${CFLAGS}
+ sed 's/CFLAGS =/CFLAGS +=/' < Makefile ) >Makefile.gentoo
+ emake -f Makefile.gentoo
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins src/libcdr*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ dodoc ReadMe.txt
+}
+
diff --git a/app-emulation/psemu-gpupetemesagl/ChangeLog b/app-emulation/psemu-gpupetemesagl/ChangeLog
new file mode 100644
index 000000000000..30ce3d108b16
--- /dev/null
+++ b/app-emulation/psemu-gpupetemesagl/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-gpupetemesagl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-gpupetemesagl/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-gpupetemesalgl-1.6.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-gpupetemesagl/files/digest-psemu-gpupetemesagl-1.6.2 b/app-emulation/psemu-gpupetemesagl/files/digest-psemu-gpupetemesagl-1.6.2
new file mode 100644
index 000000000000..a8a7e3952d1f
--- /dev/null
+++ b/app-emulation/psemu-gpupetemesagl/files/digest-psemu-gpupetemesagl-1.6.2
@@ -0,0 +1 @@
+MD5 55fe89c22a071a428a6835e175781dbc gpupetemesagl162.tar.gz 180956
diff --git a/app-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.6.2.ebuild b/app-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.6.2.ebuild
new file mode 100644
index 000000000000..cc0f9a16a3d7
--- /dev/null
+++ b/app-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.6.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.6.2.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="PSEmu OpenGL GPU"
+HOMEPAGE="http://home.t-online.de/home/PeteBernert"
+LICENSE="Freeware"
+DEPEND="virtual/opengl"
+SRC_URI="http://www.ngemu.com/psx/plugins/linux/gpu/gpupetemesagl162.tar.gz"
+S=${WORKDIR}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins lib*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ insinto /usr/lib/psemu/cfg
+ doins cfgPeteMesaGL
+ chmod 755 ${D}/usr/lib/psemu/cfg/*
+ dodoc readme.txt version.txt
+}
diff --git a/app-emulation/psemu-padjoy/ChangeLog b/app-emulation/psemu-padjoy/ChangeLog
new file mode 100644
index 000000000000..39784bdcc31b
--- /dev/null
+++ b/app-emulation/psemu-padjoy/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-padjoy
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-padjoy/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-padjoy-0.61 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.61 b/app-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.61
new file mode 100644
index 000000000000..46d8255325a9
--- /dev/null
+++ b/app-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.61
@@ -0,0 +1 @@
+MD5 7c3f21846fb34abd8e284c36adcd4b5c padJoy061.tgz 36857
diff --git a/app-emulation/psemu-padjoy/psemu-padjoy-0.61.ebuild b/app-emulation/psemu-padjoy/psemu-padjoy-0.61.ebuild
new file mode 100644
index 000000000000..cf4d09243058
--- /dev/null
+++ b/app-emulation/psemu-padjoy/psemu-padjoy-0.61.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-padjoy/psemu-padjoy-0.61.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="PSEmu plugin to use joysticks/gamepads in PSX-emulators"
+HOMEPAGE="http://www.ammoq.com"
+LICENSE="" # No mention of a license.. That makes it Public Domain?
+DEPEND="x11-libs/gtk+"
+SRC_URI="http://members.chello.at/erich.kitzmueller/ammoq/padJoy061.tgz"
+S=${WORKDIR}/padJoy
+
+src_compile() {
+ cd src
+ ( echo CFLAGS = ${CFLAGS}
+ sed 's/CFLAGS =/CFLAGS +=/' < Makefile ) >Makefile.gentoo
+ emake -f Makefile.gentoo
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins src/libpad*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ dodoc readme.txt
+}
+
diff --git a/app-emulation/psemu-padxwin/ChangeLog b/app-emulation/psemu-padxwin/ChangeLog
new file mode 100644
index 000000000000..c94beb0a9974
--- /dev/null
+++ b/app-emulation/psemu-padxwin/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-padxwin
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-padxwin/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-padxwin-1.4 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-padxwin/files/digest-psemu-padxwin-1.4 b/app-emulation/psemu-padxwin/files/digest-psemu-padxwin-1.4
new file mode 100644
index 000000000000..d9c6e45e4bd7
--- /dev/null
+++ b/app-emulation/psemu-padxwin/files/digest-psemu-padxwin-1.4
@@ -0,0 +1 @@
+MD5 bf121090983eb4aca2efc59f8a469232 padXwin-1.4.tgz 12674
diff --git a/app-emulation/psemu-padxwin/psemu-padxwin-1.4.ebuild b/app-emulation/psemu-padxwin/psemu-padxwin-1.4.ebuild
new file mode 100644
index 000000000000..8347b153718f
--- /dev/null
+++ b/app-emulation/psemu-padxwin/psemu-padxwin-1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-padxwin/psemu-padxwin-1.4.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="PSEmu plugin to use the keyboard as a gamepad"
+HOMEPAGE="http://www.pcsx.net"
+LICENSE="" # No mention of a license...
+DEPEND="x11-libs/gtk+"
+SRC_URI="http://linux.pcsx.net/downloads/plugins/padXwin-${PV}.tgz"
+S=${WORKDIR}
+
+src_compile() {
+ cd src
+ ( echo CFLAGS = ${CFLAGS}
+ sed 's/CFLAGS =/CFLAGS +=/' < Makefile ) >Makefile.gentoo
+ emake -f Makefile.gentoo
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins src/libpad*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ dodoc ReadMe.txt
+}
+
diff --git a/app-emulation/psemu-peopssoftgpu/ChangeLog b/app-emulation/psemu-peopssoftgpu/ChangeLog
new file mode 100644
index 000000000000..31b4b2978abd
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-peopssoftgpu
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopssoftgpu/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-peopssoftgpu (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6 b/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6
new file mode 100644
index 000000000000..5a96119dfe1f
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6
@@ -0,0 +1 @@
+MD5 93a49d390ded0c2db945927e1306be08 PeopsSoftGpu106.tar.gz 614725
diff --git a/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild b/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild
new file mode 100644
index 000000000000..c85ddb3781a0
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.7 2002/05/18 17:25:12 agenkin Exp
+
+DESCRIPTION="P.E.Op.S Software GPU plugin"
+HOMEPAGE="http://peops.sourceforge.net"
+LICENSE="GPL-2"
+DEPEND="x11-libs/gtk+
+ dev-lang/nasm
+ sdl? ( media-libs/libsdl )"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/peops/PeopsSoftGpu106.tar.gz"
+S=${WORKDIR}
+
+lowercase() {
+ for f in $*; do
+ mv "$f" "$(echo $f | tr A-Z a-z)"
+ done
+}
+
+src_compile() {
+ cd src
+ lowercase makes/mk.X11 Gpu.[ch] Stdafx.h Cfg.c Draw.c Key.c Menu.c \
+ Prim.c Soft.c
+ sed 's:CFLAGS =:CFLAGS +=:g' <makes/plg.mk >makes/plg.mk.tmp
+ mv -f makes/plg.mk.tmp makes/plg.mk
+
+ emake || die "Failed to make X11-version"
+
+ use sdl && (
+ sed 's:mk.x11:mk.fpse:g' <Makefile >Makefile.sdl
+ echo 'INCLUDE = `sdl-config --cflags`' >makes/mk.fpse.tmp
+ sed 's:-lSDL:`sdl-config --libs`:g' <makes/mk.fpse >>makes/mk.fpse.tmp
+ mv -f makes/mk.fpse.tmp makes/mk.fpse
+ make clean
+ emake -f Makefile.sdl || die "Failed to make SDL-version"
+ )
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins/
+ doins src/libgpu*
+ dodoc readme_1_6.txt version_1_6.txt
+}
+
diff --git a/app-emulation/psemu-peopsspu/ChangeLog b/app-emulation/psemu-peopsspu/ChangeLog
new file mode 100644
index 000000000000..8a45644e20a5
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-peopsspu
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopsspu/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-peopsspu (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1 b/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1
new file mode 100644
index 000000000000..93b2ce38955b
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1
@@ -0,0 +1 @@
+MD5 3c0a29029eb42dd567c95978ffe35ae5 PeopsSpu101.zip 216281
diff --git a/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild b/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild
new file mode 100644
index 000000000000..ea9a06dc45bd
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="P.E.Op.S Sound Emulation (SPU) PSEmu Plugin"
+HOMEPAGE="http://peops.sourceforge.net"
+LICENSE="GPL-2"
+DEPEND="app-arch/unzip
+ app-misc/fixdos
+ x11-libs/gtk+
+ sys-devel/automake"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/peops/PeopsSpu101.zip"
+S=${WORKDIR}/spuPeopsSound
+
+src_unpack() {
+ unzip -a ${DISTDIR}/PeopsSpu101.zip
+}
+
+src_compile() {
+ cd Src
+ mv StdAfx.c stdafx.c
+ mv StdAfx.h stdafx.h
+ mv OSS.H oss.h
+ emake CCFLAGS3="${CFLAGS} -fPIC -c -Wall -ffast-math -fomit-frame-pointer" || die
+ cd linuxcfg
+ tar xvfz spucfg.tar.gz
+ crlf . # convert all files in dir from dos CRLF to unix CR format...
+ automake --add-missing
+ ./configure
+ emake || die
+ mv src/spucfg src/cfgPeopsOSS
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins Src/libspu*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ insinto /usr/lib/psemu/cfg
+ doins Src/linuxcfg/src/cfgPeopsOSS
+ chmod 755 ${D}/usr/lib/psemu/cfg/*
+ dodoc Src/License.txt Src/changelog.txt
+ dodoc readme_1_1.txt version_1_1.txt
+}
+