summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-24 22:49:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-24 22:49:33 +0000
commite383d19cefe412d574cc1c4a712a687784b3a0d6 (patch)
tree32188e4315f50bf89c2ab00d086494f3ef56eec4 /app-emulation
parentFixes bug #405455, again (diff)
downloadgentoo-2-e383d19cefe412d574cc1c4a712a687784b3a0d6.tar.gz
gentoo-2-e383d19cefe412d574cc1c4a712a687784b3a0d6.tar.bz2
gentoo-2-e383d19cefe412d574cc1c4a712a687784b3a0d6.zip
Fixed configure failure against pulseaudio-1.1 (bug #384847 by Ian Abbott, fixed by Ian Abbott and Nathan Phillip Brink).
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog7
-rw-r--r--app-emulation/qemu/files/qemu-0.11.1-cfg-pulse.patch28
-rw-r--r--app-emulation/qemu/qemu-0.11.1-r1.ebuild3
-rw-r--r--app-emulation/qemu/qemu-0.11.1.ebuild3
4 files changed, 38 insertions, 3 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 6246c8944400..8588ad034be6 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.110 2012/03/20 14:57:32 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.111 2012/03/24 22:49:33 slyfox Exp $
+
+ 24 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/qemu-0.11.1-cfg-pulse.patch, qemu-0.11.1-r1.ebuild, qemu-0.11.1.ebuild:
+ Fixed configure failure against pulseaudio-1.1 (bug #384847 by Ian Abbott,
+ fixed by Ian Abbott and Nathan Phillip Brink).
20 Mar 2012; Doug Goldstein <cardoe@gentoo.org> qemu-1.0-r3.ebuild,
qemu-1.0.1.ebuild:
diff --git a/app-emulation/qemu/files/qemu-0.11.1-cfg-pulse.patch b/app-emulation/qemu/files/qemu-0.11.1-cfg-pulse.patch
new file mode 100644
index 000000000000..767038357cf4
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.11.1-cfg-pulse.patch
@@ -0,0 +1,28 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+
+Fix detection of pulseaudio caused by not including the headers which
+define NULL.
+
+--- a/configure
++++ b/configure
+@@ -1004,7 +1004,9 @@
+ lib=$3
+ exp=$4
+ cfl=$5
++ prologue=${6}
+ cat > $TMPC << EOF
++${prologue}
+ #include <$hdr>
+ int main(void) { $exp }
+ EOF
+@@ -1044,7 +1046,8 @@
+
+ pa)
+ audio_drv_probe $drv pulse/simple.h -lpulse-simple \
+- "pa_simple *s = NULL; pa_simple_free(s); return 0;"
++ "pa_simple *s = NULL; pa_simple_free(s); return 0;" \
++ '' '#include <stddef.h> /* NULL */'
+ ;;
+
+ oss|sdl|core|wav|dsound)
+
diff --git a/app-emulation/qemu/qemu-0.11.1-r1.ebuild b/app-emulation/qemu/qemu-0.11.1-r1.ebuild
index 0e9cb2efc532..0e6a41ebabb3 100644
--- a/app-emulation/qemu/qemu-0.11.1-r1.ebuild
+++ b/app-emulation/qemu/qemu-0.11.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.11.1-r1.ebuild,v 1.2 2012/03/18 13:41:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.11.1-r1.ebuild,v 1.3 2012/03/24 22:49:33 slyfox Exp $
EAPI="2"
@@ -62,6 +62,7 @@ src_prepare() {
sed -i 's/$(LDFLAGS)/$(QEMU_CFLAGS) $(CFLAGS) $(LDFLAGS)/' rules.mak
epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch"
epatch "${FILESDIR}/qemu-0.11.1-CVE-2012-0029-backport.patch"
+ epatch "${FILESDIR}"/${P}-cfg-pulse.patch #384847
}
src_configure() {
diff --git a/app-emulation/qemu/qemu-0.11.1.ebuild b/app-emulation/qemu/qemu-0.11.1.ebuild
index 6ed59cbd563e..fa21d50de8ff 100644
--- a/app-emulation/qemu/qemu-0.11.1.ebuild
+++ b/app-emulation/qemu/qemu-0.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.11.1.ebuild,v 1.8 2012/03/18 13:41:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.11.1.ebuild,v 1.9 2012/03/24 22:49:33 slyfox Exp $
EAPI="2"
@@ -61,6 +61,7 @@ src_prepare() {
# Append CFLAGS while linking
sed -i 's/$(LDFLAGS)/$(QEMU_CFLAGS) $(CFLAGS) $(LDFLAGS)/' rules.mak
epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch"
+ epatch "${FILESDIR}"/${P}-cfg-pulse.patch #384847
}
src_configure() {