summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2007-03-15 20:34:30 +0000
committerDavid Holm <dholm@gentoo.org>2007-03-15 20:34:30 +0000
commitdac096c42cbf3fd74f2265552936e642941b2f0c (patch)
tree1cceb82a6c34d0ea13e3a0a579a45f0e573284f6 /app-emulation
parentFix src_test, from ferringb@gmail.com (diff)
downloadgentoo-2-dac096c42cbf3fd74f2265552936e642941b2f0c.tar.gz
gentoo-2-dac096c42cbf3fd74f2265552936e642941b2f0c.tar.bz2
gentoo-2-dac096c42cbf3fd74f2265552936e642941b2f0c.zip
Version bumped
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/aranym/ChangeLog7
-rw-r--r--app-emulation/aranym/aranym-0.9.4_beta2.ebuild58
-rw-r--r--app-emulation/aranym/files/digest-aranym-0.9.4_beta26
3 files changed, 70 insertions, 1 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index e5612d6b14f7..d9ad28357507 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/aranym
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.9 2007/01/25 21:55:49 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.10 2007/03/15 20:34:30 dholm Exp $
+
+*aranym-0.9.4_beta2 (15 Mar 2007)
+
+ 15 Mar 2007; <dholm@gentoo.org> +aranym-0.9.4_beta2.ebuild:
+ Version bumped. Closing bug #137294.
25 Jan 2007; Marius Mauch <genone@gentoo.org> aranym-0.8.6_beta.ebuild,
aranym-0.9.0_beta2.ebuild, aranym-0.9.0.ebuild:
diff --git a/app-emulation/aranym/aranym-0.9.4_beta2.ebuild b/app-emulation/aranym/aranym-0.9.4_beta2.ebuild
new file mode 100644
index 000000000000..f7834a7857cd
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.4_beta2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit flag-o-matic eutils
+
+MY_PV="0.9.4beta2"
+AFROS="afros-20050424.zip"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${PN}-${MY_PV}.tar.gz
+ mirror://sourceforge/aranym/${AFROS}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ games-emulation/emutos
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${PN}-${MY_PV}.tar.gz
+ cd ${S}
+}
+
+src_compile() {
+ filter-flags -mpowerpc-gfxopt
+
+ use opengl && myconf="--enable-opengl"
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ cd ${S}/src/Unix
+ econf ${myconf} || die "configure failed"
+
+ emake dep || die "failed while building dependencies"
+ emake || die "failed during compilation"
+}
+
+src_install() {
+ cd ${S}/src/Unix
+ emake DESTDIR=${D} INSTALL_PROGRAM="install" install || die "installation failed"
+
+ dosym /usr/games/lib/etos512k.img /usr/share/aranym
+
+ cd ${D}/usr/share/aranym
+ unzip ${DISTDIR}/${AFROS}
+ sed -i -e "s|tmp|usr/share/aranym|g" ${D}/usr/share/aranym/afros/config
+}
+
+pkg_postinst() {
+ einfo "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}
diff --git a/app-emulation/aranym/files/digest-aranym-0.9.4_beta2 b/app-emulation/aranym/files/digest-aranym-0.9.4_beta2
new file mode 100644
index 000000000000..c1ba2f787d63
--- /dev/null
+++ b/app-emulation/aranym/files/digest-aranym-0.9.4_beta2
@@ -0,0 +1,6 @@
+MD5 949b659a476c508cc58d2fd43c6c54e6 afros-20050424.zip 1776526
+RMD160 b3858e7a8dd930fc6a5d5dea33d2434e61263f7b afros-20050424.zip 1776526
+SHA256 08f88037c92be472eae168943f455470934e33911dcbb71044bb8ed4e4b53d3c afros-20050424.zip 1776526
+MD5 777cdfdae1cbec6cfe37a5190e8bffa6 aranym-0.9.4beta2.tar.gz 1235423
+RMD160 45ba465a261fe6a04a70bd5285a5d2c1667d7104 aranym-0.9.4beta2.tar.gz 1235423
+SHA256 aadab93b562c10be407a9b660d6c3e13bbb4b4ae9a7e207f62f2e6f777c17f02 aranym-0.9.4beta2.tar.gz 1235423