summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-06-16 19:12:24 +0000
committerPacho Ramos <pacho@gentoo.org>2012-06-16 19:12:24 +0000
commitcf967d947daa992f17891b768b961f0f7d867351 (patch)
tree48e384ed16d0e1dfd37fdc1ccb466f734d5c3375 /app-emulation
parentclean up the dependency mess (diff)
downloadgentoo-2-cf967d947daa992f17891b768b961f0f7d867351.tar.gz
gentoo-2-cf967d947daa992f17891b768b961f0f7d867351.tar.bz2
gentoo-2-cf967d947daa992f17891b768b961f0f7d867351.zip
Version bump, remove old.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/playonlinux/ChangeLog8
-rw-r--r--app-emulation/playonlinux/metadata.xml3
-rw-r--r--app-emulation/playonlinux/playonlinux-4.1.1.ebuild (renamed from app-emulation/playonlinux/playonlinux-4.0.14.ebuild)50
3 files changed, 37 insertions, 24 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
index 96ab008c1396..aeb6f8a6f49f 100644
--- a/app-emulation/playonlinux/ChangeLog
+++ b/app-emulation/playonlinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/playonlinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.17 2012/06/16 07:38:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.18 2012/06/16 19:12:24 pacho Exp $
+
+*playonlinux-4.1.1 (16 Jun 2012)
+
+ 16 Jun 2012; Pacho Ramos <pacho@gentoo.org> +playonlinux-4.1.1.ebuild,
+ -playonlinux-4.0.14.ebuild, metadata.xml:
+ Version bump, remove old.
16 Jun 2012; Pacho Ramos <pacho@gentoo.org> -playonlinux-3.8.12.ebuild,
-playonlinux-3.8.8.ebuild, metadata.xml:
diff --git a/app-emulation/playonlinux/metadata.xml b/app-emulation/playonlinux/metadata.xml
index e96e35b1a37c..31b9eb325aad 100644
--- a/app-emulation/playonlinux/metadata.xml
+++ b/app-emulation/playonlinux/metadata.xml
@@ -4,5 +4,8 @@
<maintainer>
<email>maintainer-needed@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="winbind">Enables support for the winbind auth daemon</flag>
+</use>
</pkgmetadata>
diff --git a/app-emulation/playonlinux/playonlinux-4.0.14.ebuild b/app-emulation/playonlinux/playonlinux-4.1.1.ebuild
index 6c1f71dd6620..b9d348505d18 100644
--- a/app-emulation/playonlinux/playonlinux-4.0.14.ebuild
+++ b/app-emulation/playonlinux/playonlinux-4.1.1.ebuild
@@ -1,32 +1,36 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-4.0.14.ebuild,v 1.1 2011/12/15 17:20:23 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-4.1.1.ebuild,v 1.1 2012/06/16 19:12:24 pacho Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="2"
inherit eutils python games
MY_PN="PlayOnLinux"
-DESCRIPTION="set of scripts to easily install and use Windows games and software"
+DESCRIPTION="Set of scripts to easily install and use Windows games and software"
HOMEPAGE="http://playonlinux.com/"
SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="winbind"
DEPEND=""
RDEPEND="app-emulation/wine
app-arch/cabextract
+ app-arch/p7zip
app-arch/unzip
+ app-crypt/gnupg
dev-python/wxpython:2.8
|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
net-misc/wget
x11-apps/mesa-progs
- x11-terms/xterm"
+ x11-terms/xterm
+ media-gfx/icoutils
+ winbind? ( net-fs/samba[winbind] ) "
S=${WORKDIR}/${PN}
@@ -46,49 +50,49 @@ pkg_setup() {
src_prepare() {
sed -i -e "s/\(Categories=\).*/\1Game;Emulator;/" etc/PlayOnLinux.desktop \
- || die "sed failed"
- sed -e 's/PYTHON="python"/PYTHON="python2"/' -i lib/variables || die "sed failed"
+ || die
+ sed -e 's/PYTHON="python"/PYTHON="python2"/' -i lib/variables playonlinux || die
python_convert_shebangs -r 2 .
}
src_install() {
# all things without exec permissions
insinto "${GAMES_DATADIR}/${PN}"
- doins -r resources lang lib etc plugins || die "doins failed"
+ doins -r resources lang lib etc plugins
# bash/ install
exeinto "${GAMES_DATADIR}/${PN}/bash"
- doexe bash/* || die "doexe failed"
+ doexe bash/*
exeinto "${GAMES_DATADIR}/${PN}/bash/terminals"
- doexe bash/terminals/* || die "doexe failed"
+ doexe bash/terminals/*
exeinto "${GAMES_DATADIR}/${PN}/bash/expert"
- doexe bash/expert/* || die "doexe failed"
+ doexe bash/expert/*
# python/ install
exeinto "${GAMES_DATADIR}/${PN}/python"
- doexe python/* || die "doexe failed"
+ doexe python/*
# sub dir without exec permissions
insinto "${GAMES_DATADIR}/${PN}/python"
- doins -r python/lib || die "doins failed"
+ doins -r python/lib
# main executable files
exeinto "${GAMES_DATADIR}/${PN}"
- doexe ${PN}{,-pkg,-bash,-shell,-url_handler} || die "doexe failed"
+ doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
# making a script to run playonlinux from ${GAMES_BINDIR}
echo "#!/bin/bash" > ${PN}_launcher
echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN} \$*" >> ${PN}_launcher
- newgamesbin playonlinux_launcher playonlinux || die "newgamesbin failed"
+ newgamesbin playonlinux_launcher playonlinux
# making a script to run playonlinux-cmd from ${GAMES_BINDIR}
echo "#!/bin/bash" > ${PN}_cmd_launcher
echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN}-cmd \$*" >> ${PN}_cmd_launcher
- newgamesbin playonlinux_cmd_launcher playonlinux-cmd || die "newgamesbin failed"
+ newgamesbin playonlinux_cmd_launcher playonlinux-cmd
- dodoc CHANGELOG || die "dodoc failed"
+ dodoc CHANGELOG
- doicon etc/${PN}.png || die "doicon failed"
- domenu etc/${MY_PN}.desktop || die "domenu failed"
+ doicon etc/${PN}.png
+ domenu etc/${MY_PN}.desktop
prepgamesdirs
}
@@ -100,7 +104,7 @@ pkg_postinst() {
pkg_postrm() {
python_mod_cleanup "${GAMES_DATADIR}/${PN}"
- ewarn "Installed softwares and games with playonlinux have not been removed."
- ewarn "To remove them, you can re-install playonlinux and remove them using it"
- ewarn "or do it manually by removing .PlayOnLinux/ in your home directory."
+ elog "Installed softwares and games with playonlinux have not been removed."
+ elog "To remove them, you can re-install playonlinux and remove them using it"
+ elog "or do it manually by removing .PlayOnLinux/ in your home directory."
}