summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-27 13:16:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-27 13:16:36 +0000
commitc9b47d31066d3f5efd511e3eb30c56e33e270011 (patch)
tree68e0dbf8fa9deaba311ab411189cc43eef690217 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-c9b47d31066d3f5efd511e3eb30c56e33e270011.tar.gz
gentoo-2-c9b47d31066d3f5efd511e3eb30c56e33e270011.tar.bz2
gentoo-2-c9b47d31066d3f5efd511e3eb30c56e33e270011.zip
Backported a number of fixes I considered stability or worthy of a 0.10.1 release.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-manager/ChangeLog9
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild78
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0.ebuild4
3 files changed, 88 insertions, 3 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index a2a2c193106a..cf9cae0f9fe7 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.91 2013/08/02 13:13:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.92 2013/08/27 13:16:36 cardoe Exp $
+
+*virt-manager-0.10.0-r1 (27 Aug 2013)
+
+ 27 Aug 2013; Doug Goldstein <cardoe@gentoo.org>
+ +virt-manager-0.10.0-r1.ebuild, virt-manager-0.10.0.ebuild:
+ Backported a number of fixes I considered stability or worthy of a 0.10.1
+ release.
02 Aug 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild:
Add dconf as a runtime depend to save configuration. bug #477528
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..0b648163e268
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild,v 1.1 2013/08/27 13:16:36 cardoe Exp $
+
+EAPI=5
+
+BACKPORTS=1cd29748
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit eutils gnome2 distutils-r1
+
+DESCRIPTION="A graphical tool for administering virtual machines"
+HOMEPAGE="http://virt-manager.org"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gnome-keyring policykit sasl"
+
+RDEPEND="!app-emulation/virtinst
+ x11-libs/gtk+:3[introspection]
+ >=app-emulation/libvirt-0.7.0[python,${PYTHON_USEDEP}]
+ >=app-emulation/libvirt-glib-0.0.9[introspection,python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ gnome-base/dconf
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}]
+ net-misc/spice-gtk[gtk3,introspection,python,sasl?,${PYTHON_USEDEP}]
+ x11-libs/vte:2.90[introspection]
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ policykit? ( sys-auth/polkit[introspection] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool"
+
+DOCS=( README NEWS )
+
+python_prepare_all() {
+ epatch_user
+ distutils-r1_python_prepare_all
+}
+
+distutils-r1_python_compile() {
+ local defgraphics=
+
+ esetup.py configure \
+ --qemu-user=qemu \
+ --default-graphics=spice
+}
+
+python_install_all() {
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-clone"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-convert"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-image"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-install"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-manager"
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ cd "${ED}"
+ export GNOME2_ECLASS_ICONS=$(find 'usr/share/virt-manager/icons' -maxdepth 1 -mindepth 1 -type d 2> /dev/null)
+}
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
index 15daef87fe60..8b5c2bd5ab52 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.9 2013/08/02 13:13:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.10 2013/08/27 13:16:36 cardoe Exp $
EAPI=5
@@ -21,7 +21,7 @@ if [[ ${PV} = *9999* ]]; then
else
SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
fi
LICENSE="GPL-2"