summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-02 00:49:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-02 00:49:57 +0000
commitbaf2c0824d3888e4a61e466256ecae6a49263315 (patch)
tree14d63f1313d4c0b913977a73bcc58079f45887cf /app-emulation
parentmore modular init scripts, so that client and server are separate; version bu... (diff)
downloadgentoo-2-baf2c0824d3888e4a61e466256ecae6a49263315.tar.gz
gentoo-2-baf2c0824d3888e4a61e466256ecae6a49263315.tar.bz2
gentoo-2-baf2c0824d3888e4a61e466256ecae6a49263315.zip
Version bump #104492 by Martin Nowack.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/digest-wine-200508301
-rw-r--r--app-emulation/wine/files/wine-20050830-gcc-32bit.patch11
-rw-r--r--app-emulation/wine/files/wine-20050830-no-ldap.patch93
-rw-r--r--app-emulation/wine/wine-20050830.ebuild140
5 files changed, 253 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index e626c5e2d38a..e852f92382f3 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.103 2005/08/24 00:19:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.104 2005/09/02 00:49:57 vapier Exp $
+
+*wine-20050830 (02 Sep 2005)
+
+ 02 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-20050830-gcc-32bit.patch, +files/wine-20050830-no-ldap.patch,
+ +wine-20050830.ebuild:
+ Version bump #104492 by Martin Nowack.
*wine-20050725-r1 (24 Aug 2005)
*wine-20050111-r2 (24 Aug 2005)
diff --git a/app-emulation/wine/files/digest-wine-20050830 b/app-emulation/wine/files/digest-wine-20050830
new file mode 100644
index 000000000000..0dd93d94c1aa
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20050830
@@ -0,0 +1 @@
+MD5 5d95439a74decd1f94dd8d370a24f442 Wine-20050830.tar.gz 12433457
diff --git a/app-emulation/wine/files/wine-20050830-gcc-32bit.patch b/app-emulation/wine/files/wine-20050830-gcc-32bit.patch
new file mode 100644
index 000000000000..faa27d396e7b
--- /dev/null
+++ b/app-emulation/wine/files/wine-20050830-gcc-32bit.patch
@@ -0,0 +1,11 @@
+--- tools/winegcc/winegcc.c
++++ tools/winegcc/winegcc.c
+@@ -863,6 +863,8 @@
+ opts.gui_app = 0;
+ else if (strcmp("-municode", argv[i]) == 0)
+ opts.unicode_app = 1;
++ else if (strcmp("-m32", argv[i]) == 0 || strcmp("-m64", argv[i]) == 0)
++ raw_linker_arg = 1;
+ break;
+ case 'n':
+ if (strcmp("-nostdinc", argv[i]) == 0)
diff --git a/app-emulation/wine/files/wine-20050830-no-ldap.patch b/app-emulation/wine/files/wine-20050830-no-ldap.patch
new file mode 100644
index 000000000000..716a863f4c07
--- /dev/null
+++ b/app-emulation/wine/files/wine-20050830-no-ldap.patch
@@ -0,0 +1,93 @@
+Fix build error:
+x86_64-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include \
+ -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_REENTRANT \
+ -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing \
+ -gstabs+ -Wpointer-arith -O2 -march=k8 -pipe -o add.o add.c
+In file included from add.c:39:
+winldap_private.h:289: error: syntax error before "BerElement"
+winldap_private.h:290: error: syntax error before "BerElement"
+winldap_private.h:322: error: syntax error before "BerElement"
+winldap_private.h:323: error: syntax error before "BerElement"
+make[2]: *** [add.o] Error 1
+
+http://bugs.gentoo.org/104492
+http://bugs.winehq.com/show_bug.cgi?id=3265
+
+--- dlls/wldap32/misc.c
++++ dlls/wldap32/misc.c
+@@ -125,7 +125,8 @@ ULONG WLDAP32_ldap_count_references( WLD
+ return ret;
+ }
+
+-PCHAR ldap_first_attributeA( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry, BerElement** ptr )
++PCHAR ldap_first_attributeA( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry,
++ WLDAP32_BerElement** ptr )
+ {
+ PCHAR ret = NULL;
+ #ifdef HAVE_LDAP
+@@ -143,7 +144,8 @@ PCHAR ldap_first_attributeA( WLDAP32_LDA
+ return ret;
+ }
+
+-PWCHAR ldap_first_attributeW( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry, BerElement** ptr )
++PWCHAR ldap_first_attributeW( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry,
++ WLDAP32_BerElement** ptr )
+ {
+ PWCHAR ret = NULL;
+ #ifdef HAVE_LDAP
+@@ -211,7 +213,8 @@ ULONG WLDAP32_ldap_msgfree( WLDAP32_LDAP
+ return ret;
+ }
+
+-PCHAR ldap_next_attributeA( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry, BerElement *ptr )
++PCHAR ldap_next_attributeA( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry,
++ WLDAP32_BerElement *ptr )
+ {
+ PCHAR ret = NULL;
+ #ifdef HAVE_LDAP
+@@ -229,7 +232,8 @@ PCHAR ldap_next_attributeA( WLDAP32_LDAP
+ return ret;
+ }
+
+-PWCHAR ldap_next_attributeW( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry, BerElement *ptr )
++PWCHAR ldap_next_attributeW( WLDAP32_LDAP *ld, WLDAP32_LDAPMessage *entry,
++ WLDAP32_BerElement *ptr )
+ {
+ PWCHAR ret = NULL;
+ #ifdef HAVE_LDAP
+--- dlls/wldap32/winldap_private.h
++++ dlls/wldap32/winldap_private.h
+@@ -43,6 +43,11 @@ typedef enum {
+ WLDAP32_LDAP_REFERRAL_LIMIT_EXCEEDED = 0x61
+ } LDAP_RETCODE;
+
++typedef struct berelement
++{
++ PCHAR opaque;
++} WLDAP32_BerElement;
++
+ #define LDAP_OPT_THREAD_FN_PTRS 0x05
+ #define LDAP_OPT_REBIND_FN 0x06
+ #define LDAP_OPT_REBIND_ARG 0x07
+@@ -286,8 +291,8 @@ ULONG ldap_extended_operation_sA(WLDAP32
+ PCHAR*,struct WLDAP32_berval**);
+ ULONG ldap_extended_operation_sW(WLDAP32_LDAP*,PWCHAR,struct WLDAP32_berval*,PLDAPControlW*, PLDAPControlW*,
+ PWCHAR*,struct WLDAP32_berval**);
+-PCHAR ldap_first_attributeA(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,BerElement**);
+-PWCHAR ldap_first_attributeW(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,BerElement**);
++PCHAR ldap_first_attributeA(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,WLDAP32_BerElement**);
++PWCHAR ldap_first_attributeW(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,WLDAP32_BerElement**);
+ WLDAP32_LDAPMessage *WLDAP32_ldap_first_entry(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
+ WLDAP32_LDAPMessage *WLDAP32_ldap_first_reference(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
+ PCHAR ldap_get_dnA(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
+@@ -319,8 +324,8 @@ ULONG ldap_modrdn2_sW(WLDAP32_LDAP*,PWCH
+ ULONG ldap_modrdn_sA(WLDAP32_LDAP*,PCHAR,PCHAR);
+ ULONG ldap_modrdn_sW(WLDAP32_LDAP*,PWCHAR,PWCHAR);
+ ULONG WLDAP32_ldap_msgfree(WLDAP32_LDAPMessage*);
+-PCHAR ldap_next_attributeA(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,BerElement*);
+-PWCHAR ldap_next_attributeW(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,BerElement*);
++PCHAR ldap_next_attributeA(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,WLDAP32_BerElement*);
++PWCHAR ldap_next_attributeW(WLDAP32_LDAP*,WLDAP32_LDAPMessage*,WLDAP32_BerElement*);
+ WLDAP32_LDAPMessage *WLDAP32_ldap_next_entry(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
+ WLDAP32_LDAPMessage *WLDAP32_ldap_next_reference(WLDAP32_LDAP*,WLDAP32_LDAPMessage*);
+ WLDAP32_LDAP *ldap_openA(PCHAR,ULONG);
diff --git a/app-emulation/wine/wine-20050830.ebuild b/app-emulation/wine/wine-20050830.ebuild
new file mode 100644
index 000000000000..70a3cdca8110
--- /dev/null
+++ b/app-emulation/wine/wine-20050830.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050830.ebuild,v 1.1 2005/09/02 00:49:57 vapier Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses lcms" #doc
+RESTRICT="test" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ media-fonts/corefonts
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( virtual/x11 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ >=sys-kernel/linux-headers-2.6
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
+
+pkg_setup() {
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
+ epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+ epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-20050830-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-20050830-no-ldap.patch
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack header_jack_jack_h
+ config_cache cups header_cups_cups_h
+ config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas header_audio_audiolib_h header_audio_soundlib_h
+ config_cache gif header_gif_lib_h
+ config_cache glut lib_glut_glutMainLoop
+ config_cache jpeg header_jpeglib_h
+ config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
+ config_cache lcms header_lcms_h
+
+ strip-flags
+ use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+
+# if ! built_with_use app-text/docbook-sgml-utils tetex ; then
+# export DB2PDF=true
+# export DB2PS=true
+# fi
+
+ # $(use_enable amd64 win64)
+ # USE=debug is broken in this release
+ econf \
+ CC=$(tc-getCC) \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+# if use doc ; then
+# VARTEXFONTS=${T} \
+# emake -j1 -C documentation doc || die "docs"
+# fi
+}
+
+src_install() {
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ datadir="${D}"/usr/share \
+ includedir="${D}"/usr/include/wine \
+ sysconfdir="${D}"/etc/wine \
+ mandir="${D}"/usr/share/man \
+ libdir="${D}"/usr/$(get_libdir) \
+ dlldir="${D}"/usr/$(get_libdir)/wine \
+ install || die
+# use doc && dodoc documentation/*.pdf
+
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+}
+
+pkg_postinst() {
+ einfo "~/.wine/config is now deprecated. For configuration either use"
+ einfo "winecfg or regedit HKCU\\Software\\Wine"
+}