summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-02-08 22:38:59 +0000
committerLance Albertson <ramereth@gentoo.org>2010-02-08 22:38:59 +0000
commitaf15748ea00485aecca893aadea635cd66be1e18 (patch)
treee4a4abf577a3657a8986cbfd9c27cdfc1bf9bd97 /app-emulation
parentstable sparc, bug 302346 (diff)
downloadgentoo-2-af15748ea00485aecca893aadea635cd66be1e18.tar.gz
gentoo-2-af15748ea00485aecca893aadea635cd66be1e18.tar.bz2
gentoo-2-af15748ea00485aecca893aadea635cd66be1e18.zip
Enhance ganeti-2.1.x init script so that you can pass options to the daemons easily
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ChangeLog7
-rw-r--r--app-emulation/ganeti/files/ganeti-2.1.initd12
-rw-r--r--app-emulation/ganeti/files/ganeti.confd10
-rw-r--r--app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild3
4 files changed, 28 insertions, 4 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 2b09cfbdc937..758301a774d2 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.16 2010/02/06 22:51:21 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.17 2010/02/08 22:38:59 ramereth Exp $
+
+ 08 Feb 2010; Lance Albertson <ramereth@gentoo.org>
+ ganeti-2.1.0_rc4.ebuild, files/ganeti-2.1.initd, +files/ganeti.confd:
+ Enhance ganeti-2.1.x init script so that you can pass options to the daemons
+ easily
*ganeti-2.0.6 (06 Feb 2010)
diff --git a/app-emulation/ganeti/files/ganeti-2.1.initd b/app-emulation/ganeti/files/ganeti-2.1.initd
index 743c5cdb9c81..71c840212836 100644
--- a/app-emulation/ganeti/files/ganeti-2.1.initd
+++ b/app-emulation/ganeti/files/ganeti-2.1.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.1 2009/12/17 00:47:16 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.2 2010/02/08 22:38:58 ramereth Exp $
depend() {
need localmount drbd
@@ -70,7 +70,15 @@ maybe_do() {
start_all() {
check_config
for i in ${NODED} ${MASTERD} ${CONFD} ${RAPI}; do \
- maybe_do "${1}" start_action ${i}
+ case "${i}" in
+ ganeti-masterd)
+ GANETI_OPTS="${GANETI_OPTS} ${GANETI_MASTERD_OPTS}"
+ ;;
+ ganeti-rapid)
+ GANETI_OPTS="${GANETI_OPTS} ${GANETI_RAPI_OPTS}"
+ ;;
+ esac
+ maybe_do "${1}" start_action ${i} ${GANETI_OPTS}
done
}
diff --git a/app-emulation/ganeti/files/ganeti.confd b/app-emulation/ganeti/files/ganeti.confd
new file mode 100644
index 000000000000..b79a27815c12
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti.confd
@@ -0,0 +1,10 @@
+# /etc/conf.d/ganeti: config file for /etc/init.d/ganeti
+
+# Extra options to pass to all of the ganeti daemons
+# GANETI_OPTS="-d"
+
+# Options to pass to ganeti-masterd
+# GANETI_MASTERD_OPTS=""
+
+# Options to pass to ganeti-rapi
+# GANETI_RAPI_OPTS=""
diff --git a/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild b/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild
index 6fcb8871fee1..1c42c50b2d6e 100644
--- a/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild
+++ b/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild,v 1.1 2010/01/31 01:55:10 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild,v 1.2 2010/02/08 22:38:59 ramereth Exp $
EAPI=2
@@ -55,6 +55,7 @@ src_configure () {
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ newconfd "${FILESDIR}"/ganeti.confd ganeti
dobashcompletion doc/examples/bash_completion ganeti
dodoc INSTALL NEWS README doc/*.{rst,png}
rm -rf "${D}"/usr/share/doc/ganeti