summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-04 12:58:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-04 12:58:47 +0000
commitad2247342e9f9fcfcf6e019bf5aa3d936e121cd1 (patch)
treefd851c90c9f3e0d313248de87e27494c051fcea5 /app-emulation
parentStable on amd64 and x86, wrt bug #490368 (diff)
downloadgentoo-2-ad2247342e9f9fcfcf6e019bf5aa3d936e121cd1.tar.gz
gentoo-2-ad2247342e9f9fcfcf6e019bf5aa3d936e121cd1.tar.bz2
gentoo-2-ad2247342e9f9fcfcf6e019bf5aa3d936e121cd1.zip
Add patch by dlan, fixes Bug 379537 by flameeyes
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog6
-rw-r--r--app-emulation/xen-tools/files/fix-gold-ld.patch14
-rw-r--r--app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild5
-rw-r--r--app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild5
4 files changed, 27 insertions, 3 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index b2e35fdf217d..08e05eb372ce 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.195 2013/11/04 11:37:51 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.196 2013/11/04 12:58:47 idella4 Exp $
+
+ 04 Nov 2013; Ian Delaney <idella4@gentoo.org> +files/fix-gold-ld.patch,
+ xen-tools-4.2.2-r4.ebuild, xen-tools-4.3.0-r1.ebuild:
+ Add patch by dlan, fixes Bug 379537 by flameeyes
*xen-tools-4.3.0-r1 (04 Nov 2013)
diff --git a/app-emulation/xen-tools/files/fix-gold-ld.patch b/app-emulation/xen-tools/files/fix-gold-ld.patch
new file mode 100644
index 000000000000..654eb257b6f1
--- /dev/null
+++ b/app-emulation/xen-tools/files/fix-gold-ld.patch
@@ -0,0 +1,14 @@
+diff --git a/tools/libfsimage/common/Makefile b/tools/libfsimage/common/Makefile
+index cbd60b4..d2b83dd 100644
+--- a/tools/libfsimage/common/Makefile
++++ b/tools/libfsimage/common/Makefile
+@@ -5,7 +5,7 @@ MAJOR = 1.0
+ MINOR = 0
+
+ LDFLAGS-$(CONFIG_SunOS) = -Wl,-M -Wl,mapfile-SunOS
+-LDFLAGS-$(CONFIG_Linux) = -Wl,mapfile-GNU
++LDFLAGS-$(CONFIG_Linux) =
+ LDFLAGS = $(LDFLAGS-y)
+
+ CFLAGS += $(PTHREAD_CFLAGS)
+
diff --git a/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild
index cdcc8f269498..3824166adf3c 100644
--- a/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild,v 1.7 2013/10/04 18:06:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.2-r4.ebuild,v 1.8 2013/11/04 12:58:47 idella4 Exp $
EAPI=5
@@ -233,6 +233,9 @@ src_prepare() {
# Bug 445986
sed -e 's:$(MAKE) PYTHON=$(PYTHON) subdirs-$@:LC_ALL=C "$(MAKE)" PYTHON=$(PYTHON) subdirs-$@:' -i tools/firmware/Makefile || die
+ # Bug 379537
+ epatch "${FILESDIR}"/fix-gold-ld.patch
+
epatch_user
}
diff --git a/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild b/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild
index 52e2aa3d4731..1de85d45bdbf 100644
--- a/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild,v 1.1 2013/11/04 11:37:51 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.3.0-r1.ebuild,v 1.2 2013/11/04 12:58:47 idella4 Exp $
EAPI=5
@@ -224,6 +224,9 @@ src_prepare() {
use api || sed -e "/SUBDIRS-\$(LIBXENAPI_BINDINGS) += libxen/d" -i tools/Makefile || die
sed -e 's:$(MAKE) PYTHON=$(PYTHON) subdirs-$@:LC_ALL=C "$(MAKE)" PYTHON=$(PYTHON) subdirs-$@:' -i tools/firmware/Makefile || die
+ # Bug 379537
+ epatch "${FILESDIR}"/fix-gold-ld.patch
+
epatch_user
}