summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-07-28 12:05:41 +0000
committerMichael Januszewski <spock@gentoo.org>2004-07-28 12:05:41 +0000
commitac4bf850b5a33deb8f70a7fec015c396eced7b68 (patch)
treecf280c00f4a5f3902da34b333124fe12d09b7d22 /app-emulation
parentebuild submitted by Michael Panhorst <Michael@untiefe.de> in (Manifest recommit) (diff)
downloadgentoo-2-ac4bf850b5a33deb8f70a7fec015c396eced7b68.tar.gz
gentoo-2-ac4bf850b5a33deb8f70a7fec015c396eced7b68.tar.bz2
gentoo-2-ac4bf850b5a33deb8f70a7fec015c396eced7b68.zip
Version bump.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uade/ChangeLog8
-rw-r--r--app-emulation/uade/files/digest-uade-0.911
-rw-r--r--app-emulation/uade/uade-0.91.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index d3c3649722ab..623e398e27a3 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.9 2004/07/21 11:56:32 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.10 2004/07/28 12:05:41 spock Exp $
+
+*uade-0.91 (28 Jul 2004)
+
+ 28 Jul 2004; Michal Januszewski <spock@gentoo.org> +uade-0.91.ebuild:
+ Version bump, closes #58645. Thanks to Heikki Orsila for providing an
+ updated ebuild.
21 Jul 2004; Michal Januszewski <spock@gentoo.org> uade-0.91_pre3.ebuild:
Fixed a problem with configure that would make UADE totally useless.
diff --git a/app-emulation/uade/files/digest-uade-0.91 b/app-emulation/uade/files/digest-uade-0.91
new file mode 100644
index 000000000000..0489ad326287
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-0.91
@@ -0,0 +1 @@
+MD5 3b7fa0899e3456e0d37c50048685881e uade-0.91.tar.bz2 2117195
diff --git a/app-emulation/uade/uade-0.91.ebuild b/app-emulation/uade/uade-0.91.ebuild
new file mode 100644
index 000000000000..1d2ec22be479
--- /dev/null
+++ b/app-emulation/uade/uade-0.91.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-0.91.ebuild,v 1.1 2004/07/28 12:05:41 spock Exp $
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://uade.ton.tut.fi/"
+SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="xmms sdl alsa oss"
+
+RDEPEND="xmms? ( >=media-sound/xmms-1.2.2 x11-libs/gtk+ )
+ sdl? ( media-libs/libsdl )
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )"
+
+DEPEND="${RDEPEND}
+ xmms? ( sys-devel/libtool )"
+
+src_compile() {
+
+ cd ${S}
+
+ ./configure \
+ --prefix=/usr \
+ --package-prefix=${D} \
+ --docdir=/usr/share/doc/${PF} \
+ --without-bmp \
+ `use_with oss` \
+ `use_with sdl` \
+ `use_with alsa` \
+ `use_with xmms` \
+ || die "configure failed"
+
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die 'make install failed'
+ dodoc BUGS ChangeLog.txt FIXED ANTIPLANS README PLANS TESTING docs/CREDITS
+
+ find "${D}/usr/share/doc/${PF}/" \
+ \( -name '*.readme' -o \
+ -name '*.txt' -o \
+ -name 'INSTALL*' -o \
+ -name 'README*' -o \
+ -name 'Change*' \) -exec gzip -9 \{\} \;
+ dohtml -r "${D}/usr/share/doc/${PF}/"
+ rm -f "${D}/usr/share/doc/${PF}/"{COPYING,INSTALL.*.gz}
+ rm -f "${D}/usr/share/doc/${PF}/uade-docs/"{*.html,*.png,*.1}
+
+ if ! use perl; then
+ rm -f "${D}/usr/bin/pwrap.pl"
+ fi
+}