summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:10:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:10:57 +0000
commita7e8ab095e21c6e4fd888f8c83aa5093798d64d0 (patch)
treef8c06135e7df225084efa096e4a8643a24fe3027 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-a7e8ab095e21c6e4fd888f8c83aa5093798d64d0.tar.gz
gentoo-2-a7e8ab095e21c6e4fd888f8c83aa5093798d64d0.tar.bz2
gentoo-2-a7e8ab095e21c6e4fd888f8c83aa5093798d64d0.zip
Added patces from upstream for '--disable-debug-info' and '--enable-xfsctl'. Fixes configure failure (bug #406851 by Markus Peloquin and others).
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog8
-rw-r--r--app-emulation/qemu/files/qemu-1.0-unmagic-debug.patch66
-rw-r--r--app-emulation/qemu/files/qemu-1.0-unmagic-xfsctl.patch24
-rw-r--r--app-emulation/qemu/qemu-1.0.1.ebuild5
4 files changed, 101 insertions, 2 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index fac0df46fcf8..c9353eebc801 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.107 2012/03/03 17:19:52 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.108 2012/03/07 17:10:57 slyfox Exp $
+
+ 07 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/qemu-1.0-unmagic-debug.patch, +files/qemu-1.0-unmagic-xfsctl.patch,
+ qemu-1.0.1.ebuild:
+ Added patces from upstream for '--disable-debug-info' and '--enable-xfsctl'.
+ Fixes configure failure (bug #406851 by Markus Peloquin and others).
*qemu-1.0.1 (03 Mar 2012)
diff --git a/app-emulation/qemu/files/qemu-1.0-unmagic-debug.patch b/app-emulation/qemu/files/qemu-1.0-unmagic-debug.patch
new file mode 100644
index 000000000000..9ad232a778be
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-1.0-unmagic-debug.patch
@@ -0,0 +1,66 @@
+commit 5bc62e01cd22ea1f56bde94b0616c46f8af2676e
+Author: Gerd Hoffmann <kraxel@redhat.com>
+Date: Wed Feb 8 13:54:13 2012 +0100
+
+ build: allow turning off debuginfo
+
+ This patch adds --{enable,disable}-debug-info switches to configure
+ which allows to include/exclude the '-g' switch on the gcc & ld
+ command lines. Not building debug info reduces ressource usage
+ (especially disk) alot and is quite useful for test builds.
+
+ Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
+ Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
+
+diff --git a/configure b/configure
+index a1f4a6b..b22fcda 100755
+--- a/configure
++++ b/configure
+@@ -98,6 +98,7 @@ audio_pt_int=""
+ audio_win_int=""
+ cc_i386=i386-pc-linux-gnu-gcc
+ libs_qga=""
++debug_info="yes"
+
+ target_list=""
+
+@@ -207,6 +208,10 @@ for opt do
+ ;;
+ --extra-ldflags=*) LDFLAGS="$optarg $LDFLAGS"
+ ;;
++ --enable-debug-info) debug_info="yes"
++ ;;
++ --disable-debug-info) debug_info="no"
++ ;;
+ --sparc_cpu=*)
+ sparc_cpu="$optarg"
+ case $sparc_cpu in
+@@ -244,13 +249,15 @@ sdl_config="${SDL_CONFIG-${cross_prefix}sdl-config}"
+
+ # default flags for all hosts
+ QEMU_CFLAGS="-fno-strict-aliasing $QEMU_CFLAGS"
+-CFLAGS="-g $CFLAGS"
+ QEMU_CFLAGS="-Wall -Wundef -Wwrite-strings -Wmissing-prototypes $QEMU_CFLAGS"
+ QEMU_CFLAGS="-Wstrict-prototypes -Wredundant-decls $QEMU_CFLAGS"
+ QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"
+ QEMU_CFLAGS="-D_FORTIFY_SOURCE=2 $QEMU_CFLAGS"
+ QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/fpu"
+-LDFLAGS="-g $LDFLAGS"
++if test "$debug_info" = "yes"; then
++ CFLAGS="-g $CFLAGS"
++ LDFLAGS="-g $LDFLAGS"
++fi
+
+ # make source path absolute
+ source_path=`cd "$source_path"; pwd`
+@@ -545,6 +552,10 @@ for opt do
+ ;;
+ --extra-ldflags=*)
+ ;;
++ --enable-debug-info)
++ ;;
++ --disable-debug-info)
++ ;;
+ --cpu=*)
+ ;;
+ --target-list=*) target_list="$optarg"
diff --git a/app-emulation/qemu/files/qemu-1.0-unmagic-xfsctl.patch b/app-emulation/qemu/files/qemu-1.0-unmagic-xfsctl.patch
new file mode 100644
index 000000000000..df8aacbc4f36
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-1.0-unmagic-xfsctl.patch
@@ -0,0 +1,24 @@
+commit 8c84cf11660322489f839bc29db79bad31b4ecde
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue Jan 24 20:42:40 2012 +0300
+
+ ./configure: export xfs config via --{enable, disable}-xfsctl
+
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+ Signed-off-by: Stefan Hajnoczi <stefanha@linux.vnet.ibm.com>
+
+diff --git a/configure b/configure
+index 9d5175b..69fb239 100755
+--- a/configure
++++ b/configure
+@@ -766,6 +766,10 @@ for opt do
+ ;;
+ --enable-rbd) rbd="yes"
+ ;;
++ --disable-xfsctl) xfs="no"
++ ;;
++ --enable-xfsctl) xfs="yes"
++ ;;
+ --disable-smartcard) smartcard="no"
+ ;;
+ --enable-smartcard) smartcard="yes"
diff --git a/app-emulation/qemu/qemu-1.0.1.ebuild b/app-emulation/qemu/qemu-1.0.1.ebuild
index ebbca3388d9f..b7265fa2a4da 100644
--- a/app-emulation/qemu/qemu-1.0.1.ebuild
+++ b/app-emulation/qemu/qemu-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.0.1.ebuild,v 1.1 2012/03/03 17:19:52 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.0.1.ebuild,v 1.2 2012/03/07 17:10:57 slyfox Exp $
EAPI=4
@@ -135,6 +135,9 @@ src_prepare() {
EPATCH_EXCLUDE="0033-PPC-Fix-linker-scripts-on-ppc-hosts.patch" \
EPATCH_FORCE="yes" epatch
+ epatch "${FILESDIR}"/${PN}-1.0-unmagic-debug.patch
+ epatch "${FILESDIR}"/${PN}-1.0-unmagic-xfsctl.patch
+
# prevent docs to get automatically installed
sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die