summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Lennard <yakmoose@gentoo.org>2002-12-16 10:44:09 +0000
committerJohn Lennard <yakmoose@gentoo.org>2002-12-16 10:44:09 +0000
commit9ec55863423891b23bcad3b804cb91ca5b28cbdf (patch)
tree1176fe6d4229c8042aa1482c6df4f02610910432 /app-emulation
parentnew eclass for xemacs packages (diff)
downloadgentoo-2-9ec55863423891b23bcad3b804cb91ca5b28cbdf.tar.gz
gentoo-2-9ec55863423891b23bcad3b804cb91ca5b28cbdf.tar.bz2
gentoo-2-9ec55863423891b23bcad3b804cb91ca5b28cbdf.zip
More inital work to the win4lin ebuild, win4lin now installs and can be started.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/win4lin/ChangeLog9
-rw-r--r--app-emulation/win4lin/win4lin-4.0.11.ebuild33
2 files changed, 38 insertions, 4 deletions
diff --git a/app-emulation/win4lin/ChangeLog b/app-emulation/win4lin/ChangeLog
index 43730be2ae0c..f848a2548c4d 100644
--- a/app-emulation/win4lin/ChangeLog
+++ b/app-emulation/win4lin/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for app-emulation/win4lin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.1 2002/12/13 00:40:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.2 2002/12/16 10:44:09 yakmoose Exp $
-*win4lin-4.0.11 (12 Dec 2002)
+*win4lin-4.0.11 (16 Dec 2002)
+
+ 16 Dec 2002; John Lennard <yakmoose@gentoo.org> win4lin-4.0.11.ebuild
+ Added execution of post-install and pre-remove, these are just the
+ originall Netraverse ones so far and many still need changing. Added a
+ config section to the ebuild also to install the Windows files.
12 Dec 2002; Seemant Kulleen <seemant@gentoo.org> win4lin-4.0.11.ebuild
files/digest-win4lin-4.0.11 ChangeLog :
diff --git a/app-emulation/win4lin/win4lin-4.0.11.ebuild b/app-emulation/win4lin/win4lin-4.0.11.ebuild
index 44a5a9151f0d..020b6223dd7c 100644
--- a/app-emulation/win4lin/win4lin-4.0.11.ebuild
+++ b/app-emulation/win4lin/win4lin-4.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.11.ebuild,v 1.1 2002/12/13 00:40:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.11.ebuild,v 1.2 2002/12/16 10:44:09 yakmoose Exp $
IUSE="X gnome"
@@ -9,7 +9,8 @@ S=${WORKDIR}
DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
under linux."
HOMEPAGE="http://www.netraverse.com/"
-SRC_URI="Win4Lin-5.3.11a-d.i386.rpm"
+At="Win4Lin-5.3.11a-d.i386.rpm"
+SRC_URI=""
SLOT="0"
LICENSE="NeTraverse"
@@ -25,6 +26,10 @@ RESTRICT="nofetch"
# /usr/portage/distfiles after downloading, then emerge win4lin again
src_unpack() {
+ #check for the dist file
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE} and place in /usr/portage/distfiles"
+ fi
rpm2targz ${DISTDIR}/${MY_P}.rpm
tar zxf ${WORKDIR}/${MY_P}.tar.gz
}
@@ -35,4 +40,28 @@ src_compile() {
src_install() {
mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
}
+
+pkg_postinst() {
+ /opt/win4lin/postinst_rpm.sh
+ einfo ">>> If this is a new Win4Lin Install you will need to run the following command"
+ einfo ">>> ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo ">>> to install the windows setup files. You will need your Windows cdrom in the "
+ einfo ">>> drive in order to complete this step."
+}
+
+
+pkg_prerm() {
+ /opt/win4lin/remove_rpm.sh
+}
+
+pkg_config() {
+ loadwindowsCD cddevice /dev/cdrom
+ #put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo ">>> You can now run the command \"installwindows\" from an xterm "
+ einfo ">>> as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo ">>> will use for that user."
+ fi
+} \ No newline at end of file