summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-12 19:21:59 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-12 19:21:59 +0000
commit96f457d645abc222b0109929bb6ed0d5dee24ff1 (patch)
treec4f53bb740d76c3015f6189e5db4886f97fe4da7 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-96f457d645abc222b0109929bb6ed0d5dee24ff1.tar.gz
gentoo-2-96f457d645abc222b0109929bb6ed0d5dee24ff1.tar.bz2
gentoo-2-96f457d645abc222b0109929bb6ed0d5dee24ff1.zip
Version bump to 2.1.1
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ChangeLog16
-rw-r--r--app-emulation/ganeti/files/ganeti-2.1.1-disable-check-man.patch17
-rw-r--r--app-emulation/ganeti/ganeti-2.1.1.ebuild81
-rw-r--r--app-emulation/ganeti/metadata.xml1
4 files changed, 114 insertions, 1 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 402355d9631a..5f76685a39c2 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.19 2010/03/11 17:18:18 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.20 2010/03/12 19:21:58 ramereth Exp $
+
+*ganeti-2.1.1 (12 Mar 2010)
+
+ 12 Mar 2010; Lance Albertson <ramereth@gentoo.org> +ganeti-2.1.1.ebuild,
+ +files/ganeti-2.1.1-disable-check-man.patch, metadata.xml:
+ Version bump to 2.1.1
+
+ * Added patch to remove use of check-man (ganeti issue 91)
+
+ * Removed old brctl patch since its now fixed upstream.
+
+ * Added filestorage useflag to give the option disabling it
+
+ * Added syslog useflag
11 Mar 2010; Lance Albertson <ramereth@gentoo.org> -ganeti-1.2.1.ebuild,
-ganeti-2.0.5.ebuild, -ganeti-2.1.0_rc3.ebuild, -ganeti-2.1.0_rc4.ebuild:
diff --git a/app-emulation/ganeti/files/ganeti-2.1.1-disable-check-man.patch b/app-emulation/ganeti/files/ganeti-2.1.1-disable-check-man.patch
new file mode 100644
index 000000000000..5c2868d1a0fd
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.1.1-disable-check-man.patch
@@ -0,0 +1,17 @@
+diff -ur ganeti-2.1.1/Makefile.in ganeti-2.1.1.new/Makefile.in
+--- ganeti-2.1.1/Makefile.in 2010-03-12 03:04:33.000000000 -0800
++++ ganeti-2.1.1.new/Makefile.in 2010-03-12 11:07:47.000000000 -0800
+@@ -1320,11 +1320,11 @@
+
+ man/%.7: man/%.7.in $(REPLACE_VARS_SED)
+ sed -f $(REPLACE_VARS_SED) < $< > $@
+- $(CHECK_MAN) $@
++ #$(CHECK_MAN) $@
+
+ man/%.8: man/%.8.in $(REPLACE_VARS_SED)
+ sed -f $(REPLACE_VARS_SED) < $< > $@
+- $(CHECK_MAN) $@
++ #$(CHECK_MAN) $@
+
+ man/%.html: man/%.html.in $(REPLACE_VARS_SED)
+ sed -f $(REPLACE_VARS_SED) < $< > $@
diff --git a/app-emulation/ganeti/ganeti-2.1.1.ebuild b/app-emulation/ganeti/ganeti-2.1.1.ebuild
new file mode 100644
index 000000000000..989660e85fc8
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.1.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.1.ebuild,v 1.1 2010/03/12 19:21:58 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+MY_PV="${PV/_rc/~rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd +filestorage syslog"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/pyinotify
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-disable-check-man.patch
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ local myconf
+ if use filestorage ; then
+ myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
+ else
+ myconf="--with-file-storage-dir=no"
+ fi
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ $(use_enable syslog) \
+ ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ newconfd "${FILESDIR}"/ganeti.confd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc INSTALL NEWS README doc/*.rst
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
+ docinto examples/hooks
+ dodoc doc/examples/hooks/{ipsec,ethers}
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}
diff --git a/app-emulation/ganeti/metadata.xml b/app-emulation/ganeti/metadata.xml
index 3d6ff6e967aa..563823b64931 100644
--- a/app-emulation/ganeti/metadata.xml
+++ b/app-emulation/ganeti/metadata.xml
@@ -24,6 +24,7 @@
<flag name='kvm'>Enable KVM support</flag>
<flag name='xen'>Enable Xen support</flag>
<flag name='drbd'>Enable DRBD support</flag>
+ <flag name='filestorage'>Enable File Storage</flag>
</use>
</pkgmetadata>