summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-07-01 16:42:02 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-07-01 16:42:02 +0000
commit914f6c7fb79be126d95d71d4c6ff7670608e54ff (patch)
tree621ebe501446cdfbf09b02e0a7fefd3c9ae6bcfd /app-emulation
parentAdd a warning too, bug #514372 (diff)
downloadgentoo-2-914f6c7fb79be126d95d71d4c6ff7670608e54ff.tar.gz
gentoo-2-914f6c7fb79be126d95d71d4c6ff7670608e54ff.tar.bz2
gentoo-2-914f6c7fb79be126d95d71d4c6ff7670608e54ff.zip
Version bump (bug #510844), also make sure that required static-libs are pulled in (bug #476268), do not run auto* anymore (bugs #493112, #514034).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog9
-rw-r--r--app-emulation/spice/files/spice-0.12.5-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch30
-rw-r--r--app-emulation/spice/spice-0.12.5.ebuild79
3 files changed, 117 insertions, 1 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index a38791eb08f0..dbae8da68a7b 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.58 2014/03/31 20:29:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.59 2014/07/01 16:42:02 dev-zero Exp $
+
+*spice-0.12.5 (01 Jul 2014)
+
+ 01 Jul 2014; Tiziano Müller <dev-zero@gentoo.org> +files/spice-0.12.5-fix-asse
+ rt-in-mjpeg_encoder_adjust_params_to_bit_rate.patch, +spice-0.12.5.ebuild:
+ Version bump (bug #510844), also make sure that required static-libs are
+ pulled in (bug #476268), do not run auto* anymore (bugs #493112, #514034).
31 Mar 2014; Michał Górny <mgorny@gentoo.org> spice-0.12.3-r1.ebuild,
spice-0.12.4-r1.ebuild:
diff --git a/app-emulation/spice/files/spice-0.12.5-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch b/app-emulation/spice/files/spice-0.12.5-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch
new file mode 100644
index 000000000000..0ced72887065
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.12.5-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch
@@ -0,0 +1,30 @@
+From 284cca2a5ebc98257275585083321a7100fb89b3 Mon Sep 17 00:00:00 2001
+From: Jonathon Jongsma <jjongsma@redhat.com>
+Date: Fri, 30 May 2014 18:45:02 +0000
+Subject: Fix assert in mjpeg_encoder_adjust_params_to_bit_rate()
+
+If mjpeg_encoder_reset_quality() is called with the same quality as currently
+set, it will not reset last_enc_size but not reset num_recent_enc_frames,
+violating some assumptions in _adjust_params_to_bit_rate(). To avoid aborting
+the server, simply return early from this function.
+
+Resolves: rhbz#1086820
+---
+diff --git a/server/mjpeg_encoder.c b/server/mjpeg_encoder.c
+index f465d88..12447da 100644
+--- a/server/mjpeg_encoder.c
++++ b/server/mjpeg_encoder.c
+@@ -625,7 +625,10 @@ static void mjpeg_encoder_adjust_params_to_bit_rate(MJpegEncoder *encoder)
+ return;
+ }
+
+- spice_assert(rate_control->num_recent_enc_frames);
++ if (!rate_control->num_recent_enc_frames) {
++ spice_debug("No recent encoded frames");
++ return;
++ }
+
+ if (rate_control->num_recent_enc_frames < MJPEG_AVERAGE_SIZE_WINDOW &&
+ rate_control->num_recent_enc_frames < rate_control->fps) {
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-emulation/spice/spice-0.12.5.ebuild b/app-emulation/spice/spice-0.12.5.ebuild
new file mode 100644
index 000000000000..5ccfd2ada8ed
--- /dev/null
+++ b/app-emulation/spice/spice-0.12.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.5.ebuild,v 1.1 2014/07/01 16:42:02 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="client sasl smartcard static-libs" # static
+
+# only the client links against libcacard, the libspice-server only uses the headers
+# the client cannot be built statically since alsa and qemu[smartcard] are missing static-libs
+RDEPEND=">=x11-libs/pixman-0.17.7[static-libs(+)?]
+ >=dev-libs/glib-2.22:2[static-libs(+)?]
+ >=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
+ dev-libs/openssl[static-libs(+)?]
+ virtual/jpeg[static-libs(+)?]
+ sys-libs/zlib[static-libs(+)?]
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
+ client? (
+ media-libs/alsa-lib
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libXinerama-1.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ smartcard? ( app-emulation/qemu[smartcard] )
+ )"
+
+DEPEND="virtual/pkgconfig
+ $(python_gen_any_dep \
+ '>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]')
+ smartcard? ( app-emulation/qemu[smartcard] )
+ ${RDEPEND}"
+
+python_check_deps() {
+ has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
+}
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/0.11.0-gold.patch" \
+ "${FILESDIR}/${P}-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch"
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable client) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ --disable-gui \
+ --disable-static-linkage
+# $(use_enable static static-linkage) \
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}